Bug 283593 - Kontact crashed after save e mail as draft (IMAP)
Summary: Kontact crashed after save e mail as draft (IMAP)
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: libakonadi (show other bugs)
Version: 4.7
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 283293 283680 284505 284842 290184 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-08 10:32 UTC by Manfred
Modified: 2012-01-05 11:33 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.09 KB, text/plain)
2011-11-19 19:25 UTC, Thomas Baag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred 2011-10-08 10:32:21 UTC
Application: kontact (4.7.1)
KDE Platform Version: 4.7.1 (4.7.1) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 2.6.34.10-0.2-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
In the application, Kontact, wrote I a new short e mail.

Identity to an IMAP account; I have a filter that moves messages from this IMAP inbox to local folders.
No recipient specify. 
I had forgotten to specify the subject. 

I wanted to save this e-mail as a draft.
Kontact crashed.
With recipient also crashed.
With subject also crashed.

I do not know, the e mail will be stored in local folders-draft or IMAP account-draft.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2dac710 (LWP 4474))]

Thread 3 (Thread 0xb1b79b70 (LWP 4528)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb4105125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb61dc11c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb5ab7c27 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb4100b25 in start_thread () from /lib/libpthread.so.0
#5  0xb61ce34e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb1250b70 (LWP 4529)):
#0  0xb4104488 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb61dc374 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0xb3fbe9e2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#3  0xb3fbf350 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb3fbf60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb6fb77f7 in QEventDispatcherGlib::processEvents (this=0x8080f30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6f8821d in QEventLoop::processEvents (this=0xb12502e0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6f88449 in QEventLoop::exec (this=0xb12502e0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6e86fb9 in QThread::exec (this=0x80805f8) at thread/qthread.cpp:498
#9  0xb6e8704b in QThread::run (this=0x80805f8) at thread/qthread.cpp:565
#10 0xb6e89c03 in QThreadPrivate::start (arg=0x80805f8) at thread/qthread_unix.cpp:331
#11 0xb4100b25 in start_thread () from /lib/libpthread.so.0
#12 0xb61ce34e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb2dac710 (LWP 4474)):
[KCrash Handler]
#7  QSharedDataPointer (one=..., other=...) at /usr/include/QtCore/qshareddata.h:93
#8  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.7.1/akonadi/entity.cpp:49
#9  0xb46cab67 in Akonadi::Entity::operator= (this=0xbf8a2aec, other=@0x1021) at /usr/src/debug/kdepimlibs-4.7.1/akonadi/entity.cpp:116
#10 0xaf8a8156 in operator= (this=0x8b0e538, job=0x8d36c28) at /usr/include/akonadi/collection.h:76
#11 Message::ComposerViewBase::slotSaveMessage (this=0x8b0e538, job=0x8d36c28) at /usr/src/debug/kdepim-4.7.1/messagecomposer/composerviewbase.cpp:971
#12 0xaf86d695 in Message::ComposerViewBase::qt_metacall (this=0x8b0e538, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf8a2c18)
    at /usr/src/debug/kdepim-4.7.1/build/messagecomposer/moc_composerviewbase.cpp:112
#13 0xb6f8f7dd in QMetaObject::metacall (object=0x8b0e538, cl=QMetaObject::InvokeMetaMethod, idx=17, argv=0xbf8a2c18) at kernel/qmetaobject.cpp:237
#14 0xb6f9fabc in QMetaObject::activate (sender=0x8d36c28, m=0xb739a508, local_signal_index=3, argv=0xbf8a2c18) at kernel/qobject.cpp:3287
#15 0xb71e2135 in KJob::result (this=0x8d36c28, _t1=0x8d36c28) at /usr/src/debug/kdelibs-4.7.1/build/kdecore/kjob.moc:194
#16 0xb71e2188 in KJob::emitResult (this=0x8d36c28) at /usr/src/debug/kdelibs-4.7.1/kdecore/jobs/kjob.cpp:312
#17 0xb46c13ee in Akonadi::JobPrivate::delayedEmitResult (this=0x8c60480) at /usr/src/debug/kdepimlibs-4.7.1/akonadi/job.cpp:144
#18 0xb46f65bf in Akonadi::Job::qt_metacall (this=0x8d36c28, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x8b3fe70) at /usr/src/debug/kdepimlibs-4.7.1/build/akonadi/job.moc:91
#19 0xb4712582 in Akonadi::CollectionFetchJob::qt_metacall (this=0x8d36c28, _c=QMetaObject::InvokeMetaMethod, _id=34, _a=0x8b3fe70)
    at /usr/src/debug/kdepimlibs-4.7.1/build/akonadi/collectionfetchjob.moc:75
#20 0xb6f8f7dd in QMetaObject::metacall (object=0x8d36c28, cl=QMetaObject::InvokeMetaMethod, idx=34, argv=0x8b3fe70) at kernel/qmetaobject.cpp:237
#21 0xb6f9a395 in QMetaCallEvent::placeMetaCall (this=0x8c925d0, object=0x8d36c28) at kernel/qobject.cpp:535
#22 0xb6f9e63f in QObject::event (this=0x8d36c28, e=0x8c925d0) at kernel/qobject.cpp:1226
#23 0xb6496624 in QApplicationPrivate::notify_helper (this=0x80798f0, receiver=0x8d36c28, e=0x8c925d0) at kernel/qapplication.cpp:4481
#24 0xb649f3e7 in QApplication::notify (this=0xbf8a3504, receiver=0x8d36c28, e=0x8c925d0) at kernel/qapplication.cpp:3881
#25 0xb75999e1 in KApplication::notify (this=0xbf8a3504, receiver=0x8d36c28, event=0x8c925d0) at /usr/src/debug/kdelibs-4.7.1/kdeui/kernel/kapplication.cpp:311
#26 0xb6f88f3e in QCoreApplication::notifyInternal (this=0xbf8a3504, receiver=0x8d36c28, event=0x8c925d0) at kernel/qcoreapplication.cpp:787
#27 0xb6f8cccc in sendEvent (receiver=0x0, event_type=0, data=0x8056b20) at kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8056b20) at kernel/qcoreapplication.cpp:1428
#29 0xb6f8ce1c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#30 0xb6fb7624 in sendPostedEvents (s=0x807bb10) at kernel/qcoreapplication.h:220
#31 postEventSourceDispatch (s=0x807bb10) at kernel/qeventdispatcher_glib.cpp:277
#32 0xb3fbeb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb3fbf350 in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb3fbf60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb6fb77ab in QEventDispatcherGlib::processEvents (this=0x80566b8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#36 0xb654d63a in QGuiEventDispatcherGlib::processEvents (this=0x80566b8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#37 0xb6f8821d in QEventLoop::processEvents (this=0xbf8a3464, flags=...) at kernel/qeventloop.cpp:149
#38 0xb6f88449 in QEventLoop::exec (this=0xbf8a3464, flags=...) at kernel/qeventloop.cpp:201
#39 0xb6f8cef0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#40 0xb6494324 in QApplication::exec () at kernel/qapplication.cpp:3755
#41 0x0804b847 in _start ()

This bug may be a duplicate of or related to bug 253150.

Possible duplicates by query: bug 283364, bug 266358, bug 253150.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-10-12 23:22:03 UTC
*** Bug 283293 has been marked as a duplicate of this bug. ***
Comment 2 Christophe Marin 2011-10-21 14:26:37 UTC
*** Bug 284505 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Marin 2011-10-29 14:11:38 UTC
*** Bug 284842 has been marked as a duplicate of this bug. ***
Comment 4 Thomas Baag 2011-11-19 19:25:19 UTC
Created attachment 65847 [details]
New crash information added by DrKonqi

kontact (4.7.2) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:
I tried to save a draft which is stored on imap.

- Custom settings of the application:
System was upgraded often (instead of clean install). Also including upgrades to develpment versions. Configs could be unclean.

-- Backtrace (Reduced):
#6  QSharedDataPointer (o=..., this=0x7fff124d4020) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007f13cf03890e in Akonadi::Entity::operator= (this=0x7fff124d4060, other=<optimized out>) at ../../akonadi/entity.cpp:116
#9  0x00007f13712ea9e5 in operator= (this=0x7fff124d4060) at /usr/include/akonadi/collection.h:75
#10 Message::ComposerViewBase::slotSaveMessage (this=0x19a36d0, job=0x2deeec0) at ../../messagecomposer/composerviewbase.cpp:971
Comment 5 Christophe Marin 2012-01-03 00:38:20 UTC
*** Bug 290184 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Marin 2012-01-03 00:38:46 UTC
*** Bug 283680 has been marked as a duplicate of this bug. ***
Comment 7 David Faure 2012-01-05 11:33:36 UTC

*** This bug has been marked as a duplicate of bug 253031 ***