Bug 290747 - Column view is not available anymore in Dolphin 2.0
Summary: Column view is not available anymore in Dolphin 2.0
Status: RESOLVED DUPLICATE of bug 387455
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: columns mode (show other bugs)
Version: 2.0
Platform: Compiled Sources Linux
: NOR normal with 41 votes (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 102379 184060 191948 205934 227976 256728 259185 260773 265945 267325 267489 268591 269265 269941 274714 274759 276464 276785 277806 281229 282642 285513 291017 291984 296025 333744 colviewreimp 336563 377825 381187 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-05 21:48 UTC by Peter Penz
Modified: 2022-01-12 05:55 UTC (History)
37 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Penz 2012-01-05 21:48:27 UTC
Version:           2.0 (using Devel) 
OS:                Linux

This is a meta-bug to be able to mark all column-view bug-reports as duplicate, so that the reporters can get some background information why the column-view is not available anymore and why it won't be reimplemented in later versions.

For those who are interested about the root-cause of the decision please check my first reply in the comments of http://ppenz.blogspot.com/2012/01/dolphin-20-status-update.html and some replies below. Thanks!



Reproducible: Always

Steps to Reproduce:
-

Actual Results:  
-

Expected Results:  
-
Comment 1 Peter Penz 2012-01-05 21:49:31 UTC
*** Bug 281229 has been marked as a duplicate of this bug. ***
Comment 2 Peter Penz 2012-01-05 21:49:50 UTC
*** Bug 269265 has been marked as a duplicate of this bug. ***
Comment 3 Peter Penz 2012-01-05 21:50:04 UTC
*** Bug 269941 has been marked as a duplicate of this bug. ***
Comment 4 Peter Penz 2012-01-05 21:50:28 UTC
*** Bug 276785 has been marked as a duplicate of this bug. ***
Comment 5 Peter Penz 2012-01-05 21:50:39 UTC
*** Bug 282642 has been marked as a duplicate of this bug. ***
Comment 6 Peter Penz 2012-01-05 21:50:53 UTC
*** Bug 285513 has been marked as a duplicate of this bug. ***
Comment 7 Peter Penz 2012-01-05 21:51:16 UTC
*** Bug 184060 has been marked as a duplicate of this bug. ***
Comment 8 Peter Penz 2012-01-05 21:51:35 UTC
*** Bug 205934 has been marked as a duplicate of this bug. ***
Comment 9 Peter Penz 2012-01-05 21:51:52 UTC
*** Bug 227976 has been marked as a duplicate of this bug. ***
Comment 10 Peter Penz 2012-01-05 21:52:13 UTC
*** Bug 267489 has been marked as a duplicate of this bug. ***
Comment 11 Peter Penz 2012-01-05 21:52:25 UTC
*** Bug 268591 has been marked as a duplicate of this bug. ***
Comment 12 Peter Penz 2012-01-05 21:52:42 UTC
*** Bug 274714 has been marked as a duplicate of this bug. ***
Comment 13 Peter Penz 2012-01-05 21:52:57 UTC
*** Bug 276464 has been marked as a duplicate of this bug. ***
Comment 14 Peter Penz 2012-01-05 21:53:13 UTC
*** Bug 277806 has been marked as a duplicate of this bug. ***
Comment 15 Peter Penz 2012-01-05 21:53:40 UTC
*** Bug 102379 has been marked as a duplicate of this bug. ***
Comment 16 Peter Penz 2012-01-05 21:54:00 UTC
*** Bug 265945 has been marked as a duplicate of this bug. ***
Comment 17 Peter Penz 2012-01-05 21:56:02 UTC
*** Bug 191948 has been marked as a duplicate of this bug. ***
Comment 18 Peter Penz 2012-01-05 21:56:15 UTC
*** Bug 259185 has been marked as a duplicate of this bug. ***
Comment 19 Peter Penz 2012-01-05 21:56:30 UTC
*** Bug 260773 has been marked as a duplicate of this bug. ***
Comment 20 Peter Penz 2012-01-05 21:57:31 UTC
*** Bug 274759 has been marked as a duplicate of this bug. ***
Comment 21 Peter Penz 2012-01-05 21:57:50 UTC
*** Bug 267325 has been marked as a duplicate of this bug. ***
Comment 22 Dotan Cohen 2012-01-05 22:11:44 UTC
Here is the text of Peter's blog post reply referenced in the OP:
"The decision to drop the column view was not easy. I myself liked the column view a lot and used it e.g. for browsing my music collection. However the column view has obviously been used by only very few people but was tricky and timeconsuming to maintain. For a project like Dolphin it is important that patches also can be written by non-core developers, but the column view introduced an internal code complexity that raised the "entry-barrier" for contributors unnecessary (and also made it tricky for us core-developers). In fact there is no big Dolphin team that can take care about maintaining something timeconsuming that is used by only a ratter small group (and I count myself as part of this group). So it was a hard decision but in the end we went for having a maintainable code-base to be able to do the things we offer really right instead of offering things that we are not able to maintain."
Comment 23 quentin.denis 2012-01-06 08:08:54 UTC
Hi Peter, thanks for the feedback, we appreciate. However, I just wanted to let you know my disappointment about the drop of the column-view, I really loved it! The reason I submitted all these bugreports was to make it even better and seamless, but not to make a "problem child" out of it... Anyway, you probably took the best decision and we respect it. Happy new year, best whishes!

-Quentin
Comment 24 Peter Penz 2012-01-06 10:28:01 UTC
Thanks Quentin for your feedback and I'm sorry that you are one of the persons that somehow suffer from my decision :-( I appreciate that you submitted all the bug-reports, without such feedback Dolphin would have a lot more issues. I still hope you'll like the improvements in Dolphin 2.0 and that you'll continue to submit bugs ;-)
Comment 25 ichramm 2012-01-06 13:23:50 UTC
I have to admit that at first I was very angry with this.

I mean: This guy marks my bug as duplicate of a newer bug and then says that column view is over? OMG!... But then I've read the 'why' and everything made sense.

It's a shame, but, as we say here at Uruguay: No hay mal que por bien no venga (every cloud has a silver lining)

Best Regards,
   Juan
Comment 26 S. Burmeister 2012-01-06 13:39:20 UTC
(In reply to comment #25)
> It's a shame, but, as we say here at Uruguay: No hay mal que por bien no venga
> (every cloud has a silver lining)

Indeed. Especially since its bugs and not smooth implementation/behaviour may have caused the lack of users in the first place. OS X users use it a lot.
Comment 27 bisrcacuo 2012-01-06 18:24:47 UTC
I'm also sorry to see the column view go.
As far as I know, Dolphin is the only filemanager other than OS X's Finder with a column view, and I use it almost exclusively.
But I always suspected that it was used by only a small number of people, as UI bugs were slow to be reported and fixed.
However, I respect the decision to remove it, and am very grateful for all the work that the KDE developers and community put into improving KDE.
Comment 28 Dimitrios Glentadakis 2012-01-06 19:08:30 UTC
Yes it is not good news when in KDE we are used to have always advanced technology.
40% workaround: in konqueror we can use the sidebar tree and it is like a column view.
Comment 29 Dimitrios Glentadakis 2012-01-06 19:09:21 UTC
*** Bug 256728 has been marked as a duplicate of this bug. ***
Comment 30 reescf 2012-01-09 04:38:34 UTC
Dolphin's column view was one of two reasons I chose KDE... And I've only just got a machine capable of running it.
Comment 31 Peter Penz 2012-01-09 08:50:30 UTC
*** Bug 291017 has been marked as a duplicate of this bug. ***
Comment 32 tim blechmann 2012-01-16 22:10:01 UTC
too bad ... it was the kde killer app
Comment 33 Peter Penz 2012-01-19 20:00:10 UTC
*** Bug 291984 has been marked as a duplicate of this bug. ***
Comment 34 Janet 2012-01-28 14:55:04 UTC
So my beloved menu which I use instead of the menus provided by KDE and which is based on konqueror in column view mode won't be there anymore after I have updated to KDE SC 4.8? http://www.fotos-hochladen.net/view/konqmenuhme3xtjl4o.jpg
Comment 35 Pulfer 2012-03-04 01:18:31 UTC
Sad news indeed. column-view was the only mode I used in Dolphin. Simply couldn't use any other. So without column-view mode Dolphin becomes useless.

We in Mandriva International Backports will replace dolphin 2 with the old dolphin in our KDE4 4.8 repository. Dolphin 2 will be available as optional package for those who doesn't need column-view (I cannot believe many people don't need it).

Still, I cannot believe such things happened :-/ Dolphin was THE file manager for me.
Comment 36 Pulfer 2012-03-04 04:56:01 UTC
Sorry, I thought Columns grid arrangement in Icons view mode was dropped because few people used it. But now it's called Compact view mode. The only thing I miss is grid spacing settings. Sorry again for my previous comment.
Comment 37 Peter Penz 2012-03-15 08:44:27 UTC
*** Bug 296025 has been marked as a duplicate of this bug. ***
Comment 38 kde 2012-10-14 12:47:24 UTC
(In reply to comment #22)
> Here is the text of Peter's blog post reply referenced in the OP:
> "The decision to drop the column view was not easy. I myself liked the
> column view a lot and used it e.g. for browsing my music collection. However
> the column view has obviously been used by only very few people but was
> tricky and timeconsuming to maintain. For a project like Dolphin it is
> important that patches also can be written by non-core developers, but the
> column view introduced an internal code complexity that raised the
> "entry-barrier" for contributors unnecessary (and also made it tricky for us
> core-developers). In fact there is no big Dolphin team that can take care
> about maintaining something timeconsuming that is used by only a ratter
> small group (and I count myself as part of this group). So it was a hard
> decision but in the end we went for having a maintainable code-base to be
> able to do the things we offer really right instead of offering things that
> we are not able to maintain."

After six years of not using a file manager under Linux at all, dolphin was my first try again and thanks to the column mode I sticked with it. So this was definitely a killer feature for me! Besides all that thanks for the good work.

Although I fully respect your decision, I would still like to give some thoughts on your arguments.

1. Column view is not used by many. How do you know that? Most people I know use the column mode. People with a Mac/NeXTStep background would probably prefer the column mode.

2. Column mode is difficult to maintain. Wouldn't that indicate problems with the code base? View modes should be factored such as to be independent of core code and vice versa. As to the information to be maintained in the core, column view is no different from tree view.

3. Would a patch be accepted bringing back column view?

If you find time to reply, I would appreciate this.

Thanks a lot,

  Stefan
Comment 39 Christoph Feck 2014-04-23 06:49:14 UTC
*** Bug 333744 has been marked as a duplicate of this bug. ***
Comment 40 Frank Reininghaus 2014-04-23 12:51:49 UTC
*** Bug 333744 has been marked as a duplicate of this bug. ***
Comment 41 Frank Reininghaus 2014-05-29 10:18:45 UTC
*** Bug 335479 has been marked as a duplicate of this bug. ***
Comment 42 Frank Reininghaus 2014-06-22 07:16:58 UTC
*** Bug 336563 has been marked as a duplicate of this bug. ***
Comment 43 Nate Graham 2017-03-20 03:43:17 UTC
*** Bug 377825 has been marked as a duplicate of this bug. ***
Comment 44 Nate Graham 2017-09-03 16:09:43 UTC
*** Bug 381187 has been marked as a duplicate of this bug. ***
Comment 45 Nate Graham 2017-09-03 16:13:29 UTC
For everybody who wants this feature back: we understand, and in fact agree with you! Column view is sorely missed. The problem is technical, not ideological. This part of Dolphin was rewritten 5 years ago in such a manner that made Column view unmaintainable/unimplementable. That's not an insurmountable barrier to overcome, but overcome it does need to be if we are to get a new column view. Patches are always welcome!
Comment 46 hiwakurdi 2020-10-03 18:19:17 UTC
I like miller column, unless add it to Dolphin as a plugin (optionally).
Comment 47 Christoph Feck 2020-11-01 14:01:40 UTC
We use a different ticket to track that.

*** This bug has been marked as a duplicate of bug 387455 ***