Bug 267489 - Unintuitive arrow key navigation in dolphin using column view
Summary: Unintuitive arrow key navigation in dolphin using column view
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: columns mode (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-02 18:43 UTC by bisrcacuo
Modified: 2012-01-05 21:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bisrcacuo 2011-03-02 18:43:38 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

When navigating using arrow keys in dolphin using column view, the right and left keys behave unintuitively when navigating within and between columns due to the first item in the newly opened column not being automatically selected.

Reproducible: Always

Steps to Reproduce:
Navigate to the right and left using arrow keys in column view.  This only happens when the directories into which you navigate contain items.

Actual Results:  
When navigating to the right using the right arrow, a new column is opened up but no item in the column list is selected.
If you press right again the first item is automatically selected and navigated into.
If you press down the first item is automatically selected, so to select the second item you have to press down twice.

If you navigate into a non-empty directory using the right arrow but try to leave the directory using the left arrow, the first item in the list will be automatically selected and you must press the left arrow a second time in order to leave the directory.

Expected Results:  
I would expect that when navigating using the right arrow the first item in the newly opened column would automatically be selected, making it clear what directory will be entered when you press the right arrow again, and making the up and down arrows behave intuitively.

When navigating backwards with the left arrow I would expect that only one press of the left arrow would be necessary to leave the active column, instead of two.

This bug has been around since 4.5.
I checked with somebody in #kde-bugs on IRC using an SVN build of 4.5 about a month before 4.6 was released, and they confirmed the behaviour.  I hoped this would be fixed in 4.6 but it was not.
Comment 1 Frank Reininghaus 2011-03-02 20:09:48 UTC
Thanks for the bug report! To fix your problem, the first item should be selected automatically when a new folder is entered. Note that this affects not only the columns view, but all view modes (just enter a new folder and note that pressing any arrow key will select the first item).
Comment 2 Peter Penz 2012-01-05 21:52:13 UTC

*** This bug has been marked as a duplicate of bug 290747 ***