Bug 191948 - inconsistent behaviour of back button in column view
Summary: inconsistent behaviour of back button in column view
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-07 20:56 UTC by Janet
Modified: 2012-01-05 21:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janet 2009-05-07 20:56:53 UTC
Version:            (using KDE 4.2.2)
Installed from:    Ubuntu Packages

When dolphin/konqueror is in columns view mode I'd expect the back button to close the last opened column (if it shouldn't act that way the columns would have close buttons I guess - which BTW wouldn't be that bad). Sometimes it does work that way. I click on a folder in the first column, a second column opens, I click the back button, nothing happens. I click on one of the folders in the second column and a third column opens. I click the back button and the third column vanishes as expected. I open a forth column - I can go back. Only the second column never vanishes. And sometimes it also doesn't work with the third and forth column, that's when I once tried to go back from the second to the first column that way. I seems to lock that function even for further columns until I leave the directory in the first column.
Comment 1 Peter Penz 2009-05-07 23:41:32 UTC
The back button always goes back in history, it does not necessarily close the last opened column (for this you must use the "Go Up" action instead of "Go Back"). If you activate a new column by clicking on it, the URL changes and an entry is added to the history. Do you still see an issue with this behavior or is the explanation sufficient?
Comment 2 Janet 2009-05-24 14:21:55 UTC
Thanks for the explanation. So it should be as follows?

By clicking on a folder I open a new column which adds an entry to the history.
This means, when I use the back button I should just jump back into the last used column, right? No matter if this is the right or left column, right? 
If I want to jump back to the parent column left to the active column I have to use the up key. So far standard behaviour, just in different wrapping. 

And the up key at the same time closes the child column to the right? And the back/forward buttons never close columns?
This I could understand.

But why do the columns sometimes close when I use the back button and sometimes don't? And sometimes when I use the up button and sometimes don't? I cannot see any consistent behaviour for this, I cannot forsee which behaviour one or the other button will produce, for me it is just absolutely confusing. Well, the best is I just don't care if the columns close or not and look straight onto the breadcrumbs above the columns... Because when I go up and the breadcrumbs show that I'm in the most left column there are nonetheless two columns open to the right and the middle one cas the active looking cursor bar in it...
Comment 3 Janet 2009-05-24 14:28:23 UTC
Just forget about the last sentence, I guess I just won't use this mode with the mouse :) The only point is: in which case do the columns close and in which case they don't?
Comment 4 Janet 2009-05-24 14:39:07 UTC
Sorry for this monolog, I thought I got it but I still don't. I thought maybe the columns close the moment a new history entry is created when browsing is changing direction. But this also isn't true, it sometimes closes although the history chain stays intact. 

Maybe to avoid confusion it really should be bound to the used buttons. And the active cursor bar always should be *visible* in the active column (it sometimes just get's visible when I click into the already active column or use the arrow keys from the keyboard)...
Comment 5 Peter Penz 2012-01-05 21:56:02 UTC

*** This bug has been marked as a duplicate of bug 290747 ***