Bug 184060 - Dolphin "loses" columns in columns view when settings are changed
Summary: Dolphin "loses" columns in columns view when settings are changed
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: columns mode (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Unspecified
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-11 22:18 UTC by Panagiotis Papadopoulos
Modified: 2012-01-05 21:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Fixes problem reported here. (2.68 KB, patch)
2011-07-23 14:28 UTC, Tautvydas Andrikys
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Panagiotis Papadopoulos 2009-02-11 22:18:35 UTC
Version:            (using KDE 4.2.0)
Installed from:    Unspecified Linux

If you have 3 columns opened and then decide to enable or disable the tooltips in the settings, dolphin will "lose" the first two columns.

I hope you understand what I mean

thanks
Comment 1 Panagiotis Papadopoulos 2009-10-02 23:54:37 UTC
still valid on a recent kde from trunk
Comment 2 Dario Andres 2009-10-23 02:00:47 UTC
I can confirm this behavior here using:

Qt: 4.6.0 (Qt git branch 4.6 commit 52aef13521af2137db15ee878893f5c5150471e5
        Date:   Mon Oct 12 14:18:51 2009 +1000)
KDE: 4.3.72 (KDE 4.3.72 (KDE 4.4 >= 20091015))
kdelibs svn rev. 1038788 / kdebase svn rev. 1038788
on ArchLinux i686 - Kernel 2.6.30.6

When updating the settings the last expanded folder in the Column view is set as the "main one", and therefore the "column history" (showing the parents folders) are lost/closed.

Tooltips are not the only setting that affects the Columns view, I could confirm this with other general settings.
Comment 3 Mark 2010-10-13 01:49:03 UTC
Confirmed on current trunk (KDE 4.6 dev cycle) although with a different result.
Here are my steps to reproduce this.

1. Change view to column view
2. open a few folders so you have a few columns open
3. now go to the dolphin settings and enable tooltips

Now your thrown back into "Detail view" mode with the column that had focus.
I can't imagine that this is intended ^_-
Comment 4 Tautvydas Andrikys 2011-07-23 14:28:31 UTC
Created attachment 62119 [details]
Fixes problem reported here. 

This patch also fixes one more problem semi related to this bug: after applying settings sometimes view mode would reset to directory default(if active directory would have such).
Comment 5 Peter Penz 2012-01-05 21:51:16 UTC

*** This bug has been marked as a duplicate of bug 290747 ***