Bug 267325 - Dolphin crashes when browsing in column mode and a parent folder is renamed
Summary: Dolphin crashes when browsing in column mode and a parent folder is renamed
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2011-02-28 18:22 UTC by ichramm
Modified: 2012-01-05 21:57 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.62 KB, text/plain)
2011-06-15 18:30 UTC, mart1.denni
Details
New crash information added by DrKonqi (3.97 KB, text/plain)
2011-08-06 18:31 UTC, Chantal HUPE
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ichramm 2011-02-28 18:22:26 UTC
Application: dolphin (1.6)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

1- Open dolphin
2- Browse some folders in column mode
3- Rename a folder someway in the path (at leat one subfolder must be visible)
4- Click a subfolder
	- Note that when renaming a folder, the columnscorresponding to the child folders are not updated or removed.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6376e64760 (LWP 4954))]

Thread 4 (Thread 0x7f63632d8700 (LWP 4955)):
#0  0x00007f6372a306fe in QElapsedTimer::isMonotonic () at tools/qelapsedtimer_unix.cpp:76
#1  0x00007f6372afd1b6 in QTimerInfoList::repairTimersIfNeeded (this=0x7f635c000910) at kernel/qeventdispatcher_unix.cpp:395
#2  0x00007f6372afd246 in QTimerInfoList::timerWait (this=0x7f635c000910, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#3  0x00007f6372afb3dd in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f63632d7c1c) at kernel/qeventdispatcher_glib.cpp:136
#4  0x00007f6372afb485 in timerSourcePrepare (source=0x7f635c000910, timeout=0x7f63632d7ae0) at kernel/qeventdispatcher_glib.cpp:169
#5  0x00007f636ee3ba11 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#6  0x00007f636ee3be78 in ?? () from /lib/libglib-2.0.so.0
#7  0x00007f636ee3c45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#8  0x00007f6372afb1e6 in QEventDispatcherGlib::processEvents (this=0x1c606e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#9  0x00007f6372acda02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#10 0x00007f6372acddec in QEventLoop::exec (this=0x7f63632d7db0, flags=) at kernel/qeventloop.cpp:201
#11 0x00007f63729d82fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#12 0x00007f6372aad5f8 in QInotifyFileSystemWatcherEngine::run (this=0x1c10af0) at io/qfilesystemwatcher_inotify.cpp:248
#13 0x00007f63729db27e in QThreadPrivate::start (arg=0x1c10af0) at thread/qthread_unix.cpp:266
#14 0x00007f636f2fa971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#15 0x00007f637677492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#16 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f63609f6700 (LWP 4961)):
#0  0x00007f6376768203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f636ee3c009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f636ee3c45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f6372afb1e6 in QEventDispatcherGlib::processEvents (this=0x20b0d30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f6372acda02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f6372acddec in QEventLoop::exec (this=0x7f63609f5db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f63729d82fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f6372aad5f8 in QInotifyFileSystemWatcherEngine::run (this=0x1bfad50) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f63729db27e in QThreadPrivate::start (arg=0x1bfad50) at thread/qthread_unix.cpp:266
#9  0x00007f636f2fa971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f637677492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6355b67700 (LWP 5502)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007f6354eb40d1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f636f2fa971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f637677492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6376e64760 (LWP 4954)):
[KCrash Handler]
#6  0x00007f63734fb3c4 in QWidget::style (this=0x2b9af60) at kernel/qwidget.cpp:2577
#7  0x00007f6373a0aec9 in QAbstractItemView::mouseReleaseEvent (this=0x2b9af60, event=<value optimized out>) at itemviews/qabstractitemview.cpp:1795
#8  0x00007f6375ad50e4 in DolphinTreeView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libdolphinprivate.so.4
#9  0x00007f637350704e in QWidget::event (this=0x2b9af60, event=0x7fff901575e0) at kernel/qwidget.cpp:8187
#10 0x00007f63738d25e6 in QFrame::event (this=0x2b9af60, e=0x7fff901575e0) at widgets/qframe.cpp:557
#11 0x00007f6373a0ba8b in QAbstractItemView::viewportEvent (this=0x2b9af60, event=0x7fff901575e0) at itemviews/qabstractitemview.cpp:1619
#12 0x00007f6373a49d65 in QTreeView::viewportEvent (this=0x2b9af60, event=0x7fff901575e0) at itemviews/qtreeview.cpp:1256
#13 0x00007f6372ace507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x2ca60f0, event=0x7fff901575e0) at kernel/qcoreapplication.cpp:847
#14 0x00007f63734b0fac in QApplicationPrivate::notify_helper (this=0x1b3d670, receiver=0x2ca60f0, e=0x7fff901575e0) at kernel/qapplication.cpp:4392
#15 0x00007f63734b730e in QApplication::notify (this=0x7fff901582f0, receiver=0x2ca60f0, e=0x7fff901575e0) at kernel/qapplication.cpp:3959
#16 0x00007f6374240a36 in KApplication::notify (this=0x7fff901582f0, receiver=0x2ca60f0, event=0x7fff901575e0) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f6372acecdc in QCoreApplication::notifyInternal (this=0x7fff901582f0, receiver=0x2ca60f0, event=0x7fff901575e0) at kernel/qcoreapplication.cpp:732
#18 0x00007f63734b5dbe in sendEvent (receiver=0x2ca60f0, event=0x7fff901575e0, alienWidget=0x2ca60f0, nativeWidget=0x2928420, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QApplicationPrivate::sendMouseEvent (receiver=0x2ca60f0, event=0x7fff901575e0, alienWidget=0x2ca60f0, nativeWidget=0x2928420, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#20 0x00007f6373539345 in QETWidget::translateMouseEvent (this=0x2928420, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#21 0x00007f6373537c5c in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff90157f00) at kernel/qapplication_x11.cpp:3536
#22 0x00007f63735640e2 in x11EventSourceDispatch (s=0x1b3b060, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#23 0x00007f636ee38342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007f636ee3c2a8 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007f636ee3c45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007f6372afb193 in QEventDispatcherGlib::processEvents (this=0x1b0fe60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#27 0x00007f6373563a4e in QGuiEventDispatcherGlib::processEvents (this=0x2b9af60, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f6372acda02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007f6372acddec in QEventLoop::exec (this=0x7fff90158230, flags=) at kernel/qeventloop.cpp:201
#30 0x00007f6372ad1ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#31 0x00007f6376a57e7f in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#32 0x00007f63766acd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff90158808) at libc-start.c:226
#33 0x0000000000400659 in _start ()

Reported using DrKonqi
Comment 1 Aguirre Carlos Federico 2011-03-01 02:36:27 UTC
I can reproduce the bug here using 

Application: dolphin (1.6)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-gentoo x86_64
Distribution: "Gentoo Base System release 2.0.1-r1"
Comment 2 mart1.denni 2011-06-15 18:30:40 UTC
Created attachment 61025 [details]
New crash information added by DrKonqi

dolphin (1.6.1) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
I renamed a parent folder and clicked on a subfolder then dolpin crashed.

- Custom settings of the application:
Using in column mode.

-- Backtrace (Reduced):
#6  0x00007f6630db0ce4 in QWidget::style() const () from /usr/lib/libQtGui.so.4
#7  0x00007f6631285f16 in QAbstractItemView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#8  0x00007f66332da78c in DolphinTreeView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libdolphinprivate.so.4
#9  0x00007f6630dc1cb8 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#10 0x00007f6631171a66 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
Comment 3 Chantal HUPE 2011-08-06 18:31:34 UTC
Created attachment 62623 [details]
New crash information added by DrKonqi

dolphin (1.7) on KDE Platform 4.7.00 (4.7.0) using Qt 4.7.3

- What I was doing when the application crashed:
I cliked on a subfolder of one I had just renamed.

- Custom settings of the application:
I'm using the multiple-columns mode.

-- Backtrace (Reduced):
#6  0x00007f8c8b23c910 in QWidget::style() const () from /usr/lib/libQtGui.so.4
#7  0x00007f8c8b700a76 in QAbstractItemView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#8  0x00007f8c7b435459 in DolphinTreeView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libdolphinprivate.so.4
#9  0x00007f8c8b24d6a0 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#10 0x00007f8c8b5edba6 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
Comment 4 Peter Penz 2012-01-05 21:57:50 UTC

*** This bug has been marked as a duplicate of bug 290747 ***