Bug 227976 - inline rename will not scroll text if whole text field is not visible (column view)
Summary: inline rename will not scroll text if whole text field is not visible (column...
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: columns mode (show other bugs)
Version: 16.12.2
Platform: OpenSUSE Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2010-02-21 21:26 UTC by George
Modified: 2012-01-05 21:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The screenshot (43.93 KB, image/png)
2010-08-02 12:34 UTC, Jaime Torres
Details

Note You need to log in before you can comment on or make changes to this bug.
Description George 2010-02-21 21:26:54 UTC
Version:            (using KDE 4.4.0)
Installed from:    openSUSE RPMs

When renaming using inline rename, text is not scrolled if the text is longer than the available width for rendering so that the caret and the text next to it is visible, thus making it impossible to know where the caret is and which caracter will be deleted hitting del or backspace.

One way to reproduce in case I did not explain it correctly:
Enable inline rename.
Enable column view.
Make a file whose name is wider than the width of the column.
Rename the file and observe that the letters beyond the length of the column are not visible and cannot be made visible.

This bug was introduced in KDE SC 4.4, before that text was split in multiple lines which were scrollable.
Comment 1 Jaime Torres 2010-08-02 12:33:29 UTC
I've reproduced the error in my test Vbox. When I move into the text editing box, I have no scroll to see the hidden chars. See the attached screen shot.
Comment 2 Jaime Torres 2010-08-02 12:34:11 UTC
Created attachment 49750 [details]
The screenshot
Comment 3 FiNeX 2010-08-29 22:21:16 UTC
Confirmed the bug in KDE 4.5 renaming a file inline with column view.
Comment 4 Frank Reininghaus 2010-09-09 00:01:10 UTC
I can also reproduce this in Details View.
Comment 5 Peter Penz 2012-01-05 21:51:52 UTC

*** This bug has been marked as a duplicate of bug 290747 ***