Bug 274714 - Crash when changing settings, while using Column view
Summary: Crash when changing settings, while using Column view
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: columns mode (show other bugs)
Version: 16.12.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2011-06-02 00:29 UTC by Matthias Fuchs
Modified: 2012-01-05 21:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.42 KB, text/plain)
2011-06-05 14:08 UTC, zeton88admn3310
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Fuchs 2011-06-02 00:29:54 UTC
Application: dolphin (1.6.9)
KDE Platform Version: 4.6.80 (4.7 Beta1) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.38-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
Reproduce:
1. start dolphin
2. choose column view
3. open at least two additional columns (three in total)
4. last column is activated
5. go to dolphin settings and press ok


This crash can only be reproduced in the devel version of dolphin, since the assert at dolphinview.cpp:1262 fails.

Related to BUG: 184060
In release mode, thus without the assert, what happens is described in BUG:184060

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
[Current thread is 1 (Thread 0x7fd01b0bd760 (LWP 5357))]

Thread 2 (Thread 0x7fd007f19700 (LWP 5359)):
#0  0x00007fd01527c933 in poll () from /lib/libc.so.6
#1  0x00007fd0113cec04 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007fd0113cf139 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007fd01881adb8 in QEventDispatcherGlib::processEvents (this=0x7fd0000008b0, flags=...) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:417
#4  0x00007fd0187e021c in QEventLoop::processEvents (this=0x7fd007f18d90, flags=...) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#5  0x00007fd0187e0370 in QEventLoop::exec (this=0x7fd007f18d90, flags=...) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qeventloop.cpp:201
#6  0x00007fd0186c54ec in QThread::exec (this=0x1d9b2b0) at /home/mat-not/kde/src/qt-copy/src/corelib/thread/qthread.cpp:490
#7  0x00007fd0187bf6eb in QInotifyFileSystemWatcherEngine::run (this=0x1d9b2b0) at /home/mat-not/kde/src/qt-copy/src/corelib/io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd0186c7c82 in QThreadPrivate::start (arg=0x1d9b2b0) at /home/mat-not/kde/src/qt-copy/src/corelib/thread/qthread_unix.cpp:285
#9  0x00007fd018416d40 in start_thread () from /lib/libpthread.so.0
#10 0x00007fd015284aed in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd01b0bd760 (LWP 5357)):
[KCrash Handler]
#6  0x00007fd0151e7705 in raise () from /lib/libc.so.6
#7  0x00007fd0151e8b7b in abort () from /lib/libc.so.6
#8  0x00007fd0186bce2b in qt_message_output (msgType=QtFatalMsg, buf=0x228fe38 "ASSERT: \"!m_dolphinViewController->itemView() || (m_dolphinViewController->itemView() == view)\" in file /home/mat-not/kde/src/kde-baseapps/dolphin/src/views/dolphinview.cpp, line 1262") at /home/mat-not/kde/src/qt-copy/src/corelib/global/qglobal.cpp:2282
#9  0x00007fd0186bcf9e in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7fd018861728 "ASSERT: \"%s\" in file %s, line %d", ap=0x7fff51a1f708) at /home/mat-not/kde/src/qt-copy/src/corelib/global/qglobal.cpp:2328
#10 0x00007fd0186bd72e in qFatal (msg=0x7fd018861728 "ASSERT: \"%s\" in file %s, line %d") at /home/mat-not/kde/src/qt-copy/src/corelib/global/qglobal.cpp:2511
#11 0x00007fd0186bc9f0 in qt_assert (assertion=0x7fd01a7d47a0 "!m_dolphinViewController->itemView() || (m_dolphinViewController->itemView() == view)", file=0x7fd01a7d42d8 "/home/mat-not/kde/src/kde-baseapps/dolphin/src/views/dolphinview.cpp", line=1262) at /home/mat-not/kde/src/qt-copy/src/corelib/global/qglobal.cpp:2027
#12 0x00007fd01a79880f in DolphinView::deleteView (this=0x1e4c6d0) at /home/mat-not/kde/src/kde-baseapps/dolphin/src/views/dolphinview.cpp:1262
#13 0x00007fd01a7985e9 in DolphinView::createView (this=0x1e4c6d0) at /home/mat-not/kde/src/kde-baseapps/dolphin/src/views/dolphinview.cpp:1237
#14 0x00007fd01a794fa7 in DolphinView::refresh (this=0x1e4c6d0) at /home/mat-not/kde/src/kde-baseapps/dolphin/src/views/dolphinview.cpp:436
#15 0x00007fd01aca0586 in DolphinViewContainer::refresh (this=0x1e2a5a0) at /home/mat-not/kde/src/kde-baseapps/dolphin/src/dolphinviewcontainer.cpp:232
#16 0x00007fd01ac9839e in DolphinMainWindow::refreshViews (this=0x1d2bdb0) at /home/mat-not/kde/src/kde-baseapps/dolphin/src/dolphinmainwindow.cpp:2055
#17 0x00007fd01ac99bc5 in DolphinMainWindow::qt_metacall (this=0x1d2bdb0, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x7fff51a1fa50) at /home/mat-not/kde/build/kde-baseapps/dolphin/src/dolphinmainwindow.moc:216
#18 0x00007fd0187ea6ae in QMetaObject::metacall (object=0x1d2bdb0, cl=QMetaObject::InvokeMetaMethod, idx=53, argv=0x7fff51a1fa50) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qmetaobject.cpp:237
#19 0x00007fd0187ff1ca in QMetaObject::activate (sender=0x23ce720, m=0x7fd01aefb740, local_signal_index=0, argv=0x0) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qobject.cpp:3280
#20 0x00007fd01acbc69d in DolphinSettingsDialog::settingsChanged (this=0x23ce720) at /home/mat-not/kde/build/kde-baseapps/dolphin/src/dolphinsettingsdialog.moc:91
#21 0x00007fd01acbc411 in DolphinSettingsDialog::applySettings (this=0x23ce720) at /home/mat-not/kde/src/kde-baseapps/dolphin/src/settings/dolphinsettingsdialog.cpp:133
#22 0x00007fd01acbc2ef in DolphinSettingsDialog::slotButtonClicked (this=0x23ce720, button=4) at /home/mat-not/kde/src/kde-baseapps/dolphin/src/settings/dolphinsettingsdialog.cpp:114
#23 0x00007fd019508837 in KDialog::qt_metacall (this=0x23ce720, _c=QMetaObject::InvokeMetaMethod, _id=33, _a=0x7fff51a1fd20) at /home/mat-not/kde/build/kdelibs/kdeui/kdialog.moc:190
#24 0x00007fd019606a94 in KPageDialog::qt_metacall (this=0x23ce720, _c=QMetaObject::InvokeMetaMethod, _id=69, _a=0x7fff51a1fd20) at /home/mat-not/kde/build/kdelibs/kdeui/kpagedialog.moc:70
#25 0x00007fd01acbc600 in DolphinSettingsDialog::qt_metacall (this=0x23ce720, _c=QMetaObject::InvokeMetaMethod, _id=69, _a=0x7fff51a1fd20) at /home/mat-not/kde/build/kde-baseapps/dolphin/src/dolphinsettingsdialog.moc:73
#26 0x00007fd0187ea6ae in QMetaObject::metacall (object=0x23ce720, cl=QMetaObject::InvokeMetaMethod, idx=69, argv=0x7fff51a1fd20) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qmetaobject.cpp:237
#27 0x00007fd0187ff1ca in QMetaObject::activate (sender=0x241f450, m=0x7fd018b687e0, local_signal_index=0, argv=0x7fff51a1fd20) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qobject.cpp:3280
#28 0x00007fd018804dc0 in QSignalMapper::mapped (this=0x241f450, _t1=4) at .moc/debug-shared/moc_qsignalmapper.cpp:101
#29 0x00007fd018804a95 in QSignalMapper::map (this=0x241f450, sender=0x23cf400) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qsignalmapper.cpp:266
#30 0x00007fd018804a2a in QSignalMapper::map (this=0x241f450) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qsignalmapper.cpp:257
#31 0x00007fd018804d3a in QSignalMapper::qt_metacall (this=0x241f450, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff51a1fee0) at .moc/debug-shared/moc_qsignalmapper.cpp:87
#32 0x00007fd0187ea6ae in QMetaObject::metacall (object=0x241f450, cl=QMetaObject::InvokeMetaMethod, idx=8, argv=0x7fff51a1fee0) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qmetaobject.cpp:237
#33 0x00007fd0187ff1ca in QMetaObject::activate (sender=0x23cf400, m=0x7fd018152900, local_signal_index=2, argv=0x7fff51a1fee0) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qobject.cpp:3280
#34 0x00007fd017c1b9ee in QAbstractButton::clicked (this=0x23cf400, _t1=false) at .moc/debug-shared/moc_qabstractbutton.cpp:206
#35 0x00007fd0178ae13a in QAbstractButtonPrivate::emitClicked (this=0x242eb30) at /home/mat-not/kde/src/qt-copy/src/gui/widgets/qabstractbutton.cpp:546
#36 0x00007fd0178ae0b9 in QAbstractButtonPrivate::click (this=0x242eb30) at /home/mat-not/kde/src/qt-copy/src/gui/widgets/qabstractbutton.cpp:539
#37 0x00007fd0178af57f in QAbstractButton::mouseReleaseEvent (this=0x23cf400, e=0x7fff51a20cd0) at /home/mat-not/kde/src/qt-copy/src/gui/widgets/qabstractbutton.cpp:1121
#38 0x00007fd01745af52 in QWidget::event (this=0x23cf400, event=0x7fff51a20cd0) at /home/mat-not/kde/src/qt-copy/src/gui/kernel/qwidget.cpp:8200
#39 0x00007fd0178af3d5 in QAbstractButton::event (this=0x23cf400, e=0x7fff51a20cd0) at /home/mat-not/kde/src/qt-copy/src/gui/widgets/qabstractbutton.cpp:1080
#40 0x00007fd017970baf in QPushButton::event (this=0x23cf400, e=0x7fff51a20cd0) at /home/mat-not/kde/src/qt-copy/src/gui/widgets/qpushbutton.cpp:683
#41 0x00007fd0173f5732 in QApplicationPrivate::notify_helper (this=0x1c181d0, receiver=0x23cf400, e=0x7fff51a20cd0) at /home/mat-not/kde/src/qt-copy/src/gui/kernel/qapplication.cpp:4445
#42 0x00007fd0173f36d2 in QApplication::notify (this=0x7fff51a21ad0, receiver=0x23cf400, e=0x7fff51a20cd0) at /home/mat-not/kde/src/qt-copy/src/gui/kernel/qapplication.cpp:4006
#43 0x00007fd0195c96db in KApplication::notify (this=0x7fff51a21ad0, receiver=0x23cf400, event=0x7fff51a20cd0) at /home/mat-not/kde/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#44 0x00007fd0187e2656 in QCoreApplication::notifyInternal (this=0x7fff51a21ad0, receiver=0x23cf400, event=0x7fff51a20cd0) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qcoreapplication.cpp:732
#45 0x00007fd0173f7ec9 in QCoreApplication::sendSpontaneousEvent (receiver=0x23cf400, event=0x7fff51a20cd0) at ../../include/QtCore/../../../../src/qt-copy/src/corelib/kernel/qcoreapplication.h:218
#46 0x00007fd0173f1c7a in QApplicationPrivate::sendMouseEvent (receiver=0x23cf400, event=0x7fff51a20cd0, alienWidget=0x23cf400, nativeWidget=0x23ce720, buttonDown=0x7fd018173c48, lastMouseReceiver=..., spontaneous=true) at /home/mat-not/kde/src/qt-copy/src/gui/kernel/qapplication.cpp:3103
#47 0x00007fd01749537b in QETWidget::translateMouseEvent (this=0x23ce720, event=0x7fff51a216b0) at /home/mat-not/kde/src/qt-copy/src/gui/kernel/qapplication_x11.cpp:4438
#48 0x00007fd017491d9e in QApplication::x11ProcessEvent (this=0x7fff51a21ad0, event=0x7fff51a216b0) at /home/mat-not/kde/src/qt-copy/src/gui/kernel/qapplication_x11.cpp:3442
#49 0x00007fd0174cb66c in x11EventSourceDispatch (s=0x1c1ba70, callback=0, user_data=0x0) at /home/mat-not/kde/src/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:146
#50 0x00007fd0113ce6cd in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#51 0x00007fd0113ceea8 in ?? () from /usr/lib/libglib-2.0.so.0
#52 0x00007fd0113cf139 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#53 0x00007fd01881ad95 in QEventDispatcherGlib::processEvents (this=0x1bd56e0, flags=...) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:415
#54 0x00007fd0174cba0c in QGuiEventDispatcherGlib::processEvents (this=0x1bd56e0, flags=...) at /home/mat-not/kde/src/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#55 0x00007fd0187e021c in QEventLoop::processEvents (this=0x7fff51a21a40, flags=...) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#56 0x00007fd0187e0370 in QEventLoop::exec (this=0x7fff51a21a40, flags=...) at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qeventloop.cpp:201
#57 0x00007fd0187e2d48 in QCoreApplication::exec () at /home/mat-not/kde/src/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1009
#58 0x00007fd0173f28e6 in QApplication::exec () at /home/mat-not/kde/src/qt-copy/src/gui/kernel/qapplication.cpp:3719
#59 0x00007fd01aca857a in kdemain (argc=1, argv=0x7fff51a21fc8) at /home/mat-not/kde/src/kde-baseapps/dolphin/src/main.cpp:85
#60 0x0000000000400916 in main (argc=1, argv=0x7fff51a21fc8) at /home/mat-not/kde/build/kde-baseapps/dolphin/src/dolphin_dummy.cpp:3

Reported using DrKonqi
Comment 1 zeton88admn3310 2011-06-05 14:08:24 UTC
Created attachment 60659 [details]
New crash information added by DrKonqi

dolphin (1.6) on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed:

1. open removable hdd in new tab.
2. split folder view.
3. move to another directory in right view.
4. copy filename(including CJK code) in right view.
5. crash.

Enviroment:
    LANG=ja_JP.UTF-8

-- Backtrace (Reduced):
#8  0xb63a8dbb in QApplication::x11ProcessEvent (this=0xbfb35540, event=0xbfb351dc) at kernel/qapplication_x11.cpp:3344
#9  0xb63d4960 in x11EventSourceDispatch (s=0x80e61f8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
[...]
#13 0xb6e4076b in QEventDispatcherGlib::processEvents (this=0x80cf0c8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#14 0xb63d455a in QGuiEventDispatcherGlib::processEvents (this=0x80cf0c8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#15 0xb6e112bd in QEventLoop::processEvents (this=0xbfb35494, flags=...) at kernel/qeventloop.cpp:149
Comment 2 Peter Penz 2012-01-05 21:52:42 UTC

*** This bug has been marked as a duplicate of bug 290747 ***