Bug 269265 - F15 dolphin does not show the correct directories for "columns view mode" in certain situations
Summary: F15 dolphin does not show the correct directories for "columns view mode" in...
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: columns mode (show other bugs)
Version: 16.12.2
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-23 21:32 UTC by Reartes Guillermo
Modified: 2012-01-05 21:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reartes Guillermo 2011-03-23 21:32:42 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

Sometimes, when clicking a filesystem in dolphin results in the wrong directories displayed. (and potentially used)

I think is releated to selecting "columns view mode" for a filesystem, then
switching back and forth another in another mode. 
it does not allwatys happend the same.
If all (data0,1 & 3) are in the same mode, all is allways ok, i think.

filesystems & folders (these are mounted by fstab a boot)

data0 /data0   
        /0one
        /0two

data1 /data1
        /1one
        /1two
        /1thre

data3 /data3
        /3one

#1
Details view mode for all (data0,1,3)
click data1 shows data1 directories
click data0 shows data0 directories
click data3 shows data3 directories
[OK]


#2
click data0 > data0 directories are displayed > ok > choose "columns view mode" > ok

click data1 > data1 directories are dispalyed > ok > click data0 > data0 shows data0 > ok

click data3 > data3 shows directories from data0 > BAD
click data0 > data0 shows data0 > ok
click data1 > shows data0 directories > BAD


Reproducible: Always

Steps to Reproduce:
click data0 > data0 directories are displayed > ok > choose "columns view mode" > ok
click data1 > data1 directories are dispalyed > ok > click data0 > data0 shows data0 > ok
click data3 > data3 shows directories from data0 > BAD
click data0 > data0 shows data0 > ok
click data1 > shows data0 directories > BAD

note: it is reproducible, but it may not be in the same way i described.

Actual Results:  
clicking another filesystem shows the directories of another, can open files in the root of the filesystem. 

Expected Results:  
display the actual filesystem directories
Comment 1 Reartes Guillermo 2011-06-03 18:59:09 UTC
I could not reproduce it with 4.6.3 (Fedora 15, Release)
Comment 2 Peter Penz 2012-01-05 21:49:50 UTC

*** This bug has been marked as a duplicate of bug 290747 ***