Bug 205934 - In column view when renaiming the parent directory of an open directory the opened directory is not refreshed
Summary: In column view when renaiming the parent directory of an open directory the o...
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: columns mode (show other bugs)
Version: 16.12.2
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-02 00:03 UTC by George
Modified: 2012-01-05 21:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description George 2009-09-02 00:03:25 UTC
Version:            (using KDE 4.3.0)
OS:                Linux
Installed from:    SuSE RPMs

The below is tested only in column view (it might also be applicable in spit pane or in multiple tabs, but it is not tested, or it might not be considered a bug in these cases).
When renaming the parent directory of a directory that you already see the contents of, the child directory does not refresh, so that the navigation bar changes the displayed path, nor to avoid an error that occurs when refreshing manually.
e.g. I view /home/username/folder1/folder2. Which in column view I can be able to see the contents of username, folder1 and folder2 simultaneously. Renaming folder1 to e.g. folder_1 will not change the navigation bar path when selecting again folder2's column to the new (and valid one /home/username/folder_1/folder2). This has also as consequence when refreshing manually to display an error at the bottom and disappear the content of folder2 (it is logical since /home/username/folder1/folder2 no longer exists).
But if, after the rename, without refreshing or reopening folder2, I change the name of a file in folder2, it will not have any errors nor create any other problems (e.g file does not exist, or rename did not happen).
Comment 1 Thomas R. 2009-11-03 21:11:03 UTC
I can confirm this bug, I have to refresh manually in column view, for example in this case:

1. Open a folder with dolphin in column view.
2. Select one or multiple files and choose to compress them by context menu.
3. You will not see the resulting compressed file until you hit refresh.
Comment 2 Peter Penz 2012-01-05 21:51:35 UTC

*** This bug has been marked as a duplicate of bug 290747 ***