Bug 296025 - Dolphin closed after drag and drop /media/ from the column at the left to the same column.
Summary: Dolphin closed after drag and drop /media/ from the column at the left to the...
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 1.6.1
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 23:45 UTC by Aymeric RICHARD
Modified: 2012-03-15 08:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aymeric RICHARD 2012-03-14 23:45:13 UTC
Application: dolphin (1.6.1)
KDE Platform Version: 4.6.5 (4.6.5) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-13-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

Dolphin closed after drag and drop /media/ from the column at the left to the same column.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fcc354c2780 (LWP 28601))]

Thread 3 (Thread 0x7fcc21560700 (LWP 28605)):
#0  0x00007fcc2da1b3c4 in __pthread_mutex_lock (mutex=0x2603938) at pthread_mutex_lock.c:61
#1  0x00007fcc2d54b669 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcc2d54cf21 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcc2d54d639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcc31235446 in QEventDispatcherGlib::processEvents (this=0x25c0220, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fcc31209882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fcc31209abc in QEventLoop::exec (this=0x7fcc2155fdd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fcc31120924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007fcc311ebc2f in QInotifyFileSystemWatcherEngine::run (this=0x2613420) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fcc31123175 in QThreadPrivate::start (arg=0x2613420) at thread/qthread_unix.cpp:320
#10 0x00007fcc2da18d8c in start_thread (arg=0x7fcc21560700) at pthread_create.c:304
#11 0x00007fcc34dc3c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fcc1ad60700 (LWP 28609)):
#0  0x00007fcc34db6ae3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fcc2d54d104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcc2d54d639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcc31235446 in QEventDispatcherGlib::processEvents (this=0x2990ff0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fcc31209882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fcc31209abc in QEventLoop::exec (this=0x7fcc1ad5fdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fcc31120924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fcc311ebc2f in QInotifyFileSystemWatcherEngine::run (this=0x295bae0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fcc31123175 in QThreadPrivate::start (arg=0x295bae0) at thread/qthread_unix.cpp:320
#9  0x00007fcc2da18d8c in start_thread (arg=0x7fcc1ad60700) at pthread_create.c:304
#10 0x00007fcc34dc3c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcc354c2780 (LWP 28601)):
[KCrash Handler]
#6  QDragManager::move (this=0x2d8cbf0, globalPos=...) at kernel/qdnd_x11.cpp:1658
#7  0x00007fcc31c5a2c9 in QDragManager::eventFilter (this=0x2d8cbf0, o=<value optimized out>, e=<value optimized out>) at kernel/qdnd_x11.cpp:1306
#8  0x00007fcc31bcf734 in QApplication::notify (this=<value optimized out>, receiver=0x2b32740, e=0x7fff4d78faa0) at kernel/qapplication.cpp:4017
#9  0x00007fcc328ed6c6 in KApplication::notify (this=0x7fff4d792490, receiver=0x2b32740, event=0x7fff4d78faa0) at ../../kdeui/kernel/kapplication.cpp:311
#10 0x00007fcc3120a49c in QCoreApplication::notifyInternal (this=0x7fff4d792490, receiver=0x2b32740, event=0x7fff4d78faa0) at kernel/qcoreapplication.cpp:731
#11 0x00007fcc31bcaa1d in sendEvent (receiver=0x2b32740, event=0x7fff4d78faa0, alienWidget=0x299f0c0, nativeWidget=0x25847c0, buttonDown=0x7fcc326ad218, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#12 QApplicationPrivate::sendMouseEvent (receiver=0x2b32740, event=0x7fff4d78faa0, alienWidget=0x299f0c0, nativeWidget=0x25847c0, buttonDown=0x7fcc326ad218, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3122
#13 0x00007fcc31c4c190 in QETWidget::translateMouseEvent (this=0x25847c0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4558
#14 0x00007fcc31c4aab7 in QApplication::x11ProcessEvent (this=0x7fff4d792490, event=0x7fff4d7903f0) at kernel/qapplication_x11.cpp:3680
#15 0x00007fcc31c73842 in x11EventSourceDispatch (s=0x24e1c60, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#16 0x00007fcc2d54cbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007fcc2d54d3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007fcc2d54d639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fcc312353ef in QEventDispatcherGlib::processEvents (this=0x2490db0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#20 0x00007fcc31c734de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#21 0x00007fcc31209882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007fcc31209abc in QEventLoop::exec (this=0x2b2ae90, flags=...) at kernel/qeventloop.cpp:201
#23 0x00007fcc31c59fd4 in QDragManager::drag (this=0x2d8cbf0, o=<value optimized out>) at kernel/qdnd_x11.cpp:1981
#24 0x00007fcc31bdb898 in QDrag::exec (this=0x2b0a700, supportedActions=..., defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:284
#25 0x00007fcc320e7faf in QAbstractItemView::startDrag (this=0x294cc60, supportedActions=...) at itemviews/qabstractitemview.cpp:3448
#26 0x00007fcc320fac4b in QListView::startDrag (this=0x294cc60, supportedActions=...) at itemviews/qlistview.cpp:890
#27 0x00007fcc320e6dc3 in QAbstractItemView::mouseMoveEvent (this=0x294cc60, event=<value optimized out>) at itemviews/qabstractitemview.cpp:1709
#28 0x00007fcc320fb971 in QListView::mouseMoveEvent (this=0x294cc60, e=0x7fff4d7917d0) at itemviews/qlistview.cpp:778
#29 0x00007fcc31c1acfc in QWidget::event (this=0x294cc60, event=0x7fff4d7917d0) at kernel/qwidget.cpp:8244
#30 0x00007fcc31fcd156 in QFrame::event (this=0x294cc60, e=0x7fff4d7917d0) at widgets/qframe.cpp:557
#31 0x00007fcc320de46b in QAbstractItemView::viewportEvent (this=0x294cc60, event=0x7fff4d7917d0) at itemviews/qabstractitemview.cpp:1628
#32 0x00007fcc3120a627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x2951ff0, event=0x7fff4d7917d0) at kernel/qcoreapplication.cpp:846
#33 0x00007fcc31bc99c1 in QApplicationPrivate::notify_helper (this=0x24de270, receiver=0x2951ff0, e=0x7fff4d7917d0) at kernel/qapplication.cpp:4458
#34 0x00007fcc31bcedc3 in QApplication::notify (this=<value optimized out>, receiver=0x2951ff0, e=0x7fff4d7917d0) at kernel/qapplication.cpp:4023
#35 0x00007fcc328ed6c6 in KApplication::notify (this=0x7fff4d792490, receiver=0x2951ff0, event=0x7fff4d7917d0) at ../../kdeui/kernel/kapplication.cpp:311
#36 0x00007fcc3120a49c in QCoreApplication::notifyInternal (this=0x7fff4d792490, receiver=0x2951ff0, event=0x7fff4d7917d0) at kernel/qcoreapplication.cpp:731
#37 0x00007fcc31bcaa1d in sendEvent (receiver=0x2951ff0, event=0x7fff4d7917d0, alienWidget=0x2951ff0, nativeWidget=0x25847c0, buttonDown=0x7fcc326ad218, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#38 QApplicationPrivate::sendMouseEvent (receiver=0x2951ff0, event=0x7fff4d7917d0, alienWidget=0x2951ff0, nativeWidget=0x25847c0, buttonDown=0x7fcc326ad218, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3122
#39 0x00007fcc31c4c190 in QETWidget::translateMouseEvent (this=0x25847c0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4558
#40 0x00007fcc31c4aab7 in QApplication::x11ProcessEvent (this=0x7fff4d792490, event=0x7fff4d792120) at kernel/qapplication_x11.cpp:3680
#41 0x00007fcc31c73842 in x11EventSourceDispatch (s=0x24e1c60, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#42 0x00007fcc2d54cbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fcc2d54d3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007fcc2d54d639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007fcc312353ef in QEventDispatcherGlib::processEvents (this=0x2490db0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#46 0x00007fcc31c734de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007fcc31209882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007fcc31209abc in QEventLoop::exec (this=0x7fff4d792420, flags=...) at kernel/qeventloop.cpp:201
#49 0x00007fcc3120decb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#50 0x00007fcc350b49e5 in kdemain (argc=6, argv=0x7fff4d7929b8) at ../../../dolphin/src/main.cpp:98
#51 0x00007fcc34cfbeff in __libc_start_main (main=0x400730 <main(int, char**)>, argc=6, ubp_av=0x7fff4d7929b8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff4d7929a8) at libc-start.c:226
#52 0x0000000000400659 in _start ()

This bug may be a duplicate of or related to bug 233184.

Possible duplicates by query: bug 294383, bug 288750, bug 288321, bug 287693, bug 283129.

Reported using DrKonqi
Comment 1 Peter Penz 2012-03-15 08:44:27 UTC

*** This bug has been marked as a duplicate of bug 290747 ***