Bug 276464 - Context menu has disabled entries in column mode
Summary: Context menu has disabled entries in column mode
Status: RESOLVED DUPLICATE of bug 290747
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: columns mode (show other bugs)
Version: 1.6.1
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2011-06-25 12:39 UTC by quentin.denis
Modified: 2012-01-05 21:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Illustration (212.32 KB, image/png)
2011-06-25 12:39 UTC, quentin.denis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description quentin.denis 2011-06-25 12:39:39 UTC
Created attachment 61312 [details]
Illustration

Version:           1.6.1 (using KDE 4.6.4) 
OS:                Linux

Hi Peter,

in the split-mode you will sometimes be unable to delete files/folders. The attached screenshot will show such a situation. The only way to workaround this is to move to another folder (i.e. parent folder) and to move back to the concerned folder.

Please have a look on how to fix this. Split-window mode is awesome, but still too buggy currently. That is a pity.

Regards,
Quentin

Reproducible: Sometimes

Steps to Reproduce:
Open a subfolder in split-mode and try to delete any file from the parent folder (any column on the left of the opened subfolder). You won't be able to perform some actions on those files/folders


Expected Results:  
Quite obvious
Comment 1 Sebastian Dörner 2011-06-25 17:54:32 UTC
This seems to refer to column view and also occurs in non-split mode.
Steps to reproduce:
1) Open one folder $a in column view, this adds another column to the right.
2) Open folder $a/$b in the second column. This adds another column to the right. Focus is on the righmost column.

3a) If you now right-click on a folder in the second (middle) column, it shows the context menu entries enabled.
3b) If instead, you first click in a free area in the second column and afterwards right-click on a folder in there, the context menu entries are disabled.

This is at least inconsistent.
Comment 2 quentin.denis 2011-06-27 15:20:02 UTC
(In reply to comment #1)
> This seems to refer to column view and also occurs in non-split mode.
> Steps to reproduce:
> 1) Open one folder $a in column view, this adds another column to the right.
> 2) Open folder $a/$b in the second column. This adds another column to the
> right. Focus is on the righmost column.
> 
> 3a) If you now right-click on a folder in the second (middle) column, it shows
> the context menu entries enabled.
> 3b) If instead, you first click in a free area in the second column and
> afterwards right-click on a folder in there, the context menu entries are
> disabled.
> 
> This is at least inconsistent.

Well, actually, I meant column mode, sorry! It has nothing to do with the split mode.
Comment 3 Peter Penz 2012-01-05 21:52:57 UTC

*** This bug has been marked as a duplicate of bug 290747 ***