Bug 135376 - Crash when applying filters to all messages in a folder
Summary: Crash when applying filters to all messages in a folder
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: 1.9.7
Platform: unspecified Linux
: NOR grave with 163 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 139176 140660 143268 143690 144025 144491 144578 144755 145406 145808 146575 146715 147095 147927 148087 148169 149134 150379 153162 154211 156750 158106 162746 164650 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-10 01:14 UTC by Dánial Olsen
Modified: 2008-07-08 10:08 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
backtrace (3.70 KB, text/plain)
2007-10-08 14:08 UTC, lexual
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dánial Olsen 2006-10-10 01:14:54 UTC
Version:           1.9.4 (using KDE 3.5.4, Arch Linux)
Compiler:          Target: i686-pc-linux-gnu
OS:                Linux (i686) release 2.6.16.19

Kmail crashed when applied filters with Ctrl+J on two messages in Inbox.

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1248291152 (LWP 3837)]
[New Thread -1275536480 (LWP 3931)]
[New Thread -1267143776 (LWP 3930)]
[New Thread -1258751072 (LWP 3929)]
[New Thread -1250358368 (LWP 3928)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x00004736 in ?? ()
#7  0xb7bb4a4d in KMFolderImap::saveMsgMetaData ()
   from /opt/kde/lib/libkmailprivate.so
#8  0xb7cd47ac in KMail::ImapJob::slotPutMessageInfoData ()
   from /opt/kde/lib/libkmailprivate.so
#9  0xb7e55a2a in KMail::ImapJob::qt_invoke ()
   from /opt/kde/lib/libkmailprivate.so
#10 0xb6214f19 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#11 0xb6cf8130 in KIO::Job::infoMessage () from /opt/kde/lib/libkio.so.4
#12 0xb6cf8198 in KIO::SimpleJob::slotInfoMessage ()
   from /opt/kde/lib/libkio.so.4
#13 0xb6d35cf0 in KIO::SimpleJob::qt_invoke () from /opt/kde/lib/libkio.so.4
#14 0xb6d35d83 in KIO::TransferJob::qt_invoke () from /opt/kde/lib/libkio.so.4
#15 0xb6214f19 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#16 0xb6215724 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#17 0xb6d03423 in KIO::SlaveInterface::infoMessage ()
   from /opt/kde/lib/libkio.so.4
#18 0xb6d60ec7 in KIO::SlaveInterface::dispatch ()
   from /opt/kde/lib/libkio.so.4
#19 0xb6d510a8 in KIO::SlaveInterface::dispatch ()
   from /opt/kde/lib/libkio.so.4
#20 0xb6d04f1b in KIO::Slave::gotInput () from /opt/kde/lib/libkio.so.4
#21 0xb6d527a0 in KIO::Slave::qt_invoke () from /opt/kde/lib/libkio.so.4
#22 0xb6214f19 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#23 0xb6215a22 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#24 0xb653c3c0 in QSocketNotifier::activated () from /opt/qt/lib/libqt-mt.so.3
#25 0xb6232d90 in QSocketNotifier::event () from /opt/qt/lib/libqt-mt.so.3
#26 0xb61b6c17 in QApplication::internalNotify ()
   from /opt/qt/lib/libqt-mt.so.3
#27 0xb61b79df in QApplication::notify () from /opt/qt/lib/libqt-mt.so.3
#28 0xb68acbce in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#29 0xb61abbe1 in QEventLoop::activateSocketNotifiers ()
   from /opt/qt/lib/libqt-mt.so.3
#30 0xb61664ee in QEventLoop::processEvents () from /opt/qt/lib/libqt-mt.so.3
#31 0xb61cd4f1 in QEventLoop::enterLoop () from /opt/qt/lib/libqt-mt.so.3
#32 0xb61cd3a6 in QEventLoop::exec () from /opt/qt/lib/libqt-mt.so.3
#33 0xb61b687f in QApplication::exec () from /opt/qt/lib/libqt-mt.so.3
#34 0x0804a364 in ?? ()
#35 0xbfe2e154 in ?? ()
#36 0xbfe2e340 in ?? ()
#37 0x00000000 in ?? ()
Comment 1 Tobias Ussing 2006-10-22 16:03:13 UTC
I can confirm this, I have not been able to find a fullproof way of reproducing it. But if the filters aren't run automagicly and i have a list of mails to be filtered, pressing ctrl+j a lot of times will often(if not all the time) cause this crash.

Comment 2 Stephan Kulow 2007-03-22 10:42:08 UTC
Sorry, I can't reproduce this with 3.5 branch. It's either fixed or there is something about your filters, that I can't read out of your backtrace without debug info
Comment 3 Andreas Gungl 2007-03-22 11:32:40 UTC
It's not fixed yet. Please see
http://lists.kde.org/?t=117240737300001&r=1&w=2
Comment 4 Stephan Kulow 2007-03-22 12:00:56 UTC
You claim that - and I claim mStorage being 0 is fixed. So please try the 3.5 (or pim+) branch before you reopen
Comment 5 Andreas Gungl 2007-03-22 21:22:21 UTC
> You claim that - and I claim mStorage being 0 is fixed. So please try the
> 3.5 (or pim+) branch before you reopen


I don't feel like joking. 3.5 branch revision 645527 gives a nice
crash as mentioned in the discussion on the mailing list.
We better don't claim but demonstrate:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1251251504 (LWP 9490)]
0xb7bdff81 in KMFolder::find (this=0x6e2e6c6c, msg=0x85f59e8) at /home/andreas/kde35pim/kdepim/kmail/kmfolder.cpp:429
429       return mStorage ? mStorage->find( msg ) : 0;
(gdb) bt
#0  0xb7bdff81 in KMFolder::find (this=0x6e2e6c6c, msg=0x85f59e8) at /home/andreas/kde35pim/kdepim/kmail/kmfolder.cpp:429
#1  0xb7ba3c77 in KMHeaders::applyFiltersOnMsg (this=0x83f8c78) at /home/andreas/kde35pim/kdepim/kmail/kmheaders.cpp:1384
#2  0xb7d4fbf6 in KMMainWidget::slotApplyFilters (this=0x83d4a80)
    at /home/andreas/kde35pim/kdepim/kmail/kmmainwidget.cpp:1666
#3  0xb7d681bc in KMMainWidget::qt_invoke (this=0x83d4a80, _id=123, _o=0xbff68108) at ./kmail/kmmainwidget.moc:575
#4  0xb5e2ff1d in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#5  0xb5e30b5d in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#6  0xb6704ff9 in KAction::activated () from /opt/kde3/lib/libkdeui.so.4
#7  0xb6742bd2 in KAction::slotActivated () from /opt/kde3/lib/libkdeui.so.4
#8  0xb680c1ef in KAction::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#9  0xb5e2ff1d in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0xb5e30b5d in QObject::activate_signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0xb6437709 in KAccelPrivate::menuItemActivated () from /opt/kde3/lib/libkdecore.so.4
#12 0xb6487f37 in KAccelPrivate::emitActivatedSignal () from /opt/kde3/lib/libkdecore.so.4
#13 0xb64d9d5e in KAccelPrivate::eventFilter () from /opt/kde3/lib/libkdecore.so.4
#14 0xb5e2f81c in QObject::activate_filters () from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0xb5e2f88b in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb5e6850c in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb5f24032 in QMainWindow::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb5dd09c7 in QApplication::internalNotify () from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb5dd1d52 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb651dbf2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#21 0xb6494429 in KAccelEventHandler::x11Event () from /opt/kde3/lib/libkdecore.so.4
#22 0xb6519773 in KApplication::x11EventFilter () from /opt/kde3/lib/libkdecore.so.4
#23 0xb5d5ef54 in qt_x11EventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb5d6e893 in QApplication::x11ProcessEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb5d7f98a in QEventLoop::processEvents () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb5de77f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb5de7686 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb5dd057f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x0804a98f in main (argc=2, argv=0xbff68c14) at /home/andreas/kde35pim/kdepim/kmail/main.cpp:110
Comment 6 Stephan Kulow 2007-03-23 09:27:30 UTC
Am Thursday 22 March 2007 schrieb Andreas Gungl:
> > You claim that - and I claim mStorage being 0 is fixed. So please try the
> > 3.5 (or pim+) branch before you reopen
>
> I don't feel like joking. 3.5 branch revision 645527 gives a nice
> crash as mentioned in the discussion on the mailing list.
> We better don't claim but demonstrate:


Excellent. If you can reproduce it that well (because I can't and two others 
in IRC can't either - that could before) - can you do me a favor and 
reproduce it with /branches/work/kmail_debug_imap and send me (without CCing 
bugs) the log file kmail generated? Because mStorage _has_ to be != 0 here. 
Many thanks.

Greetings, Stephan
Comment 7 Andreas Gungl 2007-03-24 18:16:32 UTC
*** Bug 143268 has been marked as a duplicate of this bug. ***
Comment 8 Andreas Gungl 2007-03-24 18:20:50 UTC
It's a misunderstandig, Stephan. You're right, mStorage != 0 for sure. However the find() method fails. It's discussed in the mailinmg list thread I've mentioned. Ingo has described some solutions. The quickest but ugliest has been tested. There is a patch ready for that, however Ingo wanted to take a better route.
So please let's keep this report open even if mStorage != 0, okay?
Comment 9 Thomas McGuire 2007-04-04 05:33:12 UTC
*** Bug 143690 has been marked as a duplicate of this bug. ***
Comment 10 Tommi Tervo 2007-04-10 09:09:25 UTC
*** Bug 144025 has been marked as a duplicate of this bug. ***
Comment 11 Thomas McGuire 2007-04-10 21:01:18 UTC
Andreas, Stephan: Is this problem limited to IMAP? I am asking because some of the duplicates do not use IMAP at all, but have the same backtrace as in comment #5.
Comment 12 Andreas Gungl 2007-04-11 07:37:53 UTC
Am Tuesday 10 April 2007 schrieb Thomas McGuire:
> Andreas, Stephan: Is this problem limited to IMAP? I am asking
> because some of the duplicates do not use IMAP at all, but have the same
> backtrace as in comment #5.


No, it's not limited to IMAP. Perhaps the original problem of mStorage being 
not defined may have been on IMAP only. Currently using Ctrl-A + Ctrl-J for 
all messages in a folder gives a crash for local, dIMAP and IMAP accounts 
if one message in the folder was selected before pressing Ctrl-A.
Comment 13 Tommi Tervo 2007-04-11 08:24:55 UTC
*** Bug 144025 has been marked as a duplicate of this bug. ***
Comment 14 Thomas McGuire 2007-04-22 16:43:59 UTC
*** Bug 144491 has been marked as a duplicate of this bug. ***
Comment 15 Thomas McGuire 2007-04-23 19:29:33 UTC
*** Bug 144578 has been marked as a duplicate of this bug. ***
Comment 16 Thomas McGuire 2007-04-27 20:49:33 UTC
*** Bug 144755 has been marked as a duplicate of this bug. ***
Comment 17 Thomas McGuire 2007-05-14 16:19:41 UTC
*** Bug 145406 has been marked as a duplicate of this bug. ***
Comment 18 Thomas McGuire 2007-05-22 19:14:07 UTC
*** Bug 145808 has been marked as a duplicate of this bug. ***
Comment 19 Thomas McGuire 2007-06-09 14:17:16 UTC
*** Bug 146575 has been marked as a duplicate of this bug. ***
Comment 20 Thomas McGuire 2007-06-13 17:25:03 UTC
*** Bug 146715 has been marked as a duplicate of this bug. ***
Comment 21 pbhj 2007-06-16 01:55:51 UTC
I'm getting this crash on use of ctrl-j too.

I've tested and if I ctrl-a then ctrl-j in a folder it crashes (sorry no useful bt). If instead I ctrl-a and then deselect a single mail item in the folder then ctrl-j it runs without a crash. The particular mail item that is deselected is unimportant. This method (of avoiding the crash) works for folders with c.150 mails in but I haven't tested for larger numbers.

The crash occurs if you use "Apply all filters" from the Message menu too. 
Comment 22 pbhj 2007-06-16 01:57:14 UTC
oops, should have said, this is for local filtering, not IMAP
Comment 23 Thomas McGuire 2007-06-17 22:12:23 UTC
Why did you remove everyone from the CC list? Was that by accident or on purpose for some reason?
Comment 24 Thomas McGuire 2007-06-23 11:50:56 UTC
*** Bug 147095 has been marked as a duplicate of this bug. ***
Comment 25 Thomas McGuire 2007-06-26 16:12:09 UTC
*** Bug 140660 has been marked as a duplicate of this bug. ***
Comment 26 Thomas McGuire 2007-06-26 16:19:42 UTC
Raising severity because of some claims of data loss, for example in duplicate bug 140660.
Comment 27 Sérgio Basto 2007-06-26 16:56:02 UTC
I also claim data loss in  Bug 147095 , btw I try expose in that bug, how you can reproduce the bug.
Comment 28 Bram Schoenmakers 2007-07-16 18:58:26 UTC
*** Bug 147927 has been marked as a duplicate of this bug. ***
Comment 29 Thomas McGuire 2007-07-23 00:07:20 UTC
*** Bug 148087 has been marked as a duplicate of this bug. ***
Comment 30 Bram Schoenmakers 2007-07-24 19:52:50 UTC
*** Bug 148169 has been marked as a duplicate of this bug. ***
Comment 31 Roger Franz 2007-07-25 22:36:31 UTC
reproduced in kde 3.5.6, kmail v 1.96, using maildir directories, GNU/Linux distro Kubuntu Feisty Fawn.

Actually, it takes a couple of iterations for me to reproduce this, but eventually if I Ctrl-A + ctrl-J enough times, kmail will crash with sigsev 11.

I can also produce this behavior if I use the Search function, but it's not as consistent.
Comment 32 Dánial Olsen 2007-08-01 11:59:39 UTC
Running: KMail 1.9.7, KDE 3.5.7 on Debian unstable (SID), kernel 2.6.22

I don't get crashes anymore with normal usage. I've tested running Ctrl-a + Ctrl-j a few times on a couple of folders and it doesn't crash.

Is anyone else able to reproduce this with KMail 1.9.7? And how?
Comment 33 Chris Pick 2007-08-12 10:12:02 UTC
I am running KMail 1.9.7 and KDE 3.5.7 and on some Ctrl-a + Ctrl-j it will crash (usuall the second time I try it) and whats worse is it seems to corrupt whatever message it was moving at the time leaving it in in the source folder with "no subject" and an empty body and leaving it in the destination folder corrupted.

Anyway I just wanted to confirm that the bug is still out there.
Comment 34 Thomas McGuire 2007-08-23 16:54:58 UTC
*** Bug 149134 has been marked as a duplicate of this bug. ***
Comment 35 Thomas McGuire 2007-08-23 17:27:26 UTC
A potential fix for this has been commited to trunk and to the enterprise branch, see SVN commits 703875 and 703867.
We don't know if it really fixes the problem yet.
Comment 36 doug.shawhan 2007-08-23 17:35:04 UTC
Thanks! I'll be patient.

On 23 Aug 2007 15:27:27 -0000, Thomas McGuire <Thomas.McGuire@gmx.net> wrote:
[bugs.kde.org quoted mail]
Comment 37 Gary Krueger 2007-08-24 17:23:15 UTC
Disabling the pipe through "spamassassin -L" makes
the problem go away for me.

I just uncheck "Apply this filter to incoming messages"

in the "Advanced" tab of the "Filter Rules".
Comment 38 Gary Krueger 2007-08-24 17:50:18 UTC
Forget that about spamassassin.  It seemed to act nicely for a while.  But, it is back to its old tricks.  Sorry, I should have given it more time.
Comment 39 Gary Krueger 2007-09-04 16:45:34 UTC
I wouldn't care so much about this bug if it wasn't for the fact that automatic filtering fails after the first one or two messages.  That leaves me having to process nearly all incoming mail manually.  That is a royal pain.
Comment 40 Sheldon Hearn 2007-09-15 23:15:34 UTC
Has anyone taken r703875 and r703867 for a spin?
Comment 41 Tommi Tervo 2007-10-01 17:40:50 UTC
*** Bug 150379 has been marked as a duplicate of this bug. ***
Comment 42 lexual 2007-10-08 14:08:03 UTC
Created attachment 21774 [details]
backtrace

here's a backtrace from current 3.5.7 from debian testing.
This is from mail from pop3.
I can confirm this crash with debian testing and fedora 7.
I'll try to build from svn tomorrow to see if I can reproduce.

Steps to reproduce:
Open kmail for 1st time.
Confirm pop3 details, etc.
Fetch mail to inbox.
Right click on a mail and define a filter on mailing list, to move to another
folder.
Ctrl-A, Ctrl-J crashes kmail.
Very easy for me to reproduce this.
Comment 43 lexual 2007-10-09 02:33:28 UTC
Still reproducible with latest kde 3.5 branch svn of kdepim as of 9-Oct-07.
723195

Is there any other relevant information or tests I can run to help fix this!
Comment 44 Allen Winter 2007-10-09 15:13:40 UTC
we are simply swamped trying to get something halfway usable for KDE 4.0.

unfortunately, KDE 3.5.8 was tagged yesterday so any fix will have
to wait for KDE 3.5.9 or above.

Comment 45 Angelo Naselli 2007-10-09 15:19:59 UTC
> unfortunately, KDE 3.5.8 was tagged yesterday so any fix will have
> to wait for KDE 3.5.9 or above.


Allen that could be ok, but just providing a solution (a patch) could help distro
packagers to backport it before that deadline....

TIA,
	Angelo 
Comment 46 Gary Krueger 2007-10-30 15:50:55 UTC
This issue goes away for me when I downgrade kdepim (kmail) to 1.9.4.
Comment 47 Tommi Tervo 2007-11-30 08:28:06 UTC
*** Bug 153162 has been marked as a duplicate of this bug. ***
Comment 48 Tommi Tervo 2007-11-30 08:28:57 UTC
*** Bug 139176 has been marked as a duplicate of this bug. ***
Comment 49 Thomas McGuire 2007-12-19 19:28:22 UTC
*** Bug 154211 has been marked as a duplicate of this bug. ***
Comment 50 Albert Bogdanowicz 2008-01-19 16:30:45 UTC
For me it's OK now. I use Kmail 1.9.6 (enterprise 0.20071123.740460) and Kontact 1.2.4 (enterprise 0.20071123.740460). Still on Arch Linux, KDEmod 3.5.8.
Sorry for not posting it earlier.
Comment 51 Thomas McGuire 2008-01-27 01:16:20 UTC
*** Bug 156750 has been marked as a duplicate of this bug. ***
Comment 52 kavol 2008-02-07 16:27:19 UTC
I just run into this one with kmail 1.9.7 - see below:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0x2b91a9a2a900 (LWP 21528)]
[New Thread 0x42003950 (LWP 21532)]
[New Thread 0x41802950 (LWP 21531)]
[New Thread 0x41001950 (LWP 21530)]
[New Thread 0x40800950 (LWP 21529)]
[KCrash handler]
#5  KMMessage::transferInProgress (this=0x0) at kmmessage.cpp:238
#6  0x00002b919f7dd21c in KMHeaders::applyFiltersOnMsg (this=0x1125d50)
    at kmheaders.cpp:1399
#7  0x00002b919f8adff5 in KMMainWidget::qt_invoke (this=0x1118ca0, _id=123, 
    _o=0x7fff0b919390) at kmmainwidget.moc:578
#8  0x00002b91a60bd24c in QObject::activate_signal (this=0x123ea20, 
    clist=<value optimized out>, o=0x7fff0b919390) at kernel/qobject.cpp:2356
#9  0x00002b91a60bdef3 in QObject::activate_signal (this=0x0, 
    signal=<value optimized out>) at kernel/qobject.cpp:2325
#10 0x00002b91a46d7dd3 in KAction::qt_invoke (this=0x123ea20, _id=15, 
    _o=0x7fff0b919450) at kaction.moc:218
#11 0x00002b91a60bd24c in QObject::activate_signal (this=0x13fd930, 
    clist=<value optimized out>, o=0x7fff0b919450) at kernel/qobject.cpp:2356
#12 0x00002b91a60bdef3 in QObject::activate_signal (this=0x0, 
    signal=<value optimized out>) at kernel/qobject.cpp:2325
#13 0x00002b91a4f18596 in KAccelPrivate::emitActivatedSignal (this=0x13fd930, 
    pAction=0x149b090) at kaccel.cpp:400
#14 0x00002b91a4f834af in KAccelPrivate::eventFilter (this=0x13fd930, 
    pEvent=0x7fff0b919940) at kaccel.cpp:370
#15 0x00002b91a60bcc62 in QObject::activate_filters (this=0x1115740, 
    e=0x7fff0b919940) at kernel/qobject.cpp:903
#16 0x00002b91a60bccb7 in QObject::event (this=0x1115740, e=0x7fff0b919940)
    at kernel/qobject.cpp:735
#17 0x00002b91a60eef58 in QWidget::event (this=0x0, e=0x2280)
    at kernel/qwidget.cpp:4659
#18 0x00002b91a6199e25 in QMainWindow::event (this=0x1115740, e=0x7fff0b919940)
    at widgets/qmainwindow.cpp:1687
#19 0x00002b91a6066cb5 in QApplication::internalNotify (
    this=<value optimized out>, receiver=0x1115740, e=0x7fff0b919940)
    at kernel/qapplication.cpp:2635
#20 0x00002b91a6067f3e in QApplication::notify (this=0x7fff0b919e10, 
    receiver=0x1125d50, e=0x7fff0b919940) at kernel/qapplication.cpp:2392
#21 0x00002b91a4f9718a in KApplication::notify (this=0x7fff0b919e10, 
    receiver=0x1125d50, event=0x7fff0b919940) at kapplication.cpp:550
#22 0x00002b91a4f9d610 in QApplication::sendEvent (receiver=0xcc93f0, 
    event=0x2280) at /usr/qt/3/include/qapplication.h:496
#23 0x00002b91a4f54d50 in KAccelEventHandler::x11Event (
    this=<value optimized out>, pEvent=<value optimized out>) at kaccel.cpp:144
#24 0x00002b91a4f9dbdd in KAppX11HackWidget::publicx11Event (this=0x0, 
    e=0x2280) at kapplication.cpp:1651
#25 0x00002b91a4f9a3e4 in KApplication::x11EventFilter (this=0x7fff0b919e10, 
    _event=0x7fff0b919c50) at kapplication.cpp:1721
#26 0x00002b91a5ffff97 in qt_x11EventFilter (ev=0x7fff0b919c50)
    at kernel/qapplication_x11.cpp:387
#27 0x00002b91a600e7d8 in QApplication::x11ProcessEvent (this=0x7fff0b919e10, 
    event=0x7fff0b919c50) at kernel/qapplication_x11.cpp:3315
#28 0x00002b91a601db7f in QEventLoop::processEvents (this=0x669260, flags=4)
    at kernel/qeventloop_x11.cpp:192
#29 0x00002b91a607b402 in QEventLoop::enterLoop (this=0x0)
    at kernel/qeventloop.cpp:198
#30 0x00002b91a607b2b2 in QEventLoop::exec (this=0x0)
    at kernel/qeventloop.cpp:145
#31 0x0000000000402ead in main (argc=<value optimized out>, 
    argv=<value optimized out>) at main.cpp:110
#32 0x00002b91a9701b74 in __libc_start_main (main=0x402d70 <main>, argc=7, 
    ubp_av=0x7fff0b91a2f8, init=<value optimized out>, 
    fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fff0b91a2e8) at libc-start.c:229
#33 0x0000000000402c39 in _start ()
Current language:  auto; currently c
Comment 53 Jonathan Marten 2008-02-20 19:01:18 UTC
*** Bug 158106 has been marked as a duplicate of this bug. ***
Comment 54 Tobias Knieper 2008-03-13 12:26:15 UTC
I can confirm that the bug is fixed in KMail 1.9.9.
Comment 55 Allen Winter 2008-03-13 14:32:12 UTC
*** Bug has been marked as fixed ***.
Comment 56 paula simoes 2008-05-13 11:57:36 UTC
I'm using KMail 1.9.9 and this still happens with me.

I create a new filter and selected all messages in inbox. Then I applied all filters and KMail (in KOntact) crashed. I killed it and reopened it: I had my messages duplicated and triplicated, some of them with unkown subject and sender.

Then I removed duplicated messages and all of my inbox messages went unkown and empty.

I tried to replicate the select all messages aplly filter and kontact crashes every time.

Paula
Comment 57 Gary Krueger 2008-05-13 21:45:06 UTC
I've backed off to 1.9.4, which is the last one that I know works 
properly.

1.9.7 is a real mess with filtering.
With 1.9.9 as messy as all that, I'll stay with 1.9.4 (KDE 3.5.4).

Gary

On Tue 13 May 2008 5:57 am, paula simoes wrote:
[bugs.kde.org quoted mail]
Comment 58 Martin Steigerwald 2008-05-13 23:13:06 UTC
Hi Paula, if that happens I suggest to stop KMail, remove the KMail index files for the affected folder and start KMail again so that KMail rebuilds the index. If it happened in your inbox for example delete the following index files

martin@shambala:~Mail> ls -la | grep inbox
drwx------   5 martin martin        36 2008-05-13 22:47 inbox
-rw-------   1 martin martin    539855 2008-05-13 22:47 .inbox.index
-rw-r--r--   1 martin martin      4389 2008-05-13 22:47 .inbox.index.ids
-rw-r--r--   1 martin martin     54499 2008-05-13 10:21 .inbox.index.sorted

by using rm ~/Mail/.inbox.index* for example. Be careful not to delete the wrong file and better make a backup of ~/Mail before. No warranty whatsoever ;-).

Its not nice but thats my usual procedure when empty no subject mails appear or a mail turns out not to be deleteable. I read that recent KMail got a context menu entry for recreating the index file, but I am not sure whether it will make it to a KDE 3.5.10 if such a version is tagged at all. I had empty no subject mails in KMail from KDE 3.5.9 but they might have happened with an earlier version. I had non deleteable mail in my spam folder I think at least twice, but no time to make a bugreport back then. Didn't happen anymore since then.

I hope that on switching to akonadi all those still existing index related problems are gone for good.
Comment 59 Thomas McGuire 2008-05-28 18:55:08 UTC
*** Bug 162746 has been marked as a duplicate of this bug. ***
Comment 60 paula simoes 2008-05-29 18:09:39 UTC
Thanks a lot, that worked to have my messages back.
I think I will try to move to a older kontact. I really need filters, but I am not willing to move to other email client, since I do not know any so good as kontact suite.
Comment 61 Jonathan Marten 2008-06-22 10:22:08 UTC
*** Bug 164650 has been marked as a duplicate of this bug. ***
Comment 62 Turtle 2008-07-08 03:37:25 UTC
For those whom have not updated and experience the horror of the undeletable email eating up there inbox Additional Comment #59 From Thomas McGuire fixes the problem. Thank you this thomas this restored my inbox from this horrible sort crash then corrupt.
I am still running 1.9.7. On Gentoo the path was not obvious from your home directory the path to kmail inbox is:
~/.kde/share/apps/kmail/mail
and I can confirm that this did work and is safe for corrupted inboxes.
Comment 63 Martin Steigerwald 2008-07-08 10:08:49 UTC
In Comment #59 Thomas marks a bug as duplicate of this bug. I think you refer to comment #58.

Maildir location also depends on account type:

- POP3 / local mails: ~/Mail (well on Gentoo ~/.kde/share/apps/kmail/mail)
- IMAP: ~/.kde/share/apps/kmail/imap
- DIMAP: ~/.kde/share/apps/kmail/dimap

BTW I think index related bugs have not yet been fixed. With KMail 3.5.9 I sometimes have it that it displays a mail as empty or does not complete a delete operation - the line with the mail in the mail list is printed with strike-through style and then nothing happens. I am able to fix up these by quitting Kontact / KMail, deleting the index file and restarting it. Maybe thats a different bug tough. I find it quite difficult to provide a pattern that triggers the bug.