Bug 144578 - crash applying filters on multiple messages
Summary: crash applying filters on multiple messages
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-23 19:22 UTC by Alessandro Badii
Modified: 2007-04-23 19:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Badii 2007-04-23 19:22:12 UTC
Version:           1.9.6 (using KDE 3.5.6, Kubuntu (feisty) 4:3.5.6-0ubuntu14)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.20-15-generic

When I select all messages (Ctrl+A) in Inbox folder and then apply filters kmail crashes without messages.

Backtrace : 

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1242863920 (LWP 24259)]
[New Thread -1286751344 (LWP 24263)]
[New Thread -1278358640 (LWP 24262)]
[New Thread -1269965936 (LWP 24261)]
[New Thread -1261573232 (LWP 24260)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb4fd4105 in KMFolder::find () from /usr/lib/libkmailprivate.so
#7  0xb5266886 in KMHeaders::applyFiltersOnMsg ()
   from /usr/lib/libkmailprivate.so
#8  0xb4fd7e3a in KMMainWidget::slotApplyFilters ()
   from /usr/lib/libkmailprivate.so
#9  0xb52bdf8e in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#10 0xb6fb188b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#11 0xb6fb2330 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb67834c9 in KAction::activated () from /usr/lib/libkdeui.so.4
#13 0xb67bbcc2 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#14 0xb688906d in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#15 0xb6889331 in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#16 0xb6fb188b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb733dae0 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#18 0xb6fd181e in QSignal::activate () from /usr/lib/libqt-mt.so.3
#19 0xb70d7f1b in QPopupMenu::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#20 0xb678a34e in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#21 0xb6fe865d in QWidget::event () from /usr/lib/libqt-mt.so.3
#22 0xb6f48a60 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#23 0xb6f4ac1e in QApplication::notify () from /usr/lib/libqt-mt.so.3
#24 0xb7684ce2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#25 0xb6edb25d in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#26 0xb6ed9b9f in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#27 0xb6ed7fac in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#28 0xb6eef180 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#29 0xb6f63136 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#30 0xb6f62f46 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#31 0xb6f4a609 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#32 0x08061e25 in ?? ()
#33 0xbff240bc in ?? ()
#34 0x00000001 in ?? ()
#35 0x00000001 in ?? ()
#36 0x00000000 in ?? ()
Comment 1 Alessandro Badii 2007-04-23 19:23:00 UTC
My platform is Kubuntu 7.04
Comment 2 Thomas McGuire 2007-04-23 19:29:32 UTC

*** This bug has been marked as a duplicate of 135376 ***