Bug 144025 - KMail crash when asking to filter to much spam
Summary: KMail crash when asking to filter to much spam
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-10 08:01 UTC by Nicolas L.
Modified: 2007-04-11 08:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas L. 2007-04-10 08:01:02 UTC
Version:           1.9.6 (using KDE KDE 3.5.6)
Installed from:    Mandriva RPMs
OS:                Linux

i add 200 Mails ( spam + good mail )  i selected all spam mails and ask to filter them as Spam, then it crashed with this backstrace [1]   in +  when relaunching KMail, all mails from the inbox were in the box twice.


(no debugging symbols found)
Using host libthread_db library "/lib/i686/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1244092720 (LWP 31110)]
[New Thread -1299473504 (LWP 31115)]
[New Thread -1288901728 (LWP 31114)]
[New Thread -1280509024 (LWP 31113)]
[New Thread -1272116320 (LWP 31112)]
[New Thread -1263723616 (LWP 31111)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb4dfbd97 in KMFolder::find () from /usr/lib/libkmailprivate.so
#7  0xb505dee3 in KMHeaders::applyFiltersOnMsg ()
   from /usr/lib/libkmailprivate.so
#8  0xb4dffb98 in KMMainWidget::slotApplyFilters ()
   from /usr/lib/libkmailprivate.so
#9  0xb50f9960 in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#10 0xb669f26d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0xb669fe7d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0xb6f5fc57 in KAction::activated () from /usr/lib/libkdeui.so.4
#13 0xb6f969f2 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#14 0xb707a29a in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#15 0xb707a548 in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#16 0xb669f26d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb69b29ae in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb66bb0b7 in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb67a2367 in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb6f66c63 in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#21 0xb66d7030 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb6641d87 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb6642d29 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb6d3349a in KApplication::notify () from /usr/lib/libkdecore.so.4
#25 0xb65e4688 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb65e2d76 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb65f2faa in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb6657762 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb66416af in QApplication::enter_loop ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb67a54f7 in QPopupMenu::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb502ed60 in KMHeaders::slotRMB () from /usr/lib/libkmailprivate.so
#32 0xb502f06b in KMHeaders::rightButtonPressed ()
   from /usr/lib/libkmailprivate.so
#33 0xb502f4ed in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so
#34 0xb669f26d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb69c6a1b in QListView::contextMenuRequested ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb678354f in QListView::contentsContextMenuEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb67b3697 in QScrollView::viewportContextMenuEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0xb67b0cd6 in QScrollView::eventFilter ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb677f896 in QListView::eventFilter ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0xb4f4afe0 in KMHeaders::eventFilter () from /usr/lib/libkmailprivate.so
#41 0xb669eb7c in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0xb669ebeb in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0xb66d6cbc in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0xb6641d87 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0xb6642eec in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0xb6d3349a in KApplication::notify () from /usr/lib/libkdecore.so.4
#47 0xb65e41ec in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0xb65e2d76 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0xb65f2faa in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0xb6657762 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0xb6657626 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#52 0xb664173f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#53 0x080610d5 in QWidget::setUpdatesEnabled ()
#54 0xb5da4d8c in __libc_start_main () from /lib/i686/libc.so.6
#55 0x08057eb1 in QWidget::setUpdatesEnabled ()
Comment 1 Tommi Tervo 2007-04-10 09:09:24 UTC

*** This bug has been marked as a duplicate of 135376 ***
Comment 2 Nicolas L. 2007-04-10 19:54:17 UTC
this have nothing to do with a IMAP i use a POP server.
Comment 3 Tommi Tervo 2007-04-11 08:24:54 UTC
http://bugs.kde.org/show_bug.cgi?id=135376#c12

*** This bug has been marked as a duplicate of 135376 ***