Bug 154211 - program crashes whenever mass filtration is attempted on AMD64 machine under Linux 2.6.22
Summary: program crashes whenever mass filtration is attempted on AMD64 machine under ...
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.7
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-17 04:59 UTC by Willy Gommel
Modified: 2007-12-19 19:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
crash report backtrace (3.66 KB, text/plain)
2007-12-17 05:05 UTC, Willy Gommel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Willy Gommel 2007-12-17 04:59:19 UTC
Version:           1.9.7 (using KDE KDE 3.5.8)
Installed from:    Debian testing/unstable Packages
Compiler:          gcc 4.x 
OS:                Linux

On my AMD64 machine, I do my daily e-mail. I tend to heavily use the filtration feature to empty the inbox, sorting the messages into their appropriate folders.

Almost always, when I try to select all of the messages either there or in Sent Mail and ^J filter them, the program generates a crash. Fortunately, recently the crash handler started working, so now I can generate a backtrace and include it here.
Comment 1 Willy Gommel 2007-12-17 05:05:30 UTC
Created attachment 22586 [details]
crash report backtrace

This is the automatically-generated backtrace file following tonight's crash.

Thank you very much! :)
Comment 2 Willy Gommel 2007-12-17 05:13:49 UTC
There is more bad behavior attendant upon this crash: When I am trying to  mass filter all of my sent e-mails, the program "loses" the content in at least the top 20~30 messages. Unfortunately, the loss of data appears to be permanent -- I have yet to retrieve a text when it has been "lost" in this way. Not only that, but the program also tends to duplicate the "lost" messages. Oddly enough, the program does not appear to mess with the total byte count of each message. However, it does refuse to display any of the information out of the message itself, including the recipient, the subject, the date and time, or the text.
Comment 3 Thomas McGuire 2007-12-19 19:28:21 UTC
Same backtrace as in bug 135376, comment 5.

*** This bug has been marked as a duplicate of 135376 ***