Bug 143690 - KMail crashes when filtering messages
Summary: KMail crashes when filtering messages
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: 1.9.6
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-01 05:59 UTC by Dima Ryazanov
Modified: 2007-04-04 05:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dima Ryazanov 2007-04-01 05:59:34 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Gentoo Packages
Compiler:          gcc (GCC) 4.1.1 (Gentoo 4.1.1-r3) 
OS:                Linux

When I manually run filters on all messages in a folder, KMail sometimes crashes:
#6  0xb7c3601f in KMFolder::getMsg () from /usr/kde/3.5/lib/libkmailprivate.so
#7  0xb7bfe2b6 in KMHeaders::applyFiltersOnMsg ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#8  0xb7d83a3a in KMMainWidget::slotApplyFilters ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#9  0xb7d9adb2 in KMMainWidget::qt_invoke ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#10 0xb604bfd9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#11 0xb604cc2d in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#12 0xb68b1499 in KAction::activated () from /usr/kde/3.5/lib/libkdeui.so.4
#13 0xb68b14f2 in KAction::slotActivated ()
   from /usr/kde/3.5/lib/libkdeui.so.4
#14 0xb68b452d in KAction::qt_invoke () from /usr/kde/3.5/lib/libkdeui.so.4
#15 0xb604bfd9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#16 0xb604cc2d in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#17 0xb668df49 in KAccelPrivate::menuItemActivated ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#18 0xb668ec4d in KAccelPrivate::emitActivatedSignal ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#19 0xb668f0ec in KAccelPrivate::eventFilter ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#20 0xb604b8ac in QObject::activate_filters ()
   from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb604b91b in QObject::event () from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb6083f8c in QWidget::event () from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb613d172 in QMainWindow::event () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb5fed457 in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb5fee756 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb66072ee in KApplication::notify ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#27 0xb668fdc7 in ?? () from /usr/kde/3.5/lib/libkdecore.so.4
#28 0xbfed1710 in ?? ()
#29 0x082c0740 in ?? ()
#30 0xbfed135c in ?? ()
#31 0x00000000 in ?? ()

(For some reason, I can't get any debugging symbols, even though I tried compiling kdepim in debug mode (using Gentoo's "USE='debug nostrip' emerge kdepim").)


I am trying to find a pattern... It seems to be caused only by certain messages and possibly my filter that pipes the message through a program.

Here's some output of KMail before it crashed:

kmail: Can't delete /home/dima/Mail/temp/new/1175283126.4646.bwWgT No such file or directory
kmail: Can't delete /home/dima/Mail/temp/new/1175283116.4646.MYWoR No such file or directory
kmail: Can't delete /home/dima/Mail/temp/new/1175283049.4646.xSWve No such file or directory
kmail: Can't delete /home/dima/Mail/temp/new/1175282988.4646.FVzB7 No such file or directory
kmail: Can't delete /home/dima/Mail/temp/new/1175283292.4646.jpqry No such file or directory
kmail: Can't delete /home/dima/Mail/temp/new/1175283289.4646.NtLD9 No such file or directory
kmail: (182576, last 0)  , readyToShow true
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: (182576, last 182576)  , readyToShow true
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: parseMsg(KMMessage* aMsg == aMsg )
kmail: + Text/Plain
kmail:       Inserting one item into MimePartTree
kmail:                 Content-Type: Text/Plain
kmail: partNode::findType() is looking at Text/Plain
kmail: [static KMail::SpamScores KMail::SpamHeaderAnalyzer::getSpamScores(const KMMessage*)]
kmail: Input: aStr
Error:You have to enter something in the email address field.
kmail: Multiple / No addressees matched email address; Count is 0
kmail: ObjectTreeParser::parseObjectTree( node OK, showOnlyOneMimePart: FALSE )
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: KMReaderWin  -  finished parsing and displaying of message.
kmail: (182609, last 182576)  , readyToShow true
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: (182609, last 182609)  , readyToShow true
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: parseMsg(KMMessage* aMsg == aMsg )
kmail: + Text/Plain
kmail:       Inserting one item into MimePartTree
kmail:                 Content-Type: Text/Plain
kmail: partNode::findType() is looking at Text/Plain
kmail: [static KMail::SpamScores KMail::SpamHeaderAnalyzer::getSpamScores(const KMMessage*)]
kmail: Input: aStr
Error:You have to enter something in the email address field.
kmail: Multiple / No addressees matched email address; Count is 0
kmail: ObjectTreeParser::parseObjectTree( node OK, showOnlyOneMimePart: FALSE )
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: KMReaderWin  -  finished parsing and displaying of message.
kmail: Could not open file r+ /home/dima/Mail/temp/cur/1175283046.4646.fDFxo
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: Could not open file r+ /home/dima/Mail/temp/cur/1175283320.4646.4EJ3R
kmail: Could not open file r+ /home/dima/Mail/temp/cur/1175283296.4646.PRhDD:2,S
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: Could not open file r+ /home/dima/Mail/temp/cur/1175283323.4646.GDdri
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: FolderStorage::msgStatusChanged
kmail: (182611, last 0)  , readyToShow true
kmail: [const QTextCodec* KMReaderWin::overrideCodec() const]  mOverrideEncoding == ''
kmail: FolderStorage::msgStatusChanged
*** KMail got signal 11 (Crashing)
KCrash: Application 'kmail' crashing...
Comment 1 Carsten Lohrke 2007-04-03 15:50:15 UTC
> (For some reason, I can't get any debugging symbols, even though I tried compiling kdepim in debug mode (using Gentoo's "USE='debug nostrip' emerge kdepim").) 

The debug use flag sets --enable-debug to trigger debug code paths, but doesn't reset your compiler flags. Please have a look at http://www.gentoo.org/proj/en/qa/backtraces.xml 
Comment 2 Dima Ryazanov 2007-04-04 01:50:06 UTC
Thanks! That worked:

#6  0xb5539339 in KMFolder::find (this=0x1, msg=0x82be3d8) at kmfolder.cpp:429
#7  0xb5501299 in KMHeaders::applyFiltersOnMsg (this=0x8440648)
    at kmheaders.cpp:1378
#8  0xb5686a3a in KMMainWidget::slotApplyFilters (this=0x8440c20)
    at kmmainwidget.cpp:1668
#9  0xb569ddb2 in KMMainWidget::qt_invoke (this=0x8440c20, _id=122, 
    _o=0xbff63478) at kmmainwidget.moc:575
#10 0xb685ffd9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#11 0xb6860c2d in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#12 0xb70d6499 in KAction::activated () from /usr/kde/3.5/lib/libkdeui.so.4
#13 0xb70d64f2 in KAction::slotActivated ()
   from /usr/kde/3.5/lib/libkdeui.so.4
#14 0xb70d952d in KAction::qt_invoke () from /usr/kde/3.5/lib/libkdeui.so.4
#15 0xb685ffd9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#16 0xb6860c2d in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#17 0xb6e87f49 in KAccelPrivate::menuItemActivated ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#18 0xb6e88c4d in KAccelPrivate::emitActivatedSignal ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#19 0xb6e890ec in KAccelPrivate::eventFilter ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#20 0xb685f8ac in QObject::activate_filters ()
   from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb685f91b in QObject::event () from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb6897f8c in QWidget::event () from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb6951172 in QMainWindow::event () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb6801457 in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb6802756 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb6e012ee in KApplication::notify ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#27 0xb6e89dc7 in ?? () from /usr/kde/3.5/lib/libkdecore.so.4
Comment 3 Thomas McGuire 2007-04-04 05:33:11 UTC
See bug 135376, comment 5.

*** This bug has been marked as a duplicate of 135376 ***