Bug 147095 - apply all filters lost messages
Summary: apply all filters lost messages
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-22 16:32 UTC by Sérgio Basto
Modified: 2007-06-23 11:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sérgio Basto 2007-06-22 16:32:06 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Fedora RPMs
Compiler:          fedora linux i386 
OS:                Linux

3.5.6-0.3.fc6 Fedora-Core
I had one filter that put emails from @somesite.com at somesite folder.

After some months I do one sub-folder for one  person and after, I made one filter to put mails from the person on his folder. After that I select all messages and I done "apply all filters" on the somesite folder ,
and kmail (kontact) crash.
I repeat operation some times  
I notice that appears some messages in blank without subject or any other thing.
After made 3 different sub folders for 3 different persons.
Today I realize that I had lost many emails 
This is very bad
Comment 1 Sérgio Basto 2007-06-23 06:39:53 UTC
as I write above, I hadn't done nothing, that should delete the messages. 

The more strange of this bug is: 
I don't lost many messages just about 10% or less, a very aleatory choices and some recently emails. 
The filter rules are simple but which person could have 2 email person@something.net and person@something2.net so the filter are like this:
match any rule and rules are:
from person@something.net move to folder something/person 
from person@someting2.net move to folder something/person

btw, hopefully, I don't lose anything important is just academic matter 
Comment 2 Thomas McGuire 2007-06-23 11:50:55 UTC
That crash is already reported at bug 135376.

*** This bug has been marked as a duplicate of 135376 ***