Bug 148169 - Kmail Filter crash by pressing Strg+a and Strg+j
Summary: Kmail Filter crash by pressing Strg+a and Strg+j
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-24 17:44 UTC by Samuel Suther
Modified: 2007-07-24 19:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Suther 2007-07-24 17:44:19 UTC
Version:           1.9.6 (using KDE 3.5.6 "release 64.1" , openSUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.13-15.15-default

If i select all Mails in current Folder (e.g. Ctrl+a) an then start the Filter (Ctrl+j) Kmail (started within Kontact) crash.

If i unselect 1 entry - it means not all Mails in current Folder are marked, the Filter (Ctrl+j) run without problems.
Comment 1 Samuel Suther 2007-07-24 17:47:35 UTC
Here is the output from KDE-Crashmanager:
------------------
Using host libthread_db library "/lib/tls/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread 1106463904 (LWP 30829)]
[New Thread 1132727216 (LWP 30835)]
[Thread debugging using libthread_db enabled]
[New Thread 1106463904 (LWP 30829)]
[New Thread 1132727216 (LWP 30835)]
[Thread debugging using libthread_db enabled]
[New Thread 1106463904 (LWP 30829)]
[New Thread 1132727216 (LWP 30835)]
[New Thread 1130625968 (LWP 30834)]
[New Thread 1128524720 (LWP 30833)]
[New Thread 1126423472 (LWP 30832)]
[KCrash handler]
#6  0x42b25e69 in KMFolder::find () from /opt/kde3/lib/libkmailprivate.so
#7  0x42aef565 in KMHeaders::applyFiltersOnMsg ()
   from /opt/kde3/lib/libkmailprivate.so
#8  0x42c9fe1a in KMMainWidget::slotApplyFilters ()
   from /opt/kde3/lib/libkmailprivate.so
#9  0x42cbb096 in KMMainWidget::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0x41130479 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x41130930 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x40a8eda9 in KAction::activated () from /opt/kde3/lib/libkdeui.so.4
#13 0x40ac8be1 in KAction::slotActivated () from /opt/kde3/lib/libkdeui.so.4
#14 0x40ae810f in KAction::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#15 0x41130479 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x41130930 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40d0d5a9 in KAccelPrivate::menuItemActivated ()
   from /opt/kde3/lib/libkdecore.so.4
#18 0x40d49e67 in KAccelPrivate::emitActivatedSignal ()
   from /opt/kde3/lib/libkdecore.so.4
#19 0x40da8fe5 in KAccelPrivate::eventFilter ()
   from /opt/kde3/lib/libkdecore.so.4
#20 0x411301be in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x4113023b in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x4116a93c in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x4122aa92 in QMainWindow::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x410cf1d1 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0x410cfff2 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x40dd1fae in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#27 0x40d49c26 in KAccelEventHandler::x11Event ()
   from /opt/kde3/lib/libkdecore.so.4
#28 0x40dd02ef in KApplication::x11EventFilter ()
   from /opt/kde3/lib/libkdecore.so.4
#29 0x4105a375 in qt_x11EventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x4106689f in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x4107b8aa in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x410e6208 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x410e6106 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x410ceb1f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x08058c72 in main ()

------------------------

and the output from shell:
-------------------------
samuel@Desktop:~> kontact
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
WeaverThreadLogger: thread (ID: 1) suspended.
WeaverThreadLogger: thread (ID: 2) suspended.
WeaverThreadLogger: thread (ID: 3) suspended.
WeaverThreadLogger: thread (ID: 4) suspended.
samuel@Desktop:~> gpgmeplug checkMessageSignature status flags: 3
gpgmeplug checkMessageSignature found email: service@suther.de
gpgmeplug checkMessageSignature found email: info@suther.de
/bin/sh: klammail: command not found
*** KMail got signal 11 (Crashing)
KCrash: Application 'kontact' crashing...

-------------------------------
Comment 2 Bram Schoenmakers 2007-07-24 19:52:48 UTC

*** This bug has been marked as a duplicate of 135376 ***