Bug 146575 - kmail apply all filters crash
Summary: kmail apply all filters crash
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.7
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-09 07:57 UTC by Arsham Shirvani
Modified: 2007-06-09 14:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
The first time (6.64 KB, text/plain)
2007-06-09 08:56 UTC, Arsham Shirvani
Details
Second trace (6.67 KB, text/plain)
2007-06-09 08:57 UTC, Arsham Shirvani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arsham Shirvani 2007-06-09 07:57:08 UTC
Version:           1.9.7 (using KDE 3.5.7, Kubuntu (feisty) 4:3.5.7-0ubuntu1~feisty2)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.20-15-generic

Wile I was fetching from gmail pop server , I made some filters , and selected all the messages and "Apply All Filters"
Almost 40% times this happened.

The traceback : 


(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1250634032 (LWP 14383)]
[New Thread -1280513136 (LWP 14387)]
[New Thread -1272120432 (LWP 14386)]
[New Thread -1263727728 (LWP 14385)]
[New Thread -1255335024 (LWP 14384)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7b78af5 in KMFolder::find () from /usr/lib/libkmailprivate.so
#7  0xb7da6556 in KMHeaders::applyFiltersOnMsg ()
   from /usr/lib/libkmailprivate.so
#8  0xb7b7c7ca in KMMainWidget::slotApplyFilters ()
   from /usr/lib/libkmailprivate.so
#9  0xb7e7b495 in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#10 0xb703b88b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#11 0xb703c330 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb5f44a89 in KAction::activated () from /usr/lib/libkdeui.so.4
#13 0xb5f82212 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#14 0xb604a37d in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#15 0xb604a641 in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#16 0xb703b88b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb73c7ae0 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#18 0xb705b81e in QSignal::activate () from /usr/lib/libqt-mt.so.3
#19 0xb7161f1b in QPopupMenu::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#20 0xb5f4b8de in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#21 0xb707265d in QWidget::event () from /usr/lib/libqt-mt.so.3
#22 0xb6fd2a60 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#23 0xb6fd4c1e in QApplication::notify () from /usr/lib/libqt-mt.so.3
#24 0xb770ec32 in KApplication::notify () from /usr/lib/libkdecore.so.4
#25 0xb6f6525d in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#26 0xb6f63b9f in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#27 0xb6f61fac in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#28 0xb6f79180 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#29 0xb6fed136 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#30 0xb6fd4587 in QApplication::enter_loop () from /usr/lib/libqt-mt.so.3
#31 0xb7162dc9 in QPopupMenu::exec () from /usr/lib/libqt-mt.so.3
#32 0xb7d693f0 in KMHeaders::slotRMB () from /usr/lib/libkmailprivate.so
#33 0xb7d69719 in KMHeaders::rightButtonPressed ()
   from /usr/lib/libkmailprivate.so
#34 0xb7dce510 in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so
#35 0xb703b88b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#36 0xb73dec94 in QListView::contextMenuRequested ()
   from /usr/lib/libqt-mt.so.3
#37 0xb71391be in QListView::contentsContextMenuEvent ()
   from /usr/lib/libqt-mt.so.3
#38 0xb717087a in QScrollView::viewportContextMenuEvent ()
   from /usr/lib/libqt-mt.so.3
#39 0xb71726c8 in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#40 0xb713a75e in QListView::eventFilter () from /usr/lib/libqt-mt.so.3
#41 0xb7cbd4a9 in KMHeaders::eventFilter () from /usr/lib/libkmailprivate.so
#42 0xb703ae38 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#43 0xb703aeb6 in QObject::event () from /usr/lib/libqt-mt.so.3
#44 0xb707258f in QWidget::event () from /usr/lib/libqt-mt.so.3
#45 0xb6fd2a60 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#46 0xb6fd509b in QApplication::notify () from /usr/lib/libqt-mt.so.3
#47 0xb770ec32 in KApplication::notify () from /usr/lib/libkdecore.so.4
#48 0xb6f6525d in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#49 0xb6f63f2e in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#50 0xb6f61fac in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#51 0xb6f79180 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#52 0xb6fed136 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#53 0xb6fecf46 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#54 0xb6fd4609 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#55 0x0804a2de in ?? ()
#56 0xbfe08964 in ?? ()
#57 0xbfe0895c in ?? ()
#58 0x00000000 in ?? ()
Comment 1 Arsham Shirvani 2007-06-09 08:56:24 UTC
Created attachment 20810 [details]
The first time

This is the first trace
Comment 2 Arsham Shirvani 2007-06-09 08:57:48 UTC
Created attachment 20811 [details]
Second trace

The second time
Comment 3 Thomas McGuire 2007-06-09 14:17:15 UTC

*** This bug has been marked as a duplicate of 135376 ***