Bug 156750 - Kmail crash on filtering
Summary: Kmail crash on filtering
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-27 00:11 UTC by scott
Modified: 2008-01-27 01:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description scott 2008-01-27 00:11:55 UTC
Version:           unknown (using 3.5.8, compiled sources)
Compiler:          Target: i586-PCLinuxOS-2007 
OS:                Linux (i686) release 2.6.18.8.tex5

I have filters made up to keep my work mail in there  correct folders. 
 If I highlight all the mail in the inbox and do the filter apply theres a crash.



(no debugging symbols found)
Using host libthread_db library "/lib/i686/libthread_db.so.1".

[Thread debugging using libthread_db enabled]
[New Thread -1247205680 (LWP 18654)]
[New Thread -1290122336 (LWP 18658)]
[New Thread -1281729632 (LWP 18657)]
[New Thread -1273336928 (LWP 18656)]
[New Thread -1264944224 (LWP 18655)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#9  0xb4d1efd4 in KMFolder::find () from /usr/lib/libkmailprivate.so
#10 0xb4ce5955 in KMHeaders::applyFiltersOnMsg ()
   from /usr/lib/libkmailprivate.so
#11 0xb4ea4848 in KMMainWidget::slotApplyFilters ()
   from /usr/lib/libkmailprivate.so
#12 0xb4ec0782 in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#13 0xb6634f1f in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb66359c4 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0xb6f8a3f7 in KAction::activated () from /usr/lib/libkdeui.so.4
#16 0xb6fce2a1 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#17 0xb70d113e in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#18 0xb70d13fa in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#19 0xb6634f1f in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb699f850 in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb6654f2a in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb675b899 in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb6f8f7b3 in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#24 0xb666be8e in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb65cd6e0 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb65cf892 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb6d5f36a in KApplication::notify () from /usr/lib/libkdecore.so.4
#28 0xb6563249 in QApplication::sendSpontaneousEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb6561c2a in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb6560330 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb65766f0 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0xb65e6e12 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb65e6c22 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb65cf289 in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x080618ac in ?? ()
#36 0xb5aac75c in __libc_start_main () from /lib/i686/libc.so.6
#37 0x08058651 in ?? ()
Comment 1 Thomas McGuire 2008-01-27 01:16:18 UTC

*** This bug has been marked as a duplicate of 135376 ***