Bug 146715 - Crash when filtering e-mail
Summary: Crash when filtering e-mail
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-12 23:20 UTC by Alexander Rødseth
Modified: 2007-06-13 17:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Rødseth 2007-06-12 23:20:06 UTC
Version:           1.9.6 (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages
OS:                Linux

I have approximately 1500 e-mails in KMail that I tried filtering.
There were only two simple filters.

No loaded plugins that I know of.

Backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1249970480 (LWP 32609)]
[New Thread -1278485616 (LWP 32682)]
[New Thread -1270092912 (LWP 32681)]
[New Thread -1261700208 (LWP 32680)]
[New Thread -1253307504 (LWP 32679)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7c07105 in KMFolder::find () from /usr/lib/libkmailprivate.so
#7  0xb7e99886 in KMHeaders::applyFiltersOnMsg ()
   from /usr/lib/libkmailprivate.so
#8  0xb7c0ae3a in KMMainWidget::slotApplyFilters ()
   from /usr/lib/libkmailprivate.so
#9  0xb7ef0f8e in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#10 0xb70d388b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#11 0xb70d4330 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb5dca4c9 in KAction::activated () from /usr/lib/libkdeui.so.4
#13 0xb5e02cc2 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#14 0xb5ed006d in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#15 0xb5ed0331 in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#16 0xb70d388b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb745fae0 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#18 0xb70f381e in QSignal::activate () from /usr/lib/libqt-mt.so.3
#19 0xb71f9f1b in QPopupMenu::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#20 0xb5dd134e in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#21 0xb710a65d in QWidget::event () from /usr/lib/libqt-mt.so.3
#22 0xb706aa60 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#23 0xb706cc1e in QApplication::notify () from /usr/lib/libqt-mt.so.3
#24 0xb77a7ce2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#25 0xb6ffd25d in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#26 0xb6ffbb9f in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#27 0xb6ff9fac in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#28 0xb7011180 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#29 0xb7085136 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#30 0xb7084f46 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#31 0xb706c609 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#32 0x0804a2de in ?? ()
#33 0xbfd31094 in ?? ()
#34 0xbfd3108c in ?? ()
#35 0x00000000 in ?? ()

How to reproduce/what I did:
1. Install KMail (blank start)
2. Make KMail download 1500 e-mails
3. Set up a filter in order to filter out all e-mails from one mailinglist to one folder
   When setting up filters, try creating a new folder for the filtered e-mails in
   the folder selection window that "belongs" to the filter-configuration window.
   I was only able to make subfolder of subfolders, not from the base folder,
   so this is what I did.
4. Do step 3 again
5. You should now have two filters. One pointing to a subfolder of the "account"-folder and
   one pointing to the subfolder of that subfolder.
6. Move the subfolder of the subfolder one step up, so that it belongs to the parent    
   folder.
7. Mark all e-mail in the inbox and run the filters (ctrl+j)
8. KMail crashed

Expected behaviour is to not crash.

Btw, I'm really impressed with the speed of the latest KMail compared to about a year ago when I used KMail a lot.

Best regards,
   Alexander Rødseth
Comment 1 Thomas McGuire 2007-06-13 17:25:01 UTC

*** This bug has been marked as a duplicate of 135376 ***