Bug 144755 - crash in KMFolderImap::saveMsgMetaData ()
Summary: crash in KMFolderImap::saveMsgMetaData ()
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-27 16:29 UTC by Olivier Vitrat
Modified: 2007-04-27 20:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Vitrat 2007-04-27 16:29:34 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages

reported in Debian BTS at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=420000

kmail crashes after I hit CTRL-J a few times, trying to apply filters
to messages that are stored in an IMAP server in my local network.

Crash handler saved the following trace:
[KCrash handler]
#9  0x00000000 in ?? ()
#10 0xb7bf5d1d in KMFolderImap::saveMsgMetaData ()
   from /usr/lib/libkmailprivate.so
#11 0xb7d187bc in KMail::ImapJob::slotPutMessageInfoData ()
   from /usr/lib/libkmailprivate.so
#12 0xb7e6b11a in KMail::ImapJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#13 0xb70cfe1b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xb5abc4a0 in KIO::Job::infoMessage () from /usr/lib/libkio.so.4
#15 0xb5abc508 in KIO::SimpleJob::slotInfoMessage () from /usr/lib/libkio.so.4
#16 0xb5afe8f0 in KIO::SimpleJob::qt_invoke () from /usr/lib/libkio.so.4
#17 0xb5afe983 in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#18 0xb70cfe1b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0xb70d0348 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#20 0xb5aca593 in KIO::SlaveInterface::infoMessage ()
   from /usr/lib/libkio.so.4
#21 0xb5b1c164 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#22 0xb5b24cb8 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#23 0xb5acc09b in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#24 0xb5b15160 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#25 0xb70cfe1b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#26 0xb70d0722 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#27 0xb7459d1f in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#28 0xb70f25c6 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#29 0xb7067cf2 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#30 0xb7069b0f in QApplication::notify () from /usr/lib/libqt-mt.so.3
#31 0xb776fcce in KApplication::notify () from /usr/lib/libkdecore.so.4
#32 0xb6ffb4c1 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#33 0xb705a079 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#34 0xb700f7f4 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#35 0xb7082245 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#36 0xb7082066 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#37 0xb706988b in QApplication::exec () from /usr/lib/libqt-mt.so.3
#38 0x0804a094 in ?? ()
#39 0xbf9279c4 in ?? ()
#40 0xbf927bb0 in ?? ()
#41 0x00000000 in ?? ()
Comment 1 Thomas McGuire 2007-04-27 20:49:31 UTC

*** This bug has been marked as a duplicate of 135376 ***