Bug 145406 - crash during apply filters (Ctrl-J)
Summary: crash during apply filters (Ctrl-J)
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-14 10:04 UTC by Peter Soetens
Modified: 2007-05-14 16:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
valgrind reports location of freed memory which has been accessed. (3.57 KB, text/plain)
2007-05-14 11:19 UTC, Peter Soetens
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Soetens 2007-05-14 10:04:49 UTC
Version:           unknown (using KDE 3.5.6, Kubuntu (feisty) 4:3.5.6-0ubuntu14)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.17-11-generic

[This bug also occurs in kmail stand alone]

1. I select all messages from my local inbox (Ctrl-A) (53 messages)
2. I press Ctrl-J, I get the crash+backtrace below.
Only one message got filtered when I restart kontact. When
I repeat 1-2, the crash occurs again So this is very reproducible.

I have made a copy of the current state of my .kde/share/apps/kmail/mail
directory such that I can reproduce this crash at a later time.

I have 11 filters, checking the mailing list id, and one final filter
moving remaining mail to an 'archive' folder.

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1243253040 (LWP 18898)]
[New Thread -1286308976 (LWP 18902)]
[New Thread -1277916272 (LWP 18901)]
[New Thread -1269523568 (LWP 18900)]
[New Thread -1261130864 (LWP 18899)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb50450f9 in KMFolder::find () from /usr/lib/libkmailprivate.so
#7  0xb52d7886 in KMHeaders::applyFiltersOnMsg ()
   from /usr/lib/libkmailprivate.so
#8  0xb5048e3a in KMMainWidget::slotApplyFilters ()
   from /usr/lib/libkmailprivate.so
#9  0xb532ef8e in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#10 0xb6f5288b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#11 0xb6f53330 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb67244c9 in KAction::activated () from /usr/lib/libkdeui.so.4
#13 0xb675ccc2 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#14 0xb682a31f in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#15 0xb6f5288b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#16 0xb6f53330 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb753b3d9 in KAccelPrivate::menuItemActivated ()
   from /usr/lib/libkdecore.so.4
#18 0xb7589527 in KAccelPrivate::emitActivatedSignal ()
   from /usr/lib/libkdecore.so.4
#19 0xb75eaa1e in KAccelPrivate::eventFilter () from /usr/lib/libkdecore.so.4
#20 0xb6f51e38 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#21 0xb6f51eb6 in QObject::event () from /usr/lib/libqt-mt.so.3
#22 0xb6f8958f in QWidget::event () from /usr/lib/libqt-mt.so.3
#23 0xb705fba6 in QMainWindow::event () from /usr/lib/libqt-mt.so.3
#24 0xb6ee9a60 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#25 0xb6eeba30 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#26 0xb7625ce2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#27 0xb7596c87 in KAccelEventHandler::x11Event ()
   from /usr/lib/libkdecore.so.4
#28 0xb7624113 in KApplication::x11EventFilter ()
   from /usr/lib/libkdecore.so.4
#29 0xb6e68133 in ?? () from /usr/lib/libqt-mt.so.3
#30 0xbfa2c01c in ?? ()
#31 0xbfa2be98 in ?? ()
#32 0x00000001 in ?? ()
#33 0xb741aab0 in ?? () from /usr/lib/libqt-mt.so.3
#34 0xbfa2be98 in ?? ()
#35 0xb741aab0 in ?? () from /usr/lib/libqt-mt.so.3
#36 0xbfa2bd38 in ?? ()
#37 0xb6e788c2 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
Backtrace stopped: frame did not save the PC
Comment 1 Peter Soetens 2007-05-14 11:19:44 UTC
Created attachment 20562 [details]
valgrind reports location of freed memory which has been accessed.

I ran the kmail program through valgrind and filtered the relevant error (no
errors before this one, other than the classical X/write errors.

Especially this part is important:
==19312==  Address 0x6E97874 is 4 bytes inside a block of size 23 free'd
==19312==    at 0x402123A: free (vg_replace_malloc.c:233)
==19312==    by 0x508E2E4: QGArray::~QGArray() (in /usr/lib/libqt-mt.so.3.3.7)
==19312==    by 0x4DE4814: QMemArray<char>::~QMemArray() (in
/usr/lib/libqt-mt.so.3.3.7)
==19312==    by 0x507F104: QCString::~QCString() (in
/usr/lib/libqt-mt.so.3.3.7)
==19312==    by 0x48E6F4C: (within /usr/lib/libkdecore.so.4.2.0)
==19312==    by 0x48E7463: KConfigINIBackEnd::writeEntries(_IO_FILE*,
QMap<KEntryKey, KEntry> const&) (in /usr/lib/libkd\
ecore.so.4.2.0)
==19312==    by 0x49A2A32: KConfigINIBackEnd::writeConfigFile(QString, bool,
bool) (in /usr/lib/libkdecore.so.4.2.0)
==19312==    by 0x49A2CE9: KConfigINIBackEnd::sync(bool) (in
/usr/lib/libkdecore.so.4.2.0)
==19312==    by 0x48C5BE6: KConfigBase::sync() (in
/usr/lib/libkdecore.so.4.2.0)
==19312==    by 0x41E0BF7: GlobalSettings::slotSyncNow() (in
/usr/lib/libkmailprivate.so)
==19312==    by 0x41EBA51: GlobalSettings::qt_invoke(int, QUObject*) (in
/usr/lib/libkmailprivate.so)
==19312==    by 0x4D9988A: QObject::activate_signal(QConnectionList*,
QUObject*) (in /usr/lib/libqt-mt.so.3.3.7)
Comment 2 Thomas McGuire 2007-05-14 16:19:39 UTC

*** This bug has been marked as a duplicate of 135376 ***