Bug 143268 - kmail crashes after filtering
Summary: kmail crashes after filtering
Status: RESOLVED DUPLICATE of bug 135376
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-20 19:47 UTC by Albert Bogdanowicz
Modified: 2007-03-24 18:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Bogdanowicz 2007-03-20 19:47:13 UTC
Version:           1.9.6 (using KDE KDE 3.5.6)
Installed from:    Unlisted Binary Package
Compiler:          gcc 4.1.2 
OS:                Linux

I wanted to filter mail imported from Thunderbird 1.5.0.9. I used 3 filters for 3 different mailing lists and wanted to move some messages to different folders. When I sorted all messages, Kmail crashed. If I used Kontact, only Kmail crashed, Kontact stayed alive.

Bug reports:
alone:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
...
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1247881520 (LWP 14530)]
[New Thread -1276961904 (LWP 14535)]
[New Thread -1268569200 (LWP 14534)]
[New Thread -1260176496 (LWP 14533)]
[New Thread -1251783792 (LWP 14532)]
(no debugging symbols found)
...
(no debugging symbols found)
[KCrash handler]
#6  0xb7c1cbae in KMFolder::find () from /opt/kde/lib/libkmailprivate.so
#7  0xb7f1f23f in KMHeaders::applyFiltersOnMsg ()
   from /opt/kde/lib/libkmailprivate.so
#8  0xb7c2098a in KMMainWidget::slotApplyFilters ()
   from /opt/kde/lib/libkmailprivate.so
#9  0xb7f11e6f in KMMainWidget::qt_invoke ()
   from /opt/kde/lib/libkmailprivate.so
#10 0xb625ec19 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#11 0xb625f82d in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#12 0xb6ab3409 in KAction::activated () from /opt/kde/lib/libkdeui.so.4
#13 0xb6af2d91 in KAction::slotActivated () from /opt/kde/lib/libkdeui.so.4
#14 0xb6baf77d in KAction::slotPopupActivated ()
   from /opt/kde/lib/libkdeui.so.4
#15 0xb6bafa41 in KAction::qt_invoke () from /opt/kde/lib/libkdeui.so.4
#16 0xb625ec19 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#17 0xb6587afe in QSignal::signal () from /opt/qt/lib/libqt-mt.so.3
#18 0xb627a995 in QSignal::activate () from /opt/qt/lib/libqt-mt.so.3
#19 0xb63632ac in QPopupMenu::mouseReleaseEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#20 0xb6ab88de in KPopupMenu::mouseReleaseEvent ()
   from /opt/kde/lib/libkdeui.so.4
#21 0xb6297a4e in QWidget::event () from /opt/qt/lib/libqt-mt.so.3
#22 0xb62003c7 in QApplication::internalNotify ()
   from /opt/qt/lib/libqt-mt.so.3
#23 0xb620135b in QApplication::notify () from /opt/qt/lib/libqt-mt.so.3
#24 0xb68f8d3e in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#25 0xb61a0702 in QETWidget::translateMouseEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#26 0xb619eb81 in QApplication::x11ProcessEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#27 0xb61af4c1 in QEventLoop::processEvents () from /opt/qt/lib/libqt-mt.so.3
#28 0xb6216c91 in QEventLoop::enterLoop () from /opt/qt/lib/libqt-mt.so.3
#29 0xb61fff9f in QApplication::enter_loop () from /opt/qt/lib/libqt-mt.so.3
#30 0xb6364c99 in QPopupMenu::exec () from /opt/qt/lib/libqt-mt.so.3
#31 0xb7e586d1 in KMHeaders::slotRMB () from /opt/kde/lib/libkmailprivate.so
#32 0xb7e589fa in KMHeaders::rightButtonPressed ()
   from /opt/kde/lib/libkmailprivate.so
#33 0xb7e761f3 in KMHeaders::qt_invoke () from /opt/kde/lib/libkmailprivate.so
#34 0xb625ec19 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#35 0xb659b214 in QListView::contextMenuRequested ()
   from /opt/qt/lib/libqt-mt.so.3
#36 0xb634284f in QListView::contentsContextMenuEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#37 0xb63730a6 in QScrollView::viewportContextMenuEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#38 0xb6371187 in QScrollView::eventFilter () from /opt/qt/lib/libqt-mt.so.3
#39 0xb633eb06 in QListView::eventFilter () from /opt/qt/lib/libqt-mt.so.3
#40 0xb7d648e9 in KMHeaders::eventFilter ()
   from /opt/kde/lib/libkmailprivate.so
#41 0xb625e526 in QObject::activate_filters () from /opt/qt/lib/libqt-mt.so.3
#42 0xb625e58b in QObject::event () from /opt/qt/lib/libqt-mt.so.3
#43 0xb62976cc in QWidget::event () from /opt/qt/lib/libqt-mt.so.3
#44 0xb62003c7 in QApplication::internalNotify ()
   from /opt/qt/lib/libqt-mt.so.3
#45 0xb62014fe in QApplication::notify () from /opt/qt/lib/libqt-mt.so.3
#46 0xb68f8d3e in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#47 0xb61a0290 in QETWidget::translateMouseEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#48 0xb619eb81 in QApplication::x11ProcessEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#49 0xb61af4c1 in QEventLoop::processEvents () from /opt/qt/lib/libqt-mt.so.3
#50 0xb6216c91 in QEventLoop::enterLoop () from /opt/qt/lib/libqt-mt.so.3
#51 0xb6216b36 in QEventLoop::exec () from /opt/qt/lib/libqt-mt.so.3
#52 0xb620002f in QApplication::exec () from /opt/qt/lib/libqt-mt.so.3
#53 0x0804a344 in ?? ()
#54 0xbfd83b20 in ?? ()
#55 0xbfd83d10 in ?? ()
#56 0x00000000 in ?? ()

in Kontact:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1247881520 (LWP 14530)]
[New Thread -1276961904 (LWP 14535)]
[New Thread -1268569200 (LWP 14534)]
[New Thread -1260176496 (LWP 14533)]
[New Thread -1251783792 (LWP 14532)]
(no debugging symbols found)
[KCrash handler]
#6  0xb7c1cbae in KMFolder::find () from /opt/kde/lib/libkmailprivate.so
#7  0xb7f1f23f in KMHeaders::applyFiltersOnMsg ()
   from /opt/kde/lib/libkmailprivate.so
#8  0xb7c2098a in KMMainWidget::slotApplyFilters ()
   from /opt/kde/lib/libkmailprivate.so
#9  0xb7f11e6f in KMMainWidget::qt_invoke ()
   from /opt/kde/lib/libkmailprivate.so
#10 0xb625ec19 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#11 0xb625f82d in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#12 0xb6ab3409 in KAction::activated () from /opt/kde/lib/libkdeui.so.4
#13 0xb6af2d91 in KAction::slotActivated () from /opt/kde/lib/libkdeui.so.4
#14 0xb6baf77d in KAction::slotPopupActivated ()
   from /opt/kde/lib/libkdeui.so.4
#15 0xb6bafa41 in KAction::qt_invoke () from /opt/kde/lib/libkdeui.so.4
#16 0xb625ec19 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#17 0xb6587afe in QSignal::signal () from /opt/qt/lib/libqt-mt.so.3
#18 0xb627a995 in QSignal::activate () from /opt/qt/lib/libqt-mt.so.3
#19 0xb63632ac in QPopupMenu::mouseReleaseEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#20 0xb6ab88de in KPopupMenu::mouseReleaseEvent ()
   from /opt/kde/lib/libkdeui.so.4
#21 0xb6297a4e in QWidget::event () from /opt/qt/lib/libqt-mt.so.3
#22 0xb62003c7 in QApplication::internalNotify ()
   from /opt/qt/lib/libqt-mt.so.3
#23 0xb620135b in QApplication::notify () from /opt/qt/lib/libqt-mt.so.3
#24 0xb68f8d3e in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#25 0xb61a0702 in QETWidget::translateMouseEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#26 0xb619eb81 in QApplication::x11ProcessEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#27 0xb61af4c1 in QEventLoop::processEvents () from /opt/qt/lib/libqt-mt.so.3
#28 0xb6216c91 in QEventLoop::enterLoop () from /opt/qt/lib/libqt-mt.so.3
#29 0xb61fff9f in QApplication::enter_loop () from /opt/qt/lib/libqt-mt.so.3
#30 0xb6364c99 in QPopupMenu::exec () from /opt/qt/lib/libqt-mt.so.3
#31 0xb7e586d1 in KMHeaders::slotRMB () from /opt/kde/lib/libkmailprivate.so
#32 0xb7e589fa in KMHeaders::rightButtonPressed ()
   from /opt/kde/lib/libkmailprivate.so
#33 0xb7e761f3 in KMHeaders::qt_invoke () from /opt/kde/lib/libkmailprivate.so
#34 0xb625ec19 in QObject::activate_signal () from /opt/qt/lib/libqt-mt.so.3
#35 0xb659b214 in QListView::contextMenuRequested ()
   from /opt/qt/lib/libqt-mt.so.3
#36 0xb634284f in QListView::contentsContextMenuEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#37 0xb63730a6 in QScrollView::viewportContextMenuEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#38 0xb6371187 in QScrollView::eventFilter () from /opt/qt/lib/libqt-mt.so.3
#39 0xb633eb06 in QListView::eventFilter () from /opt/qt/lib/libqt-mt.so.3
#40 0xb7d648e9 in KMHeaders::eventFilter ()
   from /opt/kde/lib/libkmailprivate.so
#41 0xb625e526 in QObject::activate_filters () from /opt/qt/lib/libqt-mt.so.3
#42 0xb625e58b in QObject::event () from /opt/qt/lib/libqt-mt.so.3
#43 0xb62976cc in QWidget::event () from /opt/qt/lib/libqt-mt.so.3
#44 0xb62003c7 in QApplication::internalNotify ()
   from /opt/qt/lib/libqt-mt.so.3
#45 0xb62014fe in QApplication::notify () from /opt/qt/lib/libqt-mt.so.3
#46 0xb68f8d3e in KApplication::notify () from /opt/kde/lib/libkdecore.so.4
#47 0xb61a0290 in QETWidget::translateMouseEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#48 0xb619eb81 in QApplication::x11ProcessEvent ()
   from /opt/qt/lib/libqt-mt.so.3
#49 0xb61af4c1 in QEventLoop::processEvents () from /opt/qt/lib/libqt-mt.so.3
#50 0xb6216c91 in QEventLoop::enterLoop () from /opt/qt/lib/libqt-mt.so.3
#51 0xb6216b36 in QEventLoop::exec () from /opt/qt/lib/libqt-mt.so.3
#52 0xb620002f in QApplication::exec () from /opt/qt/lib/libqt-mt.so.3
#53 0x0804a344 in ?? ()
#54 0xbfd83b20 in ?? ()
#55 0xbfd83d10 in ?? ()
#56 0x00000000 in ?? ()
Comment 1 Tommi Tervo 2007-03-20 20:59:03 UTC
possible duplicate:
http://bugs.kde.org/show_bug.cgi?id=139176
Comment 2 Albert Bogdanowicz 2007-03-20 21:16:43 UTC
I think not, in my case it crashes immediatelly, not after going to any folders. Maybe the cause is the same, but I don't know how to read debugging information.
Comment 3 Will Stephenson 2007-03-22 15:14:52 UTC
What do you mean 'when you sorted all messages' - you changed the sort order on the header view? 

If possible, add exact steps needed to reproduce.
Comment 4 Albert Bogdanowicz 2007-03-22 18:18:28 UTC
Steps:
- click on "inbox"
- click on one of the messages
- press CTRL+a
- right click on the messages
- choose "Apply Filter" and "Apply All Filters"
Now it is supposed to crash without sorting the messages.
I reproduced this bug for many times before, but now it disappeared. I guess it is because I changed localisation of KDE to write how to reproduce the bug in English. My normal localisation is Polish. Mark it as resolved?
Comment 5 Albert Bogdanowicz 2007-03-23 19:34:23 UTC
Steps:
- click on "Inbox"
- click on one of the messages
- press CTRL+a
- right-click on the messages
- choose "Apply Filter" and "Apply All Filters"
- now it crashes
I changed language in KDE to English (usually it's Polish) and the bug disappeared, but on the next day it happened again (in English).
Filters (match all of the following):
- From contains newslettery@gazeta.pl -> Move Into Folder "Local Folders/inbox/Wyborcza"
- Subject contains [eklips] -> Move Into Folder "Local Folders/inbox/Almulista"
- Subject contains [almulista] -> Move Into Folder "Local Folders/inbox/Almulista"
Comment 6 Andreas Gungl 2007-03-24 18:16:32 UTC

*** This bug has been marked as a duplicate of 135376 ***