Bug 266383 - KDE crash during partition operations in KDE Partition Editor
Summary: KDE crash during partition operations in KDE Partition Editor
Status: RESOLVED DUPLICATE of bug 251356
Alias: None
Product: solid
Classification: Unclassified
Component: libsolid (show other bugs)
Version: 4.7.4
Platform: Ubuntu Packages Linux
: HI crash (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
: 268008 268955 268994 268995 269449 269632 272350 273075 278274 281300 282678 283263 283797 284045 284237 286136 286237 288398 289643 290426 290475 291066 291844 293244 293971 294036 294317 294357 297083 298579 299188 301508 302694 303191 303640 312479 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-15 15:21 UTC by Adrian Lancaster
Modified: 2013-04-27 12:21 UTC (History)
37 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.89 KB, text/plain)
2011-12-22 15:03 UTC, GGG
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Lancaster 2011-02-15 15:21:57 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Partition Editor was applying changes to two spare locally attached hard drives.  Neither drive had system partitions on it.  Changes were:
- Delete existing ext4 partitions from both drives
- Delete old swap partition from one of the drives
- Create new ext4 partitions (1 per drive, using the full drive size - 80GB each)
- Relabel both drives (spare1 and spare2)

At some point during these operations, the crash handler appeared.  I have not tried to recreate the crash.

Kontact was also running at the time.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77ec720 (LWP 1443))]

Thread 3 (Thread 0xaed0bb70 (LWP 1445)):
#0  0x008107d4 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0x00ad6fa6 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0x0367bb34 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x0367c45e in ?? () from /lib/libglib-2.0.so.0
#4  0x0367c848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x04f4259f in QEventDispatcherGlib::processEvents (this=0x8c7ec50, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x04f12609 in QEventLoop::processEvents (this=0xaed0b280, flags=) at kernel/qeventloop.cpp:149
#7  0x04f12a8a in QEventLoop::exec (this=0xaed0b280, flags=...) at kernel/qeventloop.cpp:201
#8  0x04e0eb7e in QThread::exec (this=0x8c7c300) at thread/qthread.cpp:490
#9  0x04ef135b in QInotifyFileSystemWatcherEngine::run (this=0x8c7c300) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x04e11df9 in QThreadPrivate::start (arg=0x8c7c300) at thread/qthread_unix.cpp:266
#11 0x0080ccc9 in start_thread () from /lib/libpthread.so.0
#12 0x00ac969e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xada81b70 (LWP 5224)):
#0  0x0016f416 in __kernel_vsyscall ()
#1  0x008114dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00ad6d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x02aaa3a5 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0x02aaa481 in ?? () from /usr/lib/libQtWebKit.so.4
#5  0x0080ccc9 in start_thread () from /lib/libpthread.so.0
#6  0x00ac969e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77ec720 (LWP 1443)):
[KCrash Handler]
#7  0x082c5ae5 in ~QExplicitlySharedDataPointer (this=0x8fe4e0c, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:159
#8  Solid::Device::~Device (this=0x8fe4e0c, __in_chrg=<value optimized out>) at ../../../solid/solid/device.cpp:84
#9  0x03c67ccf in ~QHashNode (this=0x8c35264, akey=...) at /usr/include/qt4/QtCore/qhash.h:217
#10 deleteNode2 (this=0x8c35264, akey=...) at /usr/include/qt4/QtCore/qhash.h:519
#11 deleteNode (this=0x8c35264, akey=...) at /usr/include/qt4/QtCore/qhash.h:507
#12 QHash<QString, Solid::Device>::remove (this=0x8c35264, akey=...) at /usr/include/qt4/QtCore/qhash.h:794
#13 0x03c64a3f in HotplugEngine::onDeviceRemoved (this=0x8c35250, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:243
#14 0x03c66f9d in HotplugEngine::qt_metacall (this=0x8c35250, _c=QMetaObject::InvokeMetaMethod, _id=25, _a=0xbfb1f008) at ./hotplugengine.moc:81
#15 0x04f198ca in QMetaObject::metacall (object=0x8c35250, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbfb1f008) at kernel/qmetaobject.cpp:237
#16 0x04f2c6ad in QMetaObject::activate (sender=0x877ed98, m=0x832e6c8, local_signal_index=1, argv=0x8c16728) at kernel/qobject.cpp:3280
#17 0x082c7293 in Solid::DeviceNotifier::deviceRemoved (this=0x877ed98, _t1=...) at ./devicenotifier.moc:94
#18 0x082ca48c in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x877ed98, udi=...) at ../../../solid/solid/devicemanager.cpp:206
#19 0x082ca915 in Solid::DeviceManagerPrivate::qt_metacall (this=0x877ed98, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfb1f1a8) at ./devicemanager_p.moc:80
#20 0x04f198ca in QMetaObject::metacall (object=0x877ed98, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfb1f1a8) at kernel/qmetaobject.cpp:237
#21 0x04f2c6ad in QMetaObject::activate (sender=0x8bb15c0, m=0x832f780, local_signal_index=1, argv=0x8c16728) at kernel/qobject.cpp:3280
#22 0x082df1a3 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x8bb15c0, _t1=...) at ./ifaces/devicemanager.moc:94
#23 0x0830caca in Solid::Backends::Hal::HalManager::slotDeviceRemoved (this=0x8bb15c0, udi=...) at ../../../solid/solid/backends/hal/halmanager.cpp:250
#24 0x0830cb6a in Solid::Backends::Hal::HalManager::qt_metacall (this=0x8bb15c0, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfb1f35c) at ./backends/hal/halmanager.moc:78
#25 0x008619dc in QDBusConnectionPrivate::deliverCall (this=0x87b1450, object=0x8bb15c0, msg=..., metaTypes=..., slotIdx=7) at qdbusintegrator.cpp:919
#26 0x0086d1f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xa236890, object=0x8bb15c0) at qdbusintegrator_p.h:103
#27 0x04f266a2 in QObject::event (this=0x8bb15c0, e=0x1) at kernel/qobject.cpp:1219
#28 0x01402fdc in QApplicationPrivate::notify_helper (this=0x86d3680, receiver=0x8bb15c0, e=0xa236890) at kernel/qapplication.cpp:4396
#29 0x0140904e in QApplication::notify (this=0x86c87e0, receiver=0x8bb15c0, e=0xa236890) at kernel/qapplication.cpp:3798
#30 0x010f868a in KApplication::notify (this=0x86c87e0, receiver=0x8bb15c0, event=0xa236890) at ../../kdeui/kernel/kapplication.cpp:310
#31 0x04f13b3b in QCoreApplication::notifyInternal (this=0x86c87e0, receiver=0x8bb15c0, event=0xa236890) at kernel/qcoreapplication.cpp:732
#32 0x04f16d8b in sendEvent (receiver=0x0, event_type=0, data=0x86b2028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x86b2028) at kernel/qcoreapplication.cpp:1373
#34 0x04f16f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#35 0x04f42a74 in sendPostedEvents (s=0x86d5b10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#36 postEventSourceDispatch (s=0x86d5b10) at kernel/qeventdispatcher_glib.cpp:277
#37 0x03678855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#38 0x0367c668 in ?? () from /lib/libglib-2.0.so.0
#39 0x0367c848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#40 0x04f42565 in QEventDispatcherGlib::processEvents (this=0x86b1ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#41 0x014c4be5 in QGuiEventDispatcherGlib::processEvents (this=0x86b1ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x04f12609 in QEventLoop::processEvents (this=0xbfb1fb84, flags=) at kernel/qeventloop.cpp:149
#43 0x04f12a8a in QEventLoop::exec (this=0xbfb1fb84, flags=...) at kernel/qeventloop.cpp:201
#44 0x04f1700f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#45 0x01401e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#46 0x0096486e in kdemain (argc=1, argv=0xbfb1fd94) at ../../../../plasma/desktop/shell/main.cpp:118
#47 0x080485bb in main (argc=1, argv=0xbfb1fd94) at plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-02-15 20:42:49 UTC
this appears like it might be a bug in Solid, where the shared data behind a Solid::Device object (or the object itself) is being deleted behind our backs in Solid. Kevin: can you comment on this?
Comment 2 Kevin Ottens 2011-02-22 19:14:52 UTC
Hm, shouldn't be... said shared data is not destroyed by libsolid internally. It's destroyed only when there's no Solid::Device instance left (because of QExplicitlySharedDataPointer) but that's it.
Comment 3 Aaron J. Seigo 2011-03-21 15:50:36 UTC
*** Bug 268008 has been marked as a duplicate of this bug. ***
Comment 4 Aaron J. Seigo 2011-03-21 15:50:42 UTC
*** Bug 268995 has been marked as a duplicate of this bug. ***
Comment 5 Aaron J. Seigo 2011-03-21 16:43:20 UTC
*** Bug 268955 has been marked as a duplicate of this bug. ***
Comment 6 Beat Wolf 2011-03-26 12:49:48 UTC
*** Bug 269449 has been marked as a duplicate of this bug. ***
Comment 7 Beat Wolf 2011-04-11 23:12:38 UTC
*** Bug 269632 has been marked as a duplicate of this bug. ***
Comment 8 Luca 2011-04-12 11:33:44 UTC
For me too Plasma crashed when I mounted my USB driver (1 GB). When I connected my USB to the pc, the screen went black and after few second appeared the crash windows and plasma restarted by itself!

I use Kubuntu 10.10 64 bit kernel 2.6.35-28 and Kde 4.6.2
Comment 9 Dario Andres 2011-05-15 00:55:36 UTC
[Comment from a bug report cleaner]
Note: bug 271566 seems to have a similar backtrace, it may be related.
Comment 10 Nicolas L. 2011-09-24 13:43:43 UTC
*** Bug 282678 has been marked as a duplicate of this bug. ***
Comment 11 Nicolas L. 2011-10-17 00:17:57 UTC
*** Bug 283263 has been marked as a duplicate of this bug. ***
Comment 12 Nicolas L. 2011-10-17 00:18:03 UTC
*** Bug 283797 has been marked as a duplicate of this bug. ***
Comment 13 Nicolas L. 2011-10-17 00:18:09 UTC
*** Bug 284045 has been marked as a duplicate of this bug. ***
Comment 14 Nicolas L. 2011-10-17 13:23:00 UTC
*** Bug 284237 has been marked as a duplicate of this bug. ***
Comment 15 Aaron J. Seigo 2011-11-10 11:02:52 UTC
*** Bug 286237 has been marked as a duplicate of this bug. ***
Comment 16 Aaron J. Seigo 2011-11-10 11:03:58 UTC
*** Bug 286136 has been marked as a duplicate of this bug. ***
Comment 17 Nicolas L. 2011-11-28 03:10:58 UTC
reproduced today in kde 4.7.3 when i removed the battery of my laptop.
Comment 18 Marco Martin 2011-12-03 19:51:16 UTC
*** Bug 272350 has been marked as a duplicate of this bug. ***
Comment 19 Jekyll Wu 2011-12-07 12:25:00 UTC
*** Bug 288398 has been marked as a duplicate of this bug. ***
Comment 20 Jekyll Wu 2011-12-07 12:31:32 UTC
*** Bug 268994 has been marked as a duplicate of this bug. ***
Comment 21 Jekyll Wu 2011-12-07 12:39:41 UTC
*** Bug 281300 has been marked as a duplicate of this bug. ***
Comment 22 GGG 2011-12-22 15:03:54 UTC
Created attachment 67026 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

____________________

-- Backtrace (Reduced):
#7  0x00007fa7fbdf9ee1 in ~QHashNode (this=0x1961800, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#8  deleteNode2 (node=0x1961800) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (node=0x1961800, this=0x159f138) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x159f138, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#11 0x00007fa7fbdfa03c in remove (akey=..., this=0x159f138) at /usr/include/qt4/QtCore/qhash.h:784
Comment 23 Christoph Feck 2012-01-02 19:14:49 UTC
Confirmed by several duplicates. Here, plasma-desktop and knotify4 crash whenever I remove the battery afteer charging it. The bug is not related to HAL (it's not installed), so reassigning.
Comment 24 Christoph Feck 2012-01-02 19:16:01 UTC
*** Bug 290426 has been marked as a duplicate of this bug. ***
Comment 25 Christoph Feck 2012-01-02 19:16:33 UTC
*** Bug 289643 has been marked as a duplicate of this bug. ***
Comment 26 Christoph Feck 2012-01-02 19:17:23 UTC
*** Bug 273075 has been marked as a duplicate of this bug. ***
Comment 27 Thijs 2012-01-03 09:15:27 UTC
*** Bug 290475 has been marked as a duplicate of this bug. ***
Comment 28 Thijs 2012-01-09 17:02:56 UTC
*** Bug 291066 has been marked as a duplicate of this bug. ***
Comment 29 Thijs 2012-01-18 14:58:15 UTC
*** Bug 291844 has been marked as a duplicate of this bug. ***
Comment 30 Thijs 2012-02-04 09:55:04 UTC
*** Bug 293244 has been marked as a duplicate of this bug. ***
Comment 31 Anne-Marie Mahfouf 2012-02-13 09:00:58 UTC
*** Bug 293971 has been marked as a duplicate of this bug. ***
Comment 32 Jekyll Wu 2012-02-14 02:35:10 UTC
*** Bug 294036 has been marked as a duplicate of this bug. ***
Comment 33 Jekyll Wu 2012-02-17 19:58:45 UTC
*** Bug 294317 has been marked as a duplicate of this bug. ***
Comment 34 Jekyll Wu 2012-02-18 12:36:21 UTC
*** Bug 294357 has been marked as a duplicate of this bug. ***
Comment 35 Jekyll Wu 2012-03-30 07:32:19 UTC
*** Bug 297083 has been marked as a duplicate of this bug. ***
Comment 36 Bart Van Assche 2012-04-05 12:00:45 UTC
This crash occurs systematically here every time I run a script that quickly creates and removes disk partitions.
Comment 37 Alex Fiestas 2012-04-22 00:20:24 UTC
(In reply to comment #36)
> This crash occurs systematically here every time I run a script that quickly
> creates and removes disk partitions.
Can you share that script? thanks !
Comment 38 Jekyll Wu 2012-04-22 03:23:39 UTC
*** Bug 298579 has been marked as a duplicate of this bug. ***
Comment 39 Bart Van Assche 2012-04-22 07:12:13 UTC
(In reply to comment #37)
> (In reply to comment #36)
> > This crash occurs systematically here every time I run a script that quickly
> > creates and removes disk partitions.
> Can you share that script? thanks !

Sorry, but that script only works on a client-server setup equipped with InfiniBand HCA's. The script itself can be found here: http://marc.info/?l=linux-scsi&m=133261665628155. You'll have to apply that patch on top of this kernel tree: http://github.com/bvanassche/linux/tree/srp-ha. Please let me know if you need more information.
Comment 40 Alex Fiestas 2012-04-22 14:45:05 UTC
Uh that is too much work for me to reproduce this bug :/

Can anybody else provide me a way of reproducing this bug? Thanks !
> (In reply to comment #37)
> > (In reply to comment #36)
> > > This crash occurs systematically here every time I run a script that quickly
> > > creates and removes disk partitions.
> > Can you share that script? thanks !
> 
> Sorry, but that script only works on a client-server setup equipped with
> InfiniBand HCA's. The script itself can be found here:
> http://marc.info/?l=linux-scsi&m=133261665628155. You'll have to apply that
> patch on top of this kernel tree:
> http://github.com/bvanassche/linux/tree/srp-ha. Please let me know if you
> need more information.
Comment 41 Christoph Feck 2012-04-22 22:04:44 UTC
I can still reproduce daily, see comment #23.
Comment 42 Alex Fiestas 2012-04-23 14:11:49 UTC
You say "After charging it" what does it mean exactly? 

Tried to unplug mine and nothing crashed :/
> I can still reproduce daily, see comment #23.
Comment 43 Christoph Feck 2012-04-25 11:49:37 UTC
I usually use my system plugged, without the battery. When I go somewhere else, I insert a full battery and remove the plug. Then when I later come back, I plug the cord, and when the battery is fully loaded again, I remove it. At that point, knotify4 and plasma-desktop crash with the solid backtrace.
Comment 44 Alex Fiestas 2012-04-29 07:18:34 UTC
Can you provide the output of "solid-hardware listen" ? stop it when the first crash appear.
> I usually use my system plugged, without the battery. When I go somewhere
> else, I insert a full battery and remove the plug. Then when I later come
> back, I plug the cord, and when the battery is fully loaded again, I remove
> it. At that point, knotify4 and plasma-desktop crash with the solid
> backtrace.
Comment 45 Christoph Feck 2012-04-29 21:04:00 UTC
Output is as follows. Note that I really only removed the battery once, but all three messages appeared at the same time, together with the crash.

Listening to add/remove events: 
Device Removed:
udi = '/org/freedesktop/UPower/devices/battery_CMB1'
Device Added:
udi = '/org/freedesktop/UPower/devices/battery_CMB1'
Device Removed:
udi = '/org/freedesktop/UPower/devices/battery_CMB1'
Comment 46 Alex Fiestas 2012-04-29 21:58:29 UTC
Nothing relevant I'm afraid (I have the same behavior here but it doesn't crashes).
Did solid-hardware crashed?

Can you run whatever process crashes with valgrind ? 

Thanks !
Comment 47 Christoph Feck 2012-04-29 23:29:07 UTC
pepo@duo:/local/Downloads> valgrind knotify4 --nofork
==4252== Memcheck, a memory error detector
==4252== Copyright (C) 2002-2011, and GNU GPL'd, by Julian Seward et al.
==4252== Using Valgrind-3.7.0 and LibVEX; rerun with -h for copyright info
==4252== Command: knotify4 --nofork
==4252== 
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
==4252== Conditional jump or move depends on uninitialised value(s)
==4252==    at 0x4A8F0D7: QFontDef::operator==(QFontDef const&) const (qfont_p.h:119)
==4252==    by 0x4A8AD52: QFont::operator==(QFont const&) const (qfont.cpp:1784)
==4252==    by 0x4A8B4D1: QFont::resolve(QFont const&) const (qfont.cpp:1890)
==4252==    by 0x4860F3D: QWidgetPrivate::resolveFont() (qwidget.cpp:4905)
==4252==    by 0x486AEF8: QWidget::event(QEvent*) (qwidget.cpp:8591)
==4252==    by 0x480A823: QApplicationPrivate::notify_helper(QObject*, QEvent*) (qapplication.cpp:4551)
==4252==    by 0x480A50C: QApplication::notify(QObject*, QEvent*) (qapplication.cpp:4516)
==4252==    by 0x423F6B5: KApplication::notify(QObject*, QEvent*) (kapplication.cpp:311)
==4252==    by 0x592D059: QCoreApplication::notifyInternal(QObject*, QEvent*) (qcoreapplication.cpp:915)
==4252==    by 0x47FC422: QCoreApplication::sendEvent(QObject*, QEvent*) (in /local/Qt4/qt-4.8/lib/libQtGui.so.4.8.2)
==4252==    by 0x480407E: QApplication::setFont(QFont const&, char const*) (qapplication.cpp:2056)
==4252==    by 0x42728DF: KGlobalSettings::Private::kdisplaySetFont() (kglobalsettings.cpp:1066)
==4252== 
==4252== Conditional jump or move depends on uninitialised value(s)
==4252==    at 0x4A8F0D7: QFontDef::operator==(QFontDef const&) const (qfont_p.h:119)
==4252==    by 0x4A8AD52: QFont::operator==(QFont const&) const (qfont.cpp:1784)
==4252==    by 0x4873D42: QWidgetPrivate::setFont_helper(QFont const&) (qwidget_p.h:434)
==4252==    by 0x4860F52: QWidgetPrivate::resolveFont() (qwidget.cpp:4906)
==4252==    by 0x486AEF8: QWidget::event(QEvent*) (qwidget.cpp:8591)
==4252==    by 0x480A823: QApplicationPrivate::notify_helper(QObject*, QEvent*) (qapplication.cpp:4551)
==4252==    by 0x480A50C: QApplication::notify(QObject*, QEvent*) (qapplication.cpp:4516)
==4252==    by 0x423F6B5: KApplication::notify(QObject*, QEvent*) (kapplication.cpp:311)
==4252==    by 0x592D059: QCoreApplication::notifyInternal(QObject*, QEvent*) (qcoreapplication.cpp:915)
==4252==    by 0x47FC422: QCoreApplication::sendEvent(QObject*, QEvent*) (in /local/Qt4/qt-4.8/lib/libQtGui.so.4.8.2)
==4252==    by 0x480407E: QApplication::setFont(QFont const&, char const*) (qapplication.cpp:2056)
==4252==    by 0x42728DF: KGlobalSettings::Private::kdisplaySetFont() (kglobalsettings.cpp:1066)
==4252== 
ASSERT: "dev->backendObject()!=0" in file /local/git/KDE/libs/kdelibs/solid/solid/devicemanager.cpp, line 201
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = knotify4 path = /local/KDE4/trunk/bin pid = 4252
KCrash: Arguments: /local/KDE4/trunk/bin/knotify4 --nocrashhandler --nofork 
KCrash: Attempting to start /local/kde4/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/pepo/.kde/socket-duo/kdeinit4__0

[1]+  Angehalten              valgrind knotify4 --nofork
pepo@duo:/local/Downloads> QSocketNotifier: Invalid socket 10 and type 'Read', disabling...
==4252== Thread 2:
==4252== Invalid read of size 2
==4252==    at 0x5963FB9: socketNotifierSourceCheck(_GSource*) (qeventdispatcher_glib.cpp:95)
==4252==    by 0x65B051A: g_main_context_check (gmain.c:3000)
==4252==    by 0x65B0AF1: g_main_context_iterate.isra.21 (gmain.c:3120)
==4252==    by 0x65B0CC0: g_main_context_iteration (gmain.c:3184)
==4252==    by 0x592A708: QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (qeventloop.cpp:149)
==4252==    by 0x592A880: QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (qeventloop.cpp:204)
==4252==    by 0x5805D5E: QThread::exec() (qthread.cpp:501)
==4252==    by 0x5907F8D: QInotifyFileSystemWatcherEngine::run() (qfilesystemwatcher_inotify.cpp:248)
==4252==    by 0x5808578: QThreadPrivate::start(void*) (qthread_unix.cpp:307)
==4252==    by 0x5B0AE05: start_thread (pthread_create.c:305)
==4252==    by 0x5D410ED: clone (clone.S:133)
==4252==  Address 0xab5ddc6 is 6 bytes inside a block of size 12 free'd
==4252==    at 0x402A123: operator delete(void*) (in /usr/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==4252==    by 0x5950F7B: QSocketNotifier::setEnabled(bool) (qsocketnotifier.cpp:298)
==4252==    by 0x5963FB5: socketNotifierSourceCheck(_GSource*) (qeventdispatcher_glib.cpp:92)
==4252==    by 0x65B051A: g_main_context_check (gmain.c:3000)
==4252==    by 0x65B0AF1: g_main_context_iterate.isra.21 (gmain.c:3120)
==4252==    by 0x65B0CC0: g_main_context_iteration (gmain.c:3184)
==4252==    by 0x592A708: QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (qeventloop.cpp:149)
==4252==    by 0x592A880: QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (qeventloop.cpp:204)
==4252==    by 0x5805D5E: QThread::exec() (qthread.cpp:501)
==4252==    by 0x5907F8D: QInotifyFileSystemWatcherEngine::run() (qfilesystemwatcher_inotify.cpp:248)
==4252==    by 0x5808578: QThreadPrivate::start(void*) (qthread_unix.cpp:307)
==4252==    by 0x5B0AE05: start_thread (pthread_create.c:305)
==4252== 
==4252== Invalid read of size 2
==4252==    at 0x5963FC0: socketNotifierSourceCheck(_GSource*) (qeventdispatcher_glib.cpp:95)
==4252==    by 0x65B051A: g_main_context_check (gmain.c:3000)
==4252==    by 0x65B0AF1: g_main_context_iterate.isra.21 (gmain.c:3120)
==4252==    by 0x65B0CC0: g_main_context_iteration (gmain.c:3184)
==4252==    by 0x592A708: QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (qeventloop.cpp:149)
==4252==    by 0x592A880: QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (qeventloop.cpp:204)
==4252==    by 0x5805D5E: QThread::exec() (qthread.cpp:501)
==4252==    by 0x5907F8D: QInotifyFileSystemWatcherEngine::run() (qfilesystemwatcher_inotify.cpp:248)
==4252==    by 0x5808578: QThreadPrivate::start(void*) (qthread_unix.cpp:307)
==4252==    by 0x5B0AE05: start_thread (pthread_create.c:305)
==4252==    by 0x5D410ED: clone (clone.S:133)
==4252==  Address 0xab5ddc4 is 4 bytes inside a block of size 12 free'd
==4252==    at 0x402A123: operator delete(void*) (in /usr/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==4252==    by 0x5950F7B: QSocketNotifier::setEnabled(bool) (qsocketnotifier.cpp:298)
==4252==    by 0x5963FB5: socketNotifierSourceCheck(_GSource*) (qeventdispatcher_glib.cpp:92)
==4252==    by 0x65B051A: g_main_context_check (gmain.c:3000)
==4252==    by 0x65B0AF1: g_main_context_iterate.isra.21 (gmain.c:3120)
==4252==    by 0x65B0CC0: g_main_context_iteration (gmain.c:3184)
==4252==    by 0x592A708: QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (qeventloop.cpp:149)
==4252==    by 0x592A880: QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (qeventloop.cpp:204)
==4252==    by 0x5805D5E: QThread::exec() (qthread.cpp:501)
==4252==    by 0x5907F8D: QInotifyFileSystemWatcherEngine::run() (qfilesystemwatcher_inotify.cpp:248)
==4252==    by 0x5808578: QThreadPrivate::start(void*) (qthread_unix.cpp:307)
==4252==    by 0x5B0AE05: start_thread (pthread_create.c:305)
==4252== 
==4252== 
==4252== HEAP SUMMARY:
==4252==     in use at exit: 1,045,040 bytes in 19,500 blocks
==4252==   total heap usage: 116,521 allocs, 97,021 frees, 35,298,309 bytes allocated
==4252== 
==4252== LEAK SUMMARY:
==4252==    definitely lost: 1,408 bytes in 11 blocks
==4252==    indirectly lost: 220 bytes in 11 blocks
==4252==      possibly lost: 332,994 bytes in 10,465 blocks
==4252==    still reachable: 710,418 bytes in 9,013 blocks
==4252==         suppressed: 0 bytes in 0 blocks
==4252== Rerun with --leak-check=full to see details of leaked memory
==4252== 
==4252== For counts of detected and suppressed errors, rerun with: -v
==4252== Use --track-origins=yes to see where uninitialised values come from
==4252== ERROR SUMMARY: 4 errors from 4 contexts (suppressed: 0 from 0)

[1]+  Exit 253                valgrind knotify4 --nofork
pepo@duo:/local/Downloads>
Comment 48 Christoph Feck 2012-04-29 23:29:26 UTC
Application: KNotify (knotify4), signal: Aborted
[Current thread is 1 (Thread 0xb4b5e740 (LWP 4378))]

Thread 2 (Thread 0xb1a32b40 (LWP 4379)):
#0  0xb779f424 in __kernel_vsyscall ()
#1  0xb5a970a0 in __GI___poll (fds=0x8b91830, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb51a628b in g_poll (fds=0x8b91830, nfds=1, timeout=-1) at gpoll.c:132
#3  0xb5197b60 in g_main_context_poll (n_fds=1, fds=0x8b91830, timeout=<optimized out>, context=0x8b8f8f0, priority=<optimized out>) at gmain.c:3417
#4  g_main_context_iterate (context=0x8b8f8f0, block=1, dispatch=1, self=) at gmain.c:3118
#5  0xb5197cc1 in g_main_context_iteration (context=0x8b8f8f0, may_block=1) at gmain.c:3184
#6  0xb5ea2cd2 in QEventDispatcherGlib::processEvents (this=0x8b66a78, flags=...) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:426
#7  0xb5e68709 in QEventLoop::processEvents (this=0xb1a32238, flags=...) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qeventloop.cpp:149
#8  0xb5e68881 in QEventLoop::exec (this=0xb1a32238, flags=...) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qeventloop.cpp:204
#9  0xb5d43d5f in QThread::exec (this=0x8b66500) at /local/git/Qt/frameworks/qt/src/corelib/thread/qthread.cpp:501
#10 0xb5e45f8e in QInotifyFileSystemWatcherEngine::run (this=0x8b66500) at /local/git/Qt/frameworks/qt/src/corelib/io/qfilesystemwatcher_inotify.cpp:248
#11 0xb5d46579 in QThreadPrivate::start (arg=0x8b66500) at /local/git/Qt/frameworks/qt/src/corelib/thread/qthread_unix.cpp:307
#12 0xb5c98e06 in start_thread (arg=0xb1a32b40) at pthread_create.c:305
#13 0xb5aa20ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb4b5e740 (LWP 4378)):
[KCrash Handler]
#7  0xb779f424 in __kernel_vsyscall ()
#8  0xb59e425f in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0xb59e5bc5 in __GI_abort () at abort.c:91
#10 0xb5d39ab9 in qt_message_output (msgType=QtFatalMsg, buf=0x8bbc258 "ASSERT: \"dev->backendObject()!=0\" in file /local/git/KDE/libs/kdelibs/solid/solid/devicemanager.cpp, line 201") at /local/git/Qt/frameworks/qt/src/corelib/global/qglobal.cpp:2260
#11 0xb5d39c2a in qt_message (msgType=QtFatalMsg, msg=0xb5ee6584 "ASSERT: \"%s\" in file %s, line %d", ap=0xbfc678c4 "M\250\035\267\064\246\035\267\311") at /local/git/Qt/frameworks/qt/src/corelib/global/qglobal.cpp:2306
#12 0xb5d3a0c0 in qFatal (msg=0xb5ee6584 "ASSERT: \"%s\" in file %s, line %d") at /local/git/Qt/frameworks/qt/src/corelib/global/qglobal.cpp:2489
#13 0xb5d39666 in qt_assert (assertion=0xb71da84d "dev->backendObject()!=0", file=0xb71da634 "/local/git/KDE/libs/kdelibs/solid/solid/devicemanager.cpp", line=201) at /local/git/Qt/frameworks/qt/src/corelib/global/qglobal.cpp:2007
#14 0xb71601ba in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x8b65ee0, udi=...) at /local/git/KDE/libs/kdelibs/solid/solid/devicemanager.cpp:201
#15 0xb7160977 in Solid::DeviceManagerPrivate::qt_static_metacall (_o=0x8b65ee0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfc67a18) at /local/build/KDE/libs/kdelibs/solid/solid/devicemanager_p.moc:55
#16 0xb5e86dc2 in QMetaObject::activate (sender=0x8b66c90, m=0xb7224488, local_signal_index=1, argv=0xbfc67a18) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qobject.cpp:3547
#17 0xb7178522 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x8b66c90, _t1=...) at /local/build/KDE/libs/kdelibs/solid/solid/ifaces/devicemanager.moc:108
#18 0xb71bebe2 in Solid::Backends::UPower::UPowerManager::slotDeviceRemoved (this=0x8b66c90, opath=...) at /local/git/KDE/libs/kdelibs/solid/solid/backends/upower/upowermanager.cpp:164
#19 0xb71bec88 in Solid::Backends::UPower::UPowerManager::qt_static_metacall (_o=0x8b66c90, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfc67c34) at /local/build/KDE/libs/kdelibs/solid/solid/backends/upower/upowermanager.moc:53
#20 0xb5e86dc2 in QMetaObject::activate (sender=0x8b66c9c, m=0x8ba2e40, local_signal_index=4, argv=0xbfc67c34) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qobject.cpp:3547
#21 0xb605bcb2 in QDBusInterfacePrivate::metacall (this=0x8b95088, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbfc67c34) at /local/git/Qt/frameworks/qt/src/dbus/qdbusinterface.cpp:278
#22 0xb605bc0e in QDBusInterface::qt_metacall (this=0x8b66c9c, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfc67c34) at /local/git/Qt/frameworks/qt/src/dbus/qdbusinterface.cpp:265
#23 0xb6041e56 in QDBusConnectionPrivate::deliverCall (this=0x8b67048, object=0x8b66c9c, msg=..., metaTypes=..., slotIdx=9) at /local/git/Qt/frameworks/qt/src/dbus/qdbusintegrator.cpp:947
#24 0xb604cdb4 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8bbbfe0, object=0x8b66c9c) at /local/git/Qt/frameworks/qt/src/dbus/qdbusintegrator_p.h:103
#25 0xb5e82252 in QObject::event (this=0x8b66c9c, e=0x8bbbfe0) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qobject.cpp:1195
#26 0xb65c1824 in QApplicationPrivate::notify_helper (this=0x8aa13f0, receiver=0x8b66c9c, e=0x8bbbfe0) at /local/git/Qt/frameworks/qt/src/gui/kernel/qapplication.cpp:4551
#27 0xb65bf0a8 in QApplication::notify (this=0xbfc68658, receiver=0x8b66c9c, e=0x8bbbfe0) at /local/git/Qt/frameworks/qt/src/gui/kernel/qapplication.cpp:3933
#28 0xb74b66b6 in KApplication::notify (this=0xbfc68658, receiver=0x8b66c9c, event=0x8bbbfe0) at /local/git/KDE/libs/kdelibs/kdeui/kernel/kapplication.cpp:311
#29 0xb5e6b05a in QCoreApplication::notifyInternal (this=0xbfc68658, receiver=0x8b66c9c, event=0x8bbbfe0) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qcoreapplication.cpp:915
#30 0xb5e6e8d3 in QCoreApplication::sendEvent (receiver=0x8b66c9c, event=0x8bbbfe0) at ../../include/QtCore/../../../../git/Qt/frameworks/qt/src/corelib/kernel/qcoreapplication.h:231
#31 0xb5e6bf88 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8a76d48) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qcoreapplication.cpp:1539
#32 0xb5e6bc41 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qcoreapplication.cpp:1432
#33 0xb5ea3396 in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../../../git/Qt/frameworks/qt/src/corelib/kernel/qcoreapplication.h:236
#34 0xb5ea251f in postEventSourceDispatch (s=0x8aa1230) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:279
#35 0xb5197761 in g_main_dispatch (context=0x8aa1300) at gmain.c:2515
#36 g_main_context_dispatch (context=0x8aa1300) at gmain.c:3052
#37 0xb5197be0 in g_main_context_iterate (context=0x8aa1300, block=1, dispatch=1, self=) at gmain.c:3123
#38 0xb5197cc1 in g_main_context_iteration (context=0x8aa1300, may_block=1) at gmain.c:3184
#39 0xb5ea2cb2 in QEventDispatcherGlib::processEvents (this=0x8a97ab8, flags=...) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:424
#40 0xb668cef6 in QGuiEventDispatcherGlib::processEvents (this=0x8a97ab8, flags=...) at /local/git/Qt/frameworks/qt/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#41 0xb5e68709 in QEventLoop::processEvents (this=0xbfc685cc, flags=...) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qeventloop.cpp:149
#42 0xb5e68881 in QEventLoop::exec (this=0xbfc685cc, flags=...) at /local/git/Qt/frameworks/qt/src/corelib/kernel/qeventloop.cpp:204
#43 0xb5e6b6f0 in QCoreApplication::exec () at /local/git/Qt/frameworks/qt/src/corelib/kernel/qcoreapplication.cpp:1187
#44 0xb65bed3a in QApplication::exec () at /local/git/Qt/frameworks/qt/src/gui/kernel/qapplication.cpp:3812
#45 0x08050903 in main (argc=1, argv=0xbfc687c4) at /local/git/KDE/base/kde-runtime/knotify/main.cpp:73
Comment 49 Jekyll Wu 2012-05-02 02:00:37 UTC
*** Bug 299188 has been marked as a duplicate of this bug. ***
Comment 50 Jekyll Wu 2012-06-09 18:35:19 UTC
*** Bug 301508 has been marked as a duplicate of this bug. ***
Comment 51 Jekyll Wu 2012-06-28 12:23:15 UTC
*** Bug 302694 has been marked as a duplicate of this bug. ***
Comment 52 Jekyll Wu 2012-07-08 13:58:37 UTC
*** Bug 303191 has been marked as a duplicate of this bug. ***
Comment 53 Jekyll Wu 2012-07-17 06:14:05 UTC
*** Bug 303640 has been marked as a duplicate of this bug. ***
Comment 54 Jekyll Wu 2012-07-18 08:51:15 UTC
*** Bug 303640 has been marked as a duplicate of this bug. ***
Comment 55 Christian González 2012-10-14 21:00:58 UTC
*** Bug 278274 has been marked as a duplicate of this bug. ***
Comment 56 Jekyll Wu 2013-01-02 11:17:06 UTC
*** Bug 312479 has been marked as a duplicate of this bug. ***
Comment 57 Joris Meijer 2013-01-06 14:17:23 UTC
I reported the last bug (312479). For me it has something to do with sleep. The crash occurs each time after resuming from sleep. However if I first disable bluetooth and then go to sleep/resume, there is no crash.... I created a little script to disable bluetooth automatically before going to sleep and the crashes stop.
Comment 58 Alex Fiestas 2013-03-02 00:05:52 UTC

*** This bug has been marked as a duplicate of bug 314544 ***
Comment 59 ancow 2013-03-02 00:14:21 UTC
(In reply to comment #58)
> *** This bug has been marked as a duplicate of bug 314544 ***

Since this bug is way older and contains all the votes, shouldn't #314544 be the duplicate?
Comment 60 Christoph Feck 2013-04-27 12:21:49 UTC
This bug is not a duplicate of bug 314544, but bug 251356.

*** This bug has been marked as a duplicate of bug 251356 ***