Bug 293971 - plasma crash when unlocking screen
Summary: plasma crash when unlocking screen
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-13 08:09 UTC by en
Modified: 2012-02-13 09:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description en 2012-02-13 08:09:32 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: 
unlocking the screen after closing the laptop lid for a few mins.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f49ec50b7a0 (LWP 2118))]

Thread 3 (Thread 0x7f49c8a37700 (LWP 2121)):
#0  0x00007f49ebdee773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f49e0132f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f49e0133429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f49e8fdaf3e in QEventDispatcherGlib::processEvents (this=0x292c6e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f49e8faecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f49e8faeef7 in QEventLoop::exec (this=0x7f49c8a36db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f49e8ec627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f49e8f91cbf in QInotifyFileSystemWatcherEngine::run (this=0x2934590) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f49e8ec8d05 in QThreadPrivate::start (arg=0x2934590) at thread/qthread_unix.cpp:331
#9  0x00007f49e0c3fefc in start_thread (arg=0x7f49c8a37700) at pthread_create.c:304
#10 0x00007f49ebdfa89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f49c20a8700 (LWP 2122)):
#0  0x00007f49ebdee773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f49e0132f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f49e0133429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f49e8fdaf3e in QEventDispatcherGlib::processEvents (this=0x2af29a0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f49e8faecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f49e8faeef7 in QEventLoop::exec (this=0x7f49c20a7db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f49e8ec627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f49e8f91cbf in QInotifyFileSystemWatcherEngine::run (this=0x2af1f30) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f49e8ec8d05 in QThreadPrivate::start (arg=0x2af1f30) at thread/qthread_unix.cpp:331
#9  0x00007f49e0c3fefc in start_thread (arg=0x7f49c20a8700) at pthread_create.c:304
#10 0x00007f49ebdfa89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f49ec50b7a0 (LWP 2118)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f49bf32bee1 in ~QHashNode (this=0x37f3c00, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#8  deleteNode2 (node=0x37f3c00) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (node=0x37f3c00, this=0x2eee1f8) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x2eee1f8, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#11 0x00007f49bf32c03c in remove (akey=..., this=0x2eee1f8) at /usr/include/qt4/QtCore/qhash.h:784
#12 HotplugEngine::onDeviceRemoved (this=0x2eee1d0, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#13 0x00007f49bf32e309 in HotplugEngine::qt_metacall (this=0x2eee1d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe9362090) at ./hotplugengine.moc:81
#14 0x00007f49e8fc2eba in QMetaObject::activate (sender=0x292a920, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe9362090) at kernel/qobject.cpp:3278
#15 0x00007f49e47e36c5 in Solid::DeviceNotifier::deviceRemoved (this=<optimized out>, _t1=<optimized out>) at ./devicenotifier.moc:94
#16 0x00007f49e47e48ad in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x292a920, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#17 0x00007f49e47e5069 in Solid::DeviceManagerPrivate::qt_metacall (this=0x292a920, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe9362240) at ./devicemanager_p.moc:80
#18 0x00007f49e8fc2eba in QMetaObject::activate (sender=0x292b660, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe9362240) at kernel/qobject.cpp:3278
#19 0x00007f49e47f7895 in Solid::Ifaces::DeviceManager::deviceRemoved (this=<optimized out>, _t1=<optimized out>) at ./ifaces/devicemanager.moc:94
#20 0x00007f49e4838166 in slotDeviceRemoved (opath=<optimized out>, this=0x292b660) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#21 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x292b660, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe9362580) at ./backends/upower/upowermanager.moc:78
#22 0x00007f49e8fc2eba in QMetaObject::activate (sender=0x292b678, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe9362580) at kernel/qobject.cpp:3278
#23 0x00007f49e931ad8d in QDBusInterfacePrivate::metacall (this=0x292f910, c=<optimized out>, id=4, argv=0x7fffe9362580) at qdbusinterface.cpp:278
#24 0x00007f49e93070e9 in QDBusConnectionPrivate::deliverCall (this=0x1fe85f0, object=0x292b678, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:942
#25 0x00007f49e931038f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#26 0x00007f49e8fc6a5e in QObject::event (this=0x292b678, e=<optimized out>) at kernel/qobject.cpp:1217
#27 0x00007f49e835f474 in notify_helper (e=0x3801a30, receiver=0x292b678, this=0x1eabc40) at kernel/qapplication.cpp:4486
#28 QApplicationPrivate::notify_helper (this=0x1eabc40, receiver=0x292b678, e=0x3801a30) at kernel/qapplication.cpp:4458
#29 0x00007f49e83642e1 in QApplication::notify (this=0x1e9e7f0, receiver=0x292b678, e=0x3801a30) at kernel/qapplication.cpp:4365
#30 0x00007f49e9c5e466 in KApplication::notify (this=0x1e9e7f0, receiver=0x292b678, event=0x3801a30) at ../../kdeui/kernel/kapplication.cpp:311
#31 0x00007f49e8fafafc in QCoreApplication::notifyInternal (this=0x1e9e7f0, receiver=0x292b678, event=0x3801a30) at kernel/qcoreapplication.cpp:787
#32 0x00007f49e8fb351f in sendEvent (event=0x3801a30, receiver=0x292b678) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1e3f430) at kernel/qcoreapplication.cpp:1428
#34 0x00007f49e8fdaa73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#35 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#36 0x00007f49e0132a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007f49e0133258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007f49e0133429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f49e8fdaed6 in QEventDispatcherGlib::processEvents (this=0x1e40f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#40 0x00007f49e840710e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f49e8faecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007f49e8faeef7 in QEventLoop::exec (this=0x7fffe9362da0, flags=...) at kernel/qeventloop.cpp:201
#43 0x00007f49e8fb3789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#44 0x00007f49ec0f91a3 in kdemain (argc=1, argv=0x7fffe9363188) at ../../../../plasma/desktop/shell/main.cpp:120
#45 0x00007f49ebd3a30d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fffe9363188, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffe9363178) at libc-start.c:226
#46 0x0000000000400671 in _start ()

This bug may be a duplicate of or related to bug 278141.

Possible duplicates by query: bug 293415, bug 293244, bug 291844, bug 291066, bug 290475.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2012-02-13 09:00:58 UTC

*** This bug has been marked as a duplicate of bug 266383 ***