Bug 286136 - Plamsa crashes when unlocking screen after resuming from suspend
Summary: Plamsa crashes when unlocking screen after resuming from suspend
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-08 22:13 UTC by hermann.andreas
Modified: 2011-11-10 11:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.47 KB, text/plain)
2011-11-09 10:19 UTC, Tais P. Hansen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hermann.andreas 2011-11-08 22:13:43 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 3.0.6-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
Resuming from Suspend To RAM and unlocking the screen, Plasma Desktop sometimes
crashes with SEGFAULT. I'm now on KDE 4.7.3 and crash still sometimes happens.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f70d042d760 (LWP 3266))]

Thread 2 (Thread 0x7f70ae6f3700 (LWP 3268)):
#0  0xffffffffff600137 in ?? ()
#1  0x00007f70ae6f2a30 in ?? ()
#2  0x00007ffff33ff6e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f70d042d760 (LWP 3266)):
[KCrash Handler]
#6  0x00007f7000000008 in ?? ()
#7  0x00007f70ae6fb07a in ~QHashNode (this=0x1e18798, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:217
#8  deleteNode2 (this=0x1e18798, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (this=0x1e18798, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x1e18798, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#11 0x00007f70ae6f85fc in HotplugEngine::onDeviceRemoved (this=0x1e18770, udi=<value optimized out>) at /var/tmp/portage/kde-base/plasma-workspace-4.7.3/work/plasma-workspace-4.7.3/plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#12 0x00007f70ae6fa319 in HotplugEngine::qt_metacall (this=0x1e18770, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff33e8cf0) at /var/tmp/portage/kde-base/plasma-workspace-4.7.3/work/plasma-workspace-4.7.3_build/plasma/generic/dataengines/hotplug/hotplugengine.moc:81
#13 0x00007f70cf07b7e7 in QMetaObject::activate (sender=0x1d0e090, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffff33e8cf0) at kernel/qobject.cpp:3278
#14 0x00007f70c8179755 in Solid::DeviceNotifier::deviceRemoved (this=<value optimized out>, _t1=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3_build/solid/solid/devicenotifier.moc:94
#15 0x00007f70c817a8d7 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x1d0e090, udi=...) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3/solid/solid/devicemanager.cpp:207
#16 0x00007f70c817ab29 in Solid::DeviceManagerPrivate::qt_metacall (this=0x1d0e090, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff33e8eb0) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3_build/solid/solid/devicemanager_p.moc:80
#17 0x00007f70cf07b7e7 in QMetaObject::activate (sender=0x1cd7880, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffff33e8eb0) at kernel/qobject.cpp:3278
#18 0x00007f70c818d335 in Solid::Ifaces::DeviceManager::deviceRemoved (this=<value optimized out>, _t1=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3_build/solid/solid/ifaces/devicemanager.moc:94
#19 0x00007f70c81ccd96 in slotDeviceRemoved (this=0x1cd7880, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff33e9130) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3/solid/solid/backends/upower/upowermanager.cpp:164
#20 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x1cd7880, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff33e9130) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3_build/solid/solid/backends/upower/upowermanager.moc:78
#21 0x00007f70cf07b7e7 in QMetaObject::activate (sender=0x1cd7898, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffff33e9130) at kernel/qobject.cpp:3278
#22 0x00007f70cbed6d8f in QDBusInterfacePrivate::metacall (this=0x7f70a80040b0, c=<value optimized out>, id=4, argv=0x7ffff33e9130) at qdbusinterface.cpp:278
#23 0x00007f70cbec25ea in QDBusConnectionPrivate::deliverCall (this=0x1e17690, object=0x1cd7898, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:941
#24 0x00007f70cbecc91f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#25 0x00007f70cf07b2ea in QObject::event (this=0x1cd7898, e=<value optimized out>) at kernel/qobject.cpp:1217
#26 0x00007f70ce232c54 in QApplicationPrivate::notify_helper (this=0x14c4f60, receiver=0x1cd7898, e=0x26bf650) at kernel/qapplication.cpp:4462
#27 0x00007f70ce2377ca in QApplication::notify (this=<value optimized out>, receiver=0x1cd7898, e=0x26bf650) at kernel/qapplication.cpp:4341
#28 0x00007f70cfe17c76 in KApplication::notify (this=0x14b7980, receiver=0x1cd7898, event=0x26bf650) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#29 0x00007f70cf0670db in QCoreApplication::notifyInternal (this=0x14b7980, receiver=0x1cd7898, event=0x26bf650) at kernel/qcoreapplication.cpp:731
#30 0x00007f70cf06a894 in sendEvent (receiver=0x0, event_type=0, data=0x13cbb00) at kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x13cbb00) at kernel/qcoreapplication.cpp:1372
#32 0x00007f70cf091e53 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f70caae9f6e in g_main_dispatch (context=0x14cb4e0) at gmain.c:2441
#35 g_main_context_dispatch (context=0x14cb4e0) at gmain.c:3014
#36 0x00007f70caaea758 in g_main_context_iterate (context=0x14cb4e0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3092
#37 0x00007f70caaea9ed in g_main_context_iteration (context=0x14cb4e0, may_block=1) at gmain.c:3155
#38 0x00007f70cf091fef in QEventDispatcherGlib::processEvents (this=0x149afa0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#39 0x00007f70ce2d80be in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007f70cf066482 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007f70cf0666c4 in QEventLoop::exec (this=0x7ffff33e9c80, flags=...) at kernel/qeventloop.cpp:201
#42 0x00007f70cf06ab4b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#43 0x00007f70bcc290dd in kdemain (argc=1, argv=0x144fc80) at /var/tmp/portage/kde-base/plasma-workspace-4.7.3/work/plasma-workspace-4.7.3/plasma/desktop/shell/main.cpp:120
#44 0x0000000000407503 in launch (argc=1, _name=0x1463138 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b50e "0") at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3/kinit/kinit.cpp:734
#45 0x00000000004080df in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3/kinit/kinit.cpp:1226
#46 0x00000000004087c5 in handle_requests (waitForPid=0) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3/kinit/kinit.cpp:1419
#47 0x00000000004093cf in main (argc=2, argv=0x7ffff33eaed8, envp=0x7ffff33eaef0) at /var/tmp/portage/kde-base/kdelibs-4.7.3/work/kdelibs-4.7.3/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 278141.

Possible duplicates by query: bug 285850, bug 285340, bug 284920, bug 283797, bug 283463.

Reported using DrKonqi
Comment 1 Tais P. Hansen 2011-11-09 10:19:31 UTC
Created attachment 65432 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:

Resumed from suspend to ram and unlocked screensaver.

-- Backtrace (Reduced):
#7  0x00007f8254894ee1 in ~QHashNode (this=0x2e6c6a0, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#8  deleteNode2 (node=0x2e6c6a0) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (node=0x2e6c6a0, this=0x30d7e78) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x30d7e78, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#11 0x00007f825489503c in remove (akey=..., this=0x30d7e78) at /usr/include/qt4/QtCore/qhash.h:784
Comment 2 Aaron J. Seigo 2011-11-10 11:03:58 UTC

*** This bug has been marked as a duplicate of bug 266383 ***