Bug 268995 - Crashes frequently
Summary: Crashes frequently
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-20 22:24 UTC by Thomas Damgaard
Modified: 2011-03-21 15:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Damgaard 2011-03-20 22:24:45 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I was maximizing Konsole.
This also happens at other seemingly random times. But always when I am doing
something in the window manager. Like resizing or moving a window.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb65384d7a0 (LWP 2193))]

Thread 5 (Thread 0x7fb6309f4700 (LWP 2194)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fb6309f3990 in ?? ()
#2  0x00007fffa0d80852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 4 (Thread 0x7fb623f51700 (LWP 2196)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fb623f50990 in ?? ()
#2  0x00007fffa0d80852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0x7fb61cdc9700 (LWP 2199)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb64eb7820e in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007fb64eb78329 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007fb64b736953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007fb6485b8971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#5  0x00007fb65315b92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb61a8e2700 (LWP 2421)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb64da0b334 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fb64dd16160) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fb64da0b369 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fb64dd24234) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fb64b736953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007fb6485b8971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#5  0x00007fb65315b92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb65384d7a0 (LWP 2193)):
[KCrash Handler]
#6  0x0000000002462070 in ?? ()
#7  0x00007fb6309fc4d3 in ~QHashNode (this=0xdcef28, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:217
#8  deleteNode2 (this=0xdcef28, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (this=0xdcef28, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0xdcef28, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:794
#11 0x00007fb6309f969c in HotplugEngine::onDeviceRemoved (this=0xdcef00, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:243
#12 0x00007fb6309fb909 in HotplugEngine::qt_metacall (this=0xdcef00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa0c32160) at ./hotplugengine.moc:81
#13 0x00007fb6504b3b27 in QMetaObject::activate (sender=0x188ade0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x2a2cd34) at kernel/qobject.cpp:3280
#14 0x00007fb64c249a05 in Solid::DeviceNotifier::deviceRemoved (this=0x1ac4660, _t1=<value optimized out>) at ./devicenotifier.moc:94
#15 0x00007fb64c24cae3 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x188ade0, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#16 0x00007fb64c24cf81 in Solid::DeviceManagerPrivate::qt_metacall (this=0x188ade0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa0c32350) at ./devicemanager_p.moc:80
#17 0x00007fb6504b3b27 in QMetaObject::activate (sender=0x181ba80, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x2a2cd34) at kernel/qobject.cpp:3280
#18 0x00007fb64c2608d5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x1ac4660, _t1=<value optimized out>) at ./ifaces/devicemanager.moc:94
#19 0x00007fb64c2b5f29 in Solid::Backends::UDisks::UDisksManager::slotDeviceRemoved (this=0x181ba80, opath=...) at ../../../solid/solid/backends/udisks/udisksmanager.cpp:217
#20 0x00007fb64c2b6091 in Solid::Backends::UDisks::UDisksManager::qt_metacall (this=0x181ba80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa0c32850) at ./backends/udisks/udisksmanager.moc:80
#21 0x00007fb6504b3b27 in QMetaObject::activate (sender=0x181baa0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x2a2cd34) at kernel/qobject.cpp:3280
#22 0x00007fb650807c2f in QDBusInterfacePrivate::metacall (this=<value optimized out>, c=<value optimized out>, id=<value optimized out>, argv=<value optimized out>) at qdbusinterface.cpp:278
#23 0x00007fb6507f20ee in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#24 0x00007fb6507fd0ef in QDBusCallDeliveryEvent::placeMetaCall (this=0x2462070, object=0x1858f24) at qdbusintegrator_p.h:103
#25 0x00007fb6504adbde in QObject::event (this=0x181baa0, e=0x1ac4660) at kernel/qobject.cpp:1219
#26 0x00007fb64f802fdc in QApplicationPrivate::notify_helper (this=0x726720, receiver=0x181baa0, e=0x246a7b0) at kernel/qapplication.cpp:4396
#27 0x00007fb64f808aed in QApplication::notify (this=0x715390, receiver=0x181baa0, e=0x246a7b0) at kernel/qapplication.cpp:4277
#28 0x00007fb6511a22c6 in KApplication::notify (this=0x715390, receiver=0x181baa0, event=0x246a7b0) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007fb65049bcdc in QCoreApplication::notifyInternal (this=0x715390, receiver=0x181baa0, event=0x246a7b0) at kernel/qcoreapplication.cpp:732
#30 0x00007fb65049ec22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x68f530) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x68f530) at kernel/qcoreapplication.cpp:1373
#32 0x00007fb6504c8653 in sendPostedEvents (s=0x729e80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x729e80) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007fb647f02342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007fb647f062a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007fb647f0645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007fb6504c8193 in QEventDispatcherGlib::processEvents (this=0x68ec20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007fb64f8b5a4e in QGuiEventDispatcherGlib::processEvents (this=0x1ac4660, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007fb65049aa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007fb65049adec in QEventLoop::exec (this=0x7fffa0c33290, flags=) at kernel/qeventloop.cpp:201
#41 0x00007fb65049eebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007fb653439cf3 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007fb653093d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffa0c33668) at libc-start.c:226
#44 0x0000000000400669 in _start ()

Possible duplicates by query: bug 268008, bug 266383, bug 253123, bug 251131, bug 249236.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-03-21 15:50:42 UTC

*** This bug has been marked as a duplicate of bug 266383 ***