Bug 269632 - Plasma crashes when inserting and mounting USB disk
Summary: Plasma crashes when inserting and mounting USB disk
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-28 19:43 UTC by Thomas Damgaard
Modified: 2011-04-11 23:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Damgaard 2011-03-28 19:43:38 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I was attaching an external USB hard drive with an encrypted filesystem. When I mounted the disk, Plasma crashed..

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f80b46c07a0 (LWP 2203))]

Thread 5 (Thread 0x7f8091868700 (LWP 2204)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f8091867990 in ?? ()
#2  0x00007fff779bf852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 4 (Thread 0x7f8084f98700 (LWP 2206)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f8084f97990 in ?? ()
#2  0x00007fff779bf852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0x7f807db92700 (LWP 2212)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f80af9eb20e in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f80af9eb329 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007f80ac5a9953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f80a942b971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#5  0x00007f80b3fce92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f807beac700 (LWP 2504)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f80ae87e334 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f80aeb89160) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f80ae87e369 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f80aeb97234) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f80ac5a9953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f80a942b971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#5  0x00007f80b3fce92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f80b46c07a0 (LWP 2203)):
[KCrash Handler]
#6  0x0000000000000008 in ?? ()
#7  0x00007f80918704d3 in ~QHashNode (this=0x320e188, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:217
#8  deleteNode2 (this=0x320e188, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (this=0x320e188, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x320e188, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:794
#11 0x00007f809186d69c in HotplugEngine::onDeviceRemoved (this=0x320e160, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:243
#12 0x00007f809186f909 in HotplugEngine::qt_metacall (this=0x320e160, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff779affc0) at ./hotplugengine.moc:81
#13 0x00007f80b1326b27 in QMetaObject::activate (sender=0x326d040, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x4803594) at kernel/qobject.cpp:3280
#14 0x00007f80ad0bca05 in Solid::DeviceNotifier::deviceRemoved (this=0x3f2d5c0, _t1=<value optimized out>) at ./devicenotifier.moc:94
#15 0x00007f80ad0bfae3 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x326d040, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#16 0x00007f80ad0bff81 in Solid::DeviceManagerPrivate::qt_metacall (this=0x326d040, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff779b01b0) at ./devicemanager_p.moc:80
#17 0x00007f80b1326b27 in QMetaObject::activate (sender=0x326ee30, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x4803594) at kernel/qobject.cpp:3280
#18 0x00007f80ad0d38d5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x3f2d5c0, _t1=<value optimized out>) at ./ifaces/devicemanager.moc:94
#19 0x00007f80ad128f29 in Solid::Backends::UDisks::UDisksManager::slotDeviceRemoved (this=0x326ee30, opath=...) at ../../../solid/solid/backends/udisks/udisksmanager.cpp:217
#20 0x00007f80ad129091 in Solid::Backends::UDisks::UDisksManager::qt_metacall (this=0x326ee30, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff779b06b0) at ./backends/udisks/udisksmanager.moc:80
#21 0x00007f80b1326b27 in QMetaObject::activate (sender=0x326ee50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x4803594) at kernel/qobject.cpp:3280
#22 0x00007f80b167ac2f in QDBusInterfacePrivate::metacall (this=<value optimized out>, c=<value optimized out>, id=<value optimized out>, argv=<value optimized out>) at qdbusinterface.cpp:278
#23 0x00007f80b16650ee in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#24 0x00007f80b16700ef in QDBusCallDeliveryEvent::placeMetaCall (this=0x8, object=0x42a5674) at qdbusintegrator_p.h:103
#25 0x00007f80b1320bde in QObject::event (this=0x326ee50, e=0x3f2d5c0) at kernel/qobject.cpp:1219
#26 0x00007f80b0675fdc in QApplicationPrivate::notify_helper (this=0x213b720, receiver=0x326ee50, e=0x46e11b0) at kernel/qapplication.cpp:4396
#27 0x00007f80b067baed in QApplication::notify (this=0x212a390, receiver=0x326ee50, e=0x46e11b0) at kernel/qapplication.cpp:4277
#28 0x00007f80b20152c6 in KApplication::notify (this=0x212a390, receiver=0x326ee50, event=0x46e11b0) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007f80b130ecdc in QCoreApplication::notifyInternal (this=0x212a390, receiver=0x326ee50, event=0x46e11b0) at kernel/qcoreapplication.cpp:732
#30 0x00007f80b1311c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x20a4530) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x20a4530) at kernel/qcoreapplication.cpp:1373
#32 0x00007f80b133b653 in sendPostedEvents (s=0x213ee80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x213ee80) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f80a8d75342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f80a8d792a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f80a8d7945c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f80b133b193 in QEventDispatcherGlib::processEvents (this=0x20a3c20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f80b0728a4e in QGuiEventDispatcherGlib::processEvents (this=0x3f2d5c0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f80b130da02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f80b130ddec in QEventLoop::exec (this=0x7fff779b10f0, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f80b1311ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f80b42accf3 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f80b3f06d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff779b14c8) at libc-start.c:226
#44 0x0000000000400669 in _start ()

Possible duplicates by query: bug 269449, bug 268995, bug 268008, bug 266383, bug 253123.

Reported using DrKonqi
Comment 1 Beat Wolf 2011-04-11 23:12:38 UTC

*** This bug has been marked as a duplicate of bug 266383 ***