Bug 284237 - Plasma Desktop (KDE 4.7.2, Kubuntu 11.10, 64 bit) has crashed on resumption from "suspend to RAM"
Summary: Plasma Desktop (KDE 4.7.2, Kubuntu 11.10, 64 bit) has crashed on resumption f...
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-17 05:26 UTC by Thomas Dreibholz
Modified: 2011-10-17 13:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Dreibholz 2011-10-17 05:26:58 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Plasma Desktop (KDE 4.7.2, Kubuntu 11.10, 64 bit) has crashed on resumption from "suspend to RAM".

-- Backtrace:
Application: Plasma-Desktop-Umgebung (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc3a29887a0 (LWP 2040))]

Thread 3 (Thread 0x7fc3813de700 (LWP 2043)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fc3813ddad0 in ?? ()
#2  0x00007fc3a29e87e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7fc37599f700 (LWP 2044)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fc37599ead0 in ?? ()
#2  0x00007fc3a29e87e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7fc3a29887a0 (LWP 2040)):
[KCrash Handler]
#6  0x00007fc39ac7333e in ~QExplicitlySharedDataPointer (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#7  Solid::Device::~Device (this=<optimized out>, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#8  0x00007fc3742f4ee1 in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#9  0x00007fc3742f503c in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#10 0x00007fc3742f7309 in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#11 0x00007fc39f452eba in QMetaObject::activate (sender=0x2d5bdb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff925fdb20) at kernel/qobject.cpp:3278
#12 0x00007fc39ac746c5 in Solid::DeviceNotifier::deviceRemoved (this=<optimized out>, _t1=<optimized out>) at ./devicenotifier.moc:94
#13 0x00007fc39ac758ad in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x2d5bdb0, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#14 0x00007fc39ac76069 in Solid::DeviceManagerPrivate::qt_metacall (this=0x2d5bdb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff925fdcd0) at ./devicemanager_p.moc:80
#15 0x00007fc39f452eba in QMetaObject::activate (sender=0x2d5ac10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff925fdcd0) at kernel/qobject.cpp:3278
#16 0x00007fc39ac88895 in Solid::Ifaces::DeviceManager::deviceRemoved (this=<optimized out>, _t1=<optimized out>) at ./ifaces/devicemanager.moc:94
#17 0x00007fc39acc9166 in slotDeviceRemoved (opath=<optimized out>, this=0x2d5ac10) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#18 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x2d5ac10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff925fe010) at ./backends/upower/upowermanager.moc:78
#19 0x00007fc39f452eba in QMetaObject::activate (sender=0x2d5ac28, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff925fe010) at kernel/qobject.cpp:3278
#20 0x00007fc39f7aad8d in QDBusInterfacePrivate::metacall (this=0x2d894a0, c=<optimized out>, id=4, argv=0x7fff925fe010) at qdbusinterface.cpp:278
#21 0x00007fc39f7970e9 in QDBusConnectionPrivate::deliverCall (this=0x1f966f0, object=0x2d5ac28, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:942
#22 0x00007fc39f7a038f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#23 0x00007fc39f456a5e in QObject::event (this=0x2d5ac28, e=<optimized out>) at kernel/qobject.cpp:1217
#24 0x00007fc39e7f0424 in notify_helper (e=0x2d9e780, receiver=0x2d5ac28, this=0x1e26f20) at kernel/qapplication.cpp:4486
#25 QApplicationPrivate::notify_helper (this=0x1e26f20, receiver=0x2d5ac28, e=0x2d9e780) at kernel/qapplication.cpp:4458
#26 0x00007fc39e7f5291 in QApplication::notify (this=0x1e04ac0, receiver=0x2d5ac28, e=0x2d9e780) at kernel/qapplication.cpp:4365
#27 0x00007fc3a00ee126 in KApplication::notify (this=0x1e04ac0, receiver=0x2d5ac28, event=0x2d9e780) at ../../kdeui/kernel/kapplication.cpp:311
#28 0x00007fc39f43fafc in QCoreApplication::notifyInternal (this=0x1e04ac0, receiver=0x2d5ac28, event=0x2d9e780) at kernel/qcoreapplication.cpp:787
#29 0x00007fc39f44351f in sendEvent (event=0x2d9e780, receiver=0x2d5ac28) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1da2430) at kernel/qcoreapplication.cpp:1428
#31 0x00007fc39f46aa73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#32 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#33 0x00007fc396803a5d in g_main_dispatch (context=0x1e22c00) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:2441
#34 g_main_context_dispatch (context=0x1e22c00) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3011
#35 0x00007fc396804258 in g_main_context_iterate (context=0x1e22c00, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3089
#36 0x00007fc396804429 in g_main_context_iteration (context=0x1e22c00, may_block=1) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3152
#37 0x00007fc39f46aed6 in QEventDispatcherGlib::processEvents (this=0x1da3f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#38 0x00007fc39e89807e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007fc39f43ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#40 0x00007fc39f43eef7 in QEventLoop::exec (this=0x7fff925fe830, flags=...) at kernel/qeventloop.cpp:201
#41 0x00007fc39f443789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#42 0x00007fc3a25831a3 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#43 0x00007fc3a21c430d in __libc_start_main (main=0x400640, argc=1, ubp_av=0x7fff925fec18, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff925fec08) at libc-start.c:226
#44 0x0000000000400671 in _start ()

This bug may be a duplicate of or related to bug 266383.

Possible duplicates by query: bug 284045, bug 283797, bug 283263, bug 282678, bug 282665.

Reported using DrKonqi
Comment 1 Nicolas L. 2011-10-17 13:23:00 UTC

*** This bug has been marked as a duplicate of bug 266383 ***