Bug 290475 - хз
Summary: хз
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-03 08:29 UTC by dron293
Modified: 2012-01-03 09:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dron293 2012-01-03 08:29:30 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
I was sleeping when plasma was crashed. So, I do not do enething

-- Backtrace:
Application: Оболочка Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5e11720 (LWP 1811))]

Thread 4 (Thread 0xafb76b70 (LWP 1814)):
#0  0x02fcbd44 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00be8f54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x03b36f1f in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x03b378f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x03b37c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x015c8b37 in QEventDispatcherGlib::processEvents (this=0x8c9dc20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x015991dd in QEventLoop::processEvents (this=0xafb761f0, flags=...) at kernel/qeventloop.cpp:149
#7  0x01599421 in QEventLoop::exec (this=0xafb761f0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0149c90b in QThread::exec (this=0x8c9c458) at thread/qthread.cpp:498
#9  0x01579e2d in QInotifyFileSystemWatcherEngine::run (this=0x8c9c458) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0149f7b3 in QThreadPrivate::start (arg=0x8c9c458) at thread/qthread_unix.cpp:331
#11 0x032969cd in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x00bdb0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xae049b70 (LWP 1815)):
#0  0x02fcbd40 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00be8f54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x03b36c35 in g_main_context_query () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x03b37664 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x03b37c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x015c8b37 in QEventDispatcherGlib::processEvents (this=0x8e0a470, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x015991dd in QEventLoop::processEvents (this=0xae0491f0, flags=...) at kernel/qeventloop.cpp:149
#7  0x01599421 in QEventLoop::exec (this=0xae0491f0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0149c90b in QThread::exec (this=0x8e09c90) at thread/qthread.cpp:498
#9  0x01579e2d in QInotifyFileSystemWatcherEngine::run (this=0x8e09c90) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0149f7b3 in QThreadPrivate::start (arg=0x8e09c90) at thread/qthread_unix.cpp:331
#11 0x032969cd in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x00bdb0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xabdc7b70 (LWP 1826)):
#0  0x03b3790e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x03b37f9b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x053c8cea in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#3  0x03b5e5f4 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x032969cd in ?? () from /usr/lib/nvidia-current/libGL.so.1
#5  0x00bdb0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb5e11720 (LWP 1811)):
[KCrash Handler]
#7  0x03566423 in ~QExplicitlySharedDataPointer (this=0x9fb1ebc, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#8  Solid::Device::~Device (this=0x9fb1ebc, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#9  0x04d1a30a in ~QHashNode (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#10 deleteNode2 (node=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#11 deleteNode (node=<optimized out>, this=0x903e7ac) at /usr/include/qt4/QtCore/qhash.h:507
#12 QHash<QString, Solid::Device>::remove (this=0x903e7ac, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#13 0x04d1a46a in remove (akey=..., this=0x903e7ac) at /usr/include/qt4/QtCore/qhash.h:784
#14 HotplugEngine::onDeviceRemoved (this=0x903e798, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#15 0x04d1cb23 in HotplugEngine::qt_metacall (this=0x903e798, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3a238) at ./hotplugengine.moc:81
#16 0x015a0b7d in metacall (argv=0xbfe3a238, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0x903e798) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x903e798, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbfe3a238) at kernel/qmetaobject.cpp:232
#18 0x015afa6a in QMetaObject::activate (sender=0x8c9b8b0, m=0x3619f98, local_signal_index=1, argv=0xbfe3a238) at kernel/qobject.cpp:3278
#19 0x03567a65 in Solid::DeviceNotifier::deviceRemoved (this=0x8c9b8b0, _t1=...) at ./devicenotifier.moc:94
#20 0x03568db4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x8c9b8b0, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#21 0x035695b3 in Solid::DeviceManagerPrivate::qt_metacall (this=0x8c9b8b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3a3b8) at ./devicemanager_p.moc:80
#22 0x015a0b7d in metacall (argv=0xbfe3a3b8, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x8c9b8b0) at kernel/qmetaobject.cpp:237
#23 QMetaObject::metacall (object=0x8c9b8b0, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfe3a3b8) at kernel/qmetaobject.cpp:232
#24 0x015afa6a in QMetaObject::activate (sender=0x8c9dd18, m=0x361b06c, local_signal_index=1, argv=0xbfe3a3b8) at kernel/qobject.cpp:3278
#25 0x0357ecd5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x8c9dd18, _t1=...) at ./ifaces/devicemanager.moc:94
#26 0x035c8548 in slotDeviceRemoved (opath=<optimized out>, this=0x8c9dd18) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#27 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x8c9dd18, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3a61c) at ./backends/upower/upowermanager.moc:78
#28 0x015a0b7d in metacall (argv=0xbfe3a61c, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x8c9dd18) at kernel/qmetaobject.cpp:237
#29 QMetaObject::metacall (object=0x8c9dd18, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfe3a61c) at kernel/qmetaobject.cpp:232
#30 0x015afa6a in QMetaObject::activate (sender=0x8c9dd24, m=0x8cac6c0, local_signal_index=4, argv=0xbfe3a61c) at kernel/qobject.cpp:3278
#31 0x009c5110 in QDBusInterfacePrivate::metacall (this=0x8c9e128, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbfe3a61c) at qdbusinterface.cpp:278
#32 0x009afd87 in QDBusConnectionPrivate::deliverCall (this=0x8599070, object=0x8c9dd24, msg=..., metaTypes=..., slotIdx=152025112) at qdbusintegrator.cpp:942
#33 0x009b9c26 in QDBusCallDeliveryEvent::placeMetaCall (this=0x92911b8, object=0x8c9dd24) at qdbusintegrator_p.h:103
#34 0x015b2b52 in QObject::event (this=0x8c9dd24, e=0x92911b8) at kernel/qobject.cpp:1217
#35 0x07021d54 in notify_helper (e=0x92911b8, receiver=0x8c9dd24, this=0x84c1278) at kernel/qapplication.cpp:4486
#36 QApplicationPrivate::notify_helper (this=0x84c1278, receiver=0x8c9dd24, e=0x92911b8) at kernel/qapplication.cpp:4458
#37 0x07027103 in QApplication::notify (this=0x92911b8, receiver=0x8c9dd24, e=0x92911b8) at kernel/qapplication.cpp:3886
#38 0x011e1971 in KApplication::notify (this=0x84b75a8, receiver=0x8c9dd24, event=0x92911b8) at ../../kdeui/kernel/kapplication.cpp:311
#39 0x0159a19e in QCoreApplication::notifyInternal (this=0x84b75a8, receiver=0x8c9dd24, event=0x92911b8) at kernel/qcoreapplication.cpp:787
#40 0x0159df93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x84262e0) at kernel/qcoreapplication.cpp:1428
#42 0x0159e0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#43 0x015c86a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#44 postEventSourceDispatch (s=0x84c4da8) at kernel/qeventdispatcher_glib.cpp:277
#45 0x03b3725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0x03b37990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0x03b37c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0x015c8ada in QEventDispatcherGlib::processEvents (this=0x8427248, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#49 0x070d9e3a in QGuiEventDispatcherGlib::processEvents (this=0x8427248, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x015991dd in QEventLoop::processEvents (this=0xbfe3acb4, flags=...) at kernel/qeventloop.cpp:149
#51 0x01599421 in QEventLoop::exec (this=0xbfe3acb4, flags=...) at kernel/qeventloop.cpp:201
#52 0x0159e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#53 0x0701f8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#54 0x00ec118b in kdemain (argc=1, argv=0xbfe3aeb4) at ../../../../plasma/desktop/shell/main.cpp:120
#55 0x0804850b in main (argc=1, argv=0xbfe3aeb4) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 290426, bug 290045, bug 289976, bug 289526, bug 289429.

Reported using DrKonqi
Comment 1 Thijs 2012-01-03 09:15:27 UTC

*** This bug has been marked as a duplicate of bug 266383 ***