Bug 299188 - Plasma gives an error when Changing between Desktops.
Summary: Plasma gives an error when Changing between Desktops.
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-01 18:19 UTC by Luis Hurtado
Modified: 2012-05-02 02:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Hurtado 2012-05-01 18:19:12 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.2.0-2-amd64 x86_64
Distribution: Debian GNU/Linux testing (wheezy)

-- Information about the crash:
- What I was doing when the application crashed:

I was changing between desktops and apparently Desktop 1 appeared after 3 or 4presses of the combination Win+Tab.

-- Backtrace:
Application: Shell de escritorio Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3ac9e1c780 (LWP 2503))]

Thread 2 (Thread 0x7f3aa5d49700 (LWP 2505)):
#0  0x00007f3ac970a93d in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f3abd4d82ef in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3abd49d5bd in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3abd49da96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f3abd49dc24 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f3ac68674a6 in QEventDispatcherGlib::processEvents (this=0x262e870, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f3ac683b972 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3ac683bb6f in QEventLoop::exec (this=0x7f3aa5d48dd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f3ac67534af in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x00007f3ac681e9cf in QInotifyFileSystemWatcherEngine::run (this=0x262ddb0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f3ac6755ec5 in QThreadPrivate::start (arg=0x262ddb0) at thread/qthread_unix.cpp:331
#11 0x00007f3abe1adb50 in start_thread (arg=<optimized out>) at pthread_create.c:304
#12 0x00007f3ac971690d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3ac9e1c780 (LWP 2503)):
[KCrash Handler]
#6  0x00007f3ac1e3c4f2 in ~QExplicitlySharedDataPointer (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#7  Solid::Device::~Device (this=<optimized out>, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#8  0x00007f3a9dd6e281 in ~QHashNode (this=0x2bad800, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#9  deleteNode2 (node=0x2bad800) at /usr/include/qt4/QtCore/qhash.h:519
#10 deleteNode (node=0x2bad800, this=0x2d639d8) at /usr/include/qt4/QtCore/qhash.h:507
#11 QHash<QString, Solid::Device>::remove (this=0x2d639d8, akey=...) at /usr/include/qt4/QtCore/qhash.h:795
#12 0x00007f3a9dd6e3dc in remove (akey=..., this=0x2d639d8) at /usr/include/qt4/QtCore/qhash.h:784
#13 HotplugEngine::onDeviceRemoved (this=0x2d639b0, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#14 0x00007f3a9dd706a9 in HotplugEngine::qt_metacall (this=0x2d639b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6a09a3d0) at ./hotplugengine.moc:81
#15 0x00007f3ac684f4ba in QMetaObject::activate (sender=0x2629b40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6a09a3d0) at kernel/qobject.cpp:3278
#16 0x00007f3ac1e3d875 in Solid::DeviceNotifier::deviceRemoved (this=<optimized out>, _t1=...) at ./devicenotifier.moc:94
#17 0x00007f3ac1e3ea5d in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x2629b40, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#18 0x00007f3ac1e3f219 in Solid::DeviceManagerPrivate::qt_metacall (this=0x2629b40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6a09a580) at ./devicemanager_p.moc:80
#19 0x00007f3ac684f4ba in QMetaObject::activate (sender=0x262e3c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6a09a580) at kernel/qobject.cpp:3278
#20 0x00007f3ac1e51a25 in Solid::Ifaces::DeviceManager::deviceRemoved (this=<optimized out>, _t1=...) at ./ifaces/devicemanager.moc:94
#21 0x00007f3ac1e922f6 in slotDeviceRemoved (opath=..., this=0x262e3c0) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#22 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x262e3c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6a09a8e0) at ./backends/upower/upowermanager.moc:78
#23 0x00007f3ac684f4ba in QMetaObject::activate (sender=0x262e3d8, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6a09a8e0) at kernel/qobject.cpp:3278
#24 0x00007f3ac6ba36ad in QDBusInterfacePrivate::metacall (this=0x7f3aa00009d0, c=<optimized out>, id=4, argv=0x7fff6a09a8e0) at qdbusinterface.cpp:278
#25 0x00007f3ac6b8f9ab in QDBusConnectionPrivate::deliverCall (this=0x1942c90, object=0x262e3d8, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:942
#26 0x00007f3ac6b98cbf in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#27 0x00007f3ac685306a in QObject::event (this=0x262e3d8, e=<optimized out>) at kernel/qobject.cpp:1217
#28 0x00007f3ac5c0bdf4 in notify_helper (e=0x36acda0, receiver=0x262e3d8, this=0x1825f80) at kernel/qapplication.cpp:4486
#29 QApplicationPrivate::notify_helper (this=0x1825f80, receiver=0x262e3d8, e=0x36acda0) at kernel/qapplication.cpp:4458
#30 0x00007f3ac5c10c81 in QApplication::notify (this=0x1818d10, receiver=0x262e3d8, e=0x36acda0) at kernel/qapplication.cpp:4365
#31 0x00007f3ac7536b26 in KApplication::notify (this=0x1818d10, receiver=0x262e3d8, event=0x36acda0) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007f3ac683c76c in QCoreApplication::notifyInternal (this=0x1818d10, receiver=0x262e3d8, event=0x36acda0) at kernel/qcoreapplication.cpp:787
#33 0x00007f3ac683fb48 in sendEvent (event=0x36acda0, receiver=0x262e3d8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x17ad430) at kernel/qcoreapplication.cpp:1428
#35 0x00007f3ac6866fe3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#36 postEventSourceDispatch (s=0x1828000) at kernel/qeventdispatcher_glib.cpp:277
#37 0x00007f3abd49d79a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007f3abd49db60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f3abd49dc24 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f3ac686743f in QEventDispatcherGlib::processEvents (this=0x17aef40, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x00007f3ac5cb02ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00007f3ac683b972 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#43 0x00007f3ac683bb6f in QEventLoop::exec (this=0x7fff6a09b270, flags=...) at kernel/qeventloop.cpp:201
#44 0x00007f3ac683fd37 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x00007f3ac9a086a3 in kdemain (argc=1, argv=0x7fff6a09b658) at ../../../../plasma/desktop/shell/main.cpp:120
#46 0x00007f3ac965cead in __libc_start_main (main=<optimized out>, argc=<optimized out>, ubp_av=<optimized out>, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff6a09b648) at libc-start.c:228
#47 0x00000000004006f1 in _start ()

Possible duplicates by query: bug 298579, bug 294357, bug 294324, bug 294036, bug 291844.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-02 02:00:37 UTC

*** This bug has been marked as a duplicate of bug 266383 ***