Bug 291844 - Plug in the power to laptop
Summary: Plug in the power to laptop
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 10:23 UTC by m4v
Modified: 2012-01-18 14:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m4v 2012-01-18 10:23:30 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Plasma crasched just when I plug off and plug in the power to my laptop.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Powłoka pulpitu Plazmy (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5b3c720 (LWP 1669))]

Thread 3 (Thread 0xaf8c0b70 (LWP 1670)):
#0  0x056e1d37 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00e08f54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x01b2820b in g_main_context_release () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01b29906 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01b29c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x02f80b37 in QEventDispatcherGlib::processEvents (this=0x8c95188, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x02f511dd in QEventLoop::processEvents (this=0xaf8c01f0, flags=...) at kernel/qeventloop.cpp:149
#7  0x02f51421 in QEventLoop::exec (this=0xaf8c01f0, flags=...) at kernel/qeventloop.cpp:201
#8  0x02e5490b in QThread::exec (this=0x8c91580) at thread/qthread.cpp:498
#9  0x02f31e2d in QInotifyFileSystemWatcherEngine::run (this=0x8c91580) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x02e577b3 in QThreadPrivate::start (arg=0x8c91580) at thread/qthread_unix.cpp:331
#11 0x0253aa9c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x00000000 in ?? ()

Thread 2 (Thread 0xadd50b70 (LWP 1671)):
#0  0x076dad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x02eae7d5 in do_gettime (frac=0xadd4ff60, sec=0xadd4ff58) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x02f814b6 in QTimerInfoList::updateCurrentTime (this=0x8e37b9c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x02f8180a in QTimerInfoList::timerWait (this=0x8e37b9c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x02f80053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xadd5006c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x02f800ed in timerSourcePrepare (source=0x8e37b68, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01b2888c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01b29637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01b29c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x02f80b37 in QEventDispatcherGlib::processEvents (this=0x8e37a88, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x02f511dd in QEventLoop::processEvents (this=0xadd501f0, flags=...) at kernel/qeventloop.cpp:149
#12 0x02f51421 in QEventLoop::exec (this=0xadd501f0, flags=...) at kernel/qeventloop.cpp:201
#13 0x02e5490b in QThread::exec (this=0x8e33c80) at thread/qthread.cpp:498
#14 0x02f31e2d in QInotifyFileSystemWatcherEngine::run (this=0x8e33c80) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x02e577b3 in QThreadPrivate::start (arg=0x8e33c80) at thread/qthread_unix.cpp:331
#16 0x0253aa9c in ?? () from /usr/lib/nvidia-current/libGL.so.1
#17 0x00000000 in ?? ()

Thread 1 (Thread 0xb5b3c720 (LWP 1669)):
[KCrash Handler]
#7  0x00000002 in ?? ()
#8  0x01390426 in ~QExplicitlySharedDataPointer (this=0x90d78dc, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#9  Solid::Device::~Device (this=0x90d78dc, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#10 0x03e1c30a in ~QHashNode (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#11 deleteNode2 (node=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#12 deleteNode (node=<optimized out>, this=0x902c004) at /usr/include/qt4/QtCore/qhash.h:507
#13 QHash<QString, Solid::Device>::remove (this=0x902c004, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#14 0x03e1c46a in remove (akey=..., this=0x902c004) at /usr/include/qt4/QtCore/qhash.h:784
#15 HotplugEngine::onDeviceRemoved (this=0x902bff0, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#16 0x03e1eb23 in HotplugEngine::qt_metacall (this=0x902bff0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd544c8) at ./hotplugengine.moc:81
#17 0x02f58b7d in metacall (argv=0xbfd544c8, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0x902bff0) at kernel/qmetaobject.cpp:237
#18 QMetaObject::metacall (object=0x902bff0, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbfd544c8) at kernel/qmetaobject.cpp:232
#19 0x02f67a6a in QMetaObject::activate (sender=0x8c90998, m=0x1443f98, local_signal_index=1, argv=0xbfd544c8) at kernel/qobject.cpp:3278
#20 0x01391a65 in Solid::DeviceNotifier::deviceRemoved (this=0x8c90998, _t1=...) at ./devicenotifier.moc:94
#21 0x01392db4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x8c90998, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#22 0x013935b3 in Solid::DeviceManagerPrivate::qt_metacall (this=0x8c90998, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd54648) at ./devicemanager_p.moc:80
#23 0x02f58b7d in metacall (argv=0xbfd54648, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x8c90998) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8c90998, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfd54648) at kernel/qmetaobject.cpp:232
#25 0x02f67a6a in QMetaObject::activate (sender=0x8c94ed8, m=0x144506c, local_signal_index=1, argv=0xbfd54648) at kernel/qobject.cpp:3278
#26 0x013a8cd5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x8c94ed8, _t1=...) at ./ifaces/devicemanager.moc:94
#27 0x013f2548 in slotDeviceRemoved (opath=<optimized out>, this=0x8c94ed8) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#28 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x8c94ed8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd548ac) at ./backends/upower/upowermanager.moc:78
#29 0x02f58b7d in metacall (argv=0xbfd548ac, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x8c94ed8) at kernel/qmetaobject.cpp:237
#30 QMetaObject::metacall (object=0x8c94ed8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfd548ac) at kernel/qmetaobject.cpp:232
#31 0x02f67a6a in QMetaObject::activate (sender=0x8c94ee4, m=0x8caa808, local_signal_index=4, argv=0xbfd548ac) at kernel/qobject.cpp:3278
#32 0x006c5110 in QDBusInterfacePrivate::metacall (this=0x8c95270, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbfd548ac) at qdbusinterface.cpp:278
#33 0x006afd87 in QDBusConnectionPrivate::deliverCall (this=0x863bdd0, object=0x8c94ee4, msg=..., metaTypes=..., slotIdx=153057224) at qdbusintegrator.cpp:942
#34 0x006b9c26 in QDBusCallDeliveryEvent::placeMetaCall (this=0x94d8448, object=0x8c94ee4) at qdbusintegrator_p.h:103
#35 0x02f6ab52 in QObject::event (this=0x8c94ee4, e=0x94d8448) at kernel/qobject.cpp:1217
#36 0x04487d54 in notify_helper (e=0x94d8448, receiver=0x8c94ee4, this=0x852ac58) at kernel/qapplication.cpp:4486
#37 QApplicationPrivate::notify_helper (this=0x852ac58, receiver=0x8c94ee4, e=0x94d8448) at kernel/qapplication.cpp:4458
#38 0x0448d103 in QApplication::notify (this=0x94d8448, receiver=0x8c94ee4, e=0x94d8448) at kernel/qapplication.cpp:3886
#39 0x03482681 in KApplication::notify (this=0x8516918, receiver=0x8c94ee4, event=0x94d8448) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x02f5219e in QCoreApplication::notifyInternal (this=0x8516918, receiver=0x8c94ee4, event=0x94d8448) at kernel/qcoreapplication.cpp:787
#41 0x02f55f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x84902e0) at kernel/qcoreapplication.cpp:1428
#43 0x02f560ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#44 0x02f806a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x852d1d8) at kernel/qeventdispatcher_glib.cpp:277
#46 0x01b2925f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0x01b29990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0x01b29c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#49 0x02f80ada in QEventDispatcherGlib::processEvents (this=0x8491218, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#50 0x0453fe3a in QGuiEventDispatcherGlib::processEvents (this=0x8491218, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x02f511dd in QEventLoop::processEvents (this=0xbfd54f44, flags=...) at kernel/qeventloop.cpp:149
#52 0x02f51421 in QEventLoop::exec (this=0xbfd54f44, flags=...) at kernel/qeventloop.cpp:201
#53 0x02f5619d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#54 0x044858f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#55 0x00ba218b in kdemain (argc=1, argv=0xbfd55144) at ../../../../plasma/desktop/shell/main.cpp:120
#56 0x0804850b in main (argc=1, argv=0xbfd55144) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 291066, bug 290475, bug 290426, bug 290045, bug 289976.

Reported using DrKonqi
Comment 1 Thijs 2012-01-18 14:58:15 UTC

*** This bug has been marked as a duplicate of bug 266383 ***