Bug 302694 - Plasma Desktop crash when screen saver running
Summary: Plasma Desktop crash when screen saver running
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-28 12:08 UTC by mell4douglas
Modified: 2012-06-28 12:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mell4douglas 2012-06-28 12:08:00 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.11-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
Open Firefox windows running flash advertisments, screen saver running, random crashes, kills app launcher when plasma crashes.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f81b82b7760 (LWP 2762))]

Thread 2 (Thread 0x7f819ac9a700 (LWP 2764)):
#0  0x00007f81b59b15a3 in poll () from /lib64/libc.so.6
#1  0x00007f81b2822114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f81b2822650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f81b6fa2956 in QEventDispatcherGlib::processEvents (this=0xc30610, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f81b6f77032 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f81b6f77245 in QEventLoop::exec (this=0x7f819ac99d20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f81b6e8c1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f81b6f58948 in QInotifyFileSystemWatcherEngine::run (this=0xc3ee80) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f81b6e8ea5e in QThreadPrivate::start (arg=0xc3ee80) at thread/qthread_unix.cpp:285
#9  0x00007f81aa3dcb74 in ?? () from /usr/X11R6/lib64/libGL.so.1
#10 0x00007f81b6bffa3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f81b59ba71d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f81b82b7760 (LWP 2762)):
[KCrash Handler]
#6  0x0000000000000008 in ?? ()
#7  0x00007f819aca1f5a in ~QHashNode (this=0xc1e308, akey=<value optimized out>) at /usr/include/QtCore/qhash.h:217
#8  deleteNode2 (this=0xc1e308, akey=<value optimized out>) at /usr/include/QtCore/qhash.h:519
#9  deleteNode (this=0xc1e308, akey=<value optimized out>) at /usr/include/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0xc1e308, akey=<value optimized out>) at /usr/include/QtCore/qhash.h:795
#11 0x00007f819ac9f33c in HotplugEngine::onDeviceRemoved (this=0xc1e2e0, udi=...) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/generic/dataengines/hotplug/hotplugengine.cpp:243
#12 0x00007f819aca15c9 in HotplugEngine::qt_metacall (this=0xc1e2e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffe8c53040) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/generic/dataengines/hotplug/hotplugengine.moc:81
#13 0x00007f81b6f8cdcf in QMetaObject::activate (sender=0xc2fc90, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffe8c53040) at kernel/qobject.cpp:3272
#14 0x00007f81af8eb565 in Solid::DeviceNotifier::deviceRemoved (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/build/solid/solid/devicenotifier.moc:94
#15 0x00007f81af8ec247 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0xc2fc90, udi=...) at /usr/src/debug/kdelibs-4.6.0/solid/solid/devicemanager.cpp:207
#16 0x00007f81af8ec999 in Solid::DeviceManagerPrivate::qt_metacall (this=0xc2fc90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffe8c53200) at /usr/src/debug/kdelibs-4.6.0/build/solid/solid/devicemanager_p.moc:80
#17 0x00007f81b6f8cdcf in QMetaObject::activate (sender=0xc3fe80, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffe8c53200) at kernel/qobject.cpp:3272
#18 0x00007f81af8fe415 in Solid::Ifaces::DeviceManager::deviceRemoved (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/build/solid/solid/ifaces/devicemanager.moc:94
#19 0x00007f81af9427bc in Solid::Backends::UDisks::UDisksManager::slotDeviceRemoved (this=0xc3fe80, opath=...) at /usr/src/debug/kdelibs-4.6.0/solid/solid/backends/udisks/udisksmanager.cpp:217
#20 0x00007f81af9429f9 in Solid::Backends::UDisks::UDisksManager::qt_metacall (this=0xc3fe80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffe8c53650) at /usr/src/debug/kdelibs-4.6.0/build/solid/solid/backends/udisks/udisksmanager.moc:80
#21 0x00007f81b6f8cdcf in QMetaObject::activate (sender=0xc3fea0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffe8c53650) at kernel/qobject.cpp:3272
#22 0x00007f81b3de0def in QDBusInterfacePrivate::metacall (this=0xc327f0, c=<value optimized out>, id=6, argv=0x7fffe8c53650) at qdbusinterface.cpp:278
#23 0x00007f81b3dcbb68 in QDBusConnectionPrivate::deliverCall (this=0x7ff260, object=0xc3fea0, msg=..., metaTypes=..., slotIdx=11) at qdbusintegrator.cpp:919
#24 0x00007f81b3dd6c1f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#25 0x00007f81b6f8ba4a in QObject::event (this=0xc3fea0, e=<value optimized out>) at kernel/qobject.cpp:1211
#26 0x00007f81b6126d14 in QApplicationPrivate::notify_helper (this=0x75ddd0, receiver=0xc3fea0, e=0x1a9c710) at kernel/qapplication.cpp:4445
#27 0x00007f81b612f22a in QApplication::notify (this=<value optimized out>, receiver=0xc3fea0, e=0x1a9c710) at kernel/qapplication.cpp:4324
#28 0x00007f81b7c1b9e6 in KApplication::notify (this=0x719b80, receiver=0xc3fea0, event=0x1a9c710) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#29 0x00007f81b6f77bdc in QCoreApplication::notifyInternal (this=0x719b80, receiver=0xc3fea0, event=0x1a9c710) at kernel/qcoreapplication.cpp:732
#30 0x00007f81b6f7b3d5 in sendEvent (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.cpp:1373
#32 0x00007f81b6fa2763 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f81b2821bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#35 0x00007f81b28223b0 in ?? () from /lib64/libglib-2.0.so.0
#36 0x00007f81b2822650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#37 0x00007f81b6fa28ff in QEventDispatcherGlib::processEvents (this=0x71a5c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#38 0x00007f81b61cbd8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f81b6f77032 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#40 0x00007f81b6f77245 in QEventLoop::exec (this=0x7fffe8c54080, flags=...) at kernel/qeventloop.cpp:201
#41 0x00007f81b6f7b68b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f81a55fdda8 in kdemain (argc=1, argv=0x6b5400) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#43 0x00000000004075e9 in _start ()

This bug may be a duplicate of or related to bug 266383.

Possible duplicates by query: bug 301508, bug 299188, bug 298579, bug 297083, bug 296847.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-28 12:23:15 UTC

*** This bug has been marked as a duplicate of bug 266383 ***