Bug 294357 - plasma-crash when closing encrypted drive
Summary: plasma-crash when closing encrypted drive
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 12:24 UTC by Heiko Boysen
Modified: 2012-02-18 12:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Boysen 2012-02-18 12:24:50 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.9-1.4-desktop i686
Distribution: "openSUSE 12.1 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
- I closed 2 encrypted drives and after the drives were closed, the plasma-desktop crashed
The drives were mounted/unmounted as superuser in a terminal.

The crash does not seem to be reproducible.

-- Backtrace:
Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb57a4710 (LWP 5283))]

Thread 2 (Thread 0xa8984b70 (LWP 5287)):
#0  0xb601e994 in poll () from /lib/libc.so.6
#1  0xb5a2cf7b in g_poll () from /usr/lib/libglib-2.0.so.0
#2  0xb5a1e466 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb5a1e7fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb6e068a7 in QEventDispatcherGlib::processEvents (this=0xa8000478, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0xb6dd745d in QEventLoop::processEvents (this=0xa8984200, flags=...) at kernel/qeventloop.cpp:149
#6  0xb6dd76a1 in QEventLoop::exec (this=0xa8984200, flags=...) at kernel/qeventloop.cpp:201
#7  0xb6cda75b in QThread::exec (this=0x884ccb0) at thread/qthread.cpp:498
#8  0xb6db809d in QInotifyFileSystemWatcherEngine::run (this=0x884ccb0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0xb6cdd613 in QThreadPrivate::start (arg=0x884ccb0) at thread/qthread_unix.cpp:331
#10 0xb21f3a9c in ?? () from /usr/X11R6/lib/libGL.so.1
#11 0x00000000 in ?? ()

Thread 1 (Thread 0xb57a4710 (LWP 5283)):
[KCrash Handler]
#6  0xb5141bf3 in ~QExplicitlySharedDataPointer (this=0x8d2af44, __in_chrg=<optimized out>) at /usr/include/QtCore/qshareddata.h:161
#7  Solid::Device::~Device (this=0x8d2af44, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.7.2/solid/solid/device.cpp:87
#8  0xa8a2061a in ~QHashNode (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/QtCore/qhash.h:216
#9  deleteNode2 (node=<optimized out>) at /usr/include/QtCore/qhash.h:519
#10 deleteNode (node=<optimized out>, this=0x889dfa4) at /usr/include/QtCore/qhash.h:507
#11 QHash<QString, Solid::Device>::remove (this=0x889dfa4, akey=<optimized out>) at /usr/include/QtCore/qhash.h:795
#12 0xa8a2078a in remove (akey=..., this=0x889dfa4) at /usr/include/QtCore/qhash.h:784
#13 HotplugEngine::onDeviceRemoved (this=0x889df90, udi=...) at /usr/src/debug/kde-workspace-4.7.2/plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#14 0xa8a22e43 in HotplugEngine::qt_metacall (this=0x889df90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8e8038) at /usr/src/debug/kde-workspace-4.7.2/build/plasma/generic/dataengines/hotplug/hotplugengine.moc:81
#15 0xb6dde7ed in metacall (argv=0xbf8e8038, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0x889df90) at kernel/qmetaobject.cpp:237
#16 QMetaObject::metacall (object=0x889df90, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbf8e8038) at kernel/qmetaobject.cpp:232
#17 0xb6ded720 in QMetaObject::activate (sender=0x889c798, m=0xb51f5f98, local_signal_index=1, argv=0xbf8e8038) at kernel/qobject.cpp:3287
#18 0xb5143235 in Solid::DeviceNotifier::deviceRemoved (this=0x889c798, _t1=...) at /usr/src/debug/kdelibs-4.7.2/build/solid/solid/devicenotifier.moc:94
#19 0xb51444a4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x889c798, udi=...) at /usr/src/debug/kdelibs-4.7.2/solid/solid/devicemanager.cpp:207
#20 0xb5144ca3 in Solid::DeviceManagerPrivate::qt_metacall (this=0x889c798, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8e81b8) at /usr/src/debug/kdelibs-4.7.2/build/solid/solid/devicemanager_p.moc:80
#21 0xb6dde7ed in metacall (argv=0xbf8e81b8, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x889c798) at kernel/qmetaobject.cpp:237
#22 QMetaObject::metacall (object=0x889c798, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf8e81b8) at kernel/qmetaobject.cpp:232
#23 0xb6ded720 in QMetaObject::activate (sender=0x884c750, m=0xb51f706c, local_signal_index=1, argv=0xbf8e81b8) at kernel/qobject.cpp:3287
#24 0xb5159f85 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x884c750, _t1=...) at /usr/src/debug/kdelibs-4.7.2/build/solid/solid/ifaces/devicemanager.moc:94
#25 0xb51aa28f in Solid::Backends::UDisks::UDisksManager::slotDeviceRemoved (this=0x884c750, opath=...) at /usr/src/debug/kdelibs-4.7.2/solid/solid/backends/udisks/udisksmanager.cpp:217
#26 0xb51aa5c3 in Solid::Backends::UDisks::UDisksManager::qt_metacall (this=0x884c750, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8e849c) at /usr/src/debug/kdelibs-4.7.2/build/solid/solid/backends/udisks/udisksmanager.moc:80
#27 0xb6dde7ed in metacall (argv=0xbf8e849c, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x884c750) at kernel/qmetaobject.cpp:237
#28 QMetaObject::metacall (object=0x884c750, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf8e849c) at kernel/qmetaobject.cpp:232
#29 0xb6ded720 in QMetaObject::activate (sender=0x884c760, m=0x894bc40, local_signal_index=6, argv=0xbf8e849c) at kernel/qobject.cpp:3287
#30 0xb5be2900 in QDBusInterfacePrivate::metacall (this=0x81e8d08, c=QMetaObject::InvokeMetaMethod, id=6, argv=0xbf8e849c) at qdbusinterface.cpp:278
#31 0xb5bcd400 in QDBusConnectionPrivate::deliverCall (this=0x81e69b8, object=0x884c760, msg=..., metaTypes=..., slotIdx=149212944) at qdbusintegrator.cpp:942
#32 0xb5bd7406 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8e1c1f0, object=0x884c760) at qdbusintegrator_p.h:103
#33 0xb6df083f in QObject::event (this=0x884c760, e=0x8e1c1f0) at kernel/qobject.cpp:1226
#34 0xb62f3f24 in notify_helper (e=0x8e1c1f0, receiver=0x884c760, this=0x8138b80) at kernel/qapplication.cpp:4481
#35 QApplicationPrivate::notify_helper (this=0x8138b80, receiver=0x884c760, e=0x8e1c1f0) at kernel/qapplication.cpp:4453
#36 0xb62f92b2 in QApplication::notify (this=0x8e1c1f0, receiver=0x884c760, e=0x8e1c1f0) at kernel/qapplication.cpp:4228
#37 0xb751c681 in KApplication::notify (this=0x812dbc8, receiver=0x884c760, event=0x8e1c1f0) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#38 0xb6dd843e in QCoreApplication::notifyInternal (this=0x812dbc8, receiver=0x884c760, event=0x8e1c1f0) at kernel/qcoreapplication.cpp:787
#39 0xb6ddbc04 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x805b1c0) at kernel/qcoreapplication.cpp:1428
#41 0xb6ddbd4c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#42 0xb6e06414 in sendPostedEvents () at kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=0x805bd80) at kernel/qeventdispatcher_glib.cpp:277
#44 0xb5a1de2f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#45 0xb5a1e560 in ?? () from /usr/lib/libglib-2.0.so.0
#46 0xb5a1e7fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#47 0xb6e06847 in QEventDispatcherGlib::processEvents (this=0x8135498, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#48 0xb63a7b1a in QGuiEventDispatcherGlib::processEvents (this=0x8135498, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0xb6dd745d in QEventLoop::processEvents (this=0xbf8e8c44, flags=...) at kernel/qeventloop.cpp:149
#50 0xb6dd76a1 in QEventLoop::exec (this=0xbf8e8c44, flags=...) at kernel/qeventloop.cpp:201
#51 0xb6ddbdfa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#52 0xb62f1da4 in QApplication::exec () at kernel/qapplication.cpp:3755
#53 0xb01307cb in kdemain (argc=1, argv=0x80ed600) at /usr/src/debug/kde-workspace-4.7.2/plasma/desktop/shell/main.cpp:120
#54 0x0804fbcd in _start ()

Possible duplicates by query: bug 294324, bug 294036, bug 291844, bug 291066, bug 290475.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-18 12:36:21 UTC

*** This bug has been marked as a duplicate of bug 266383 ***