Bug 294036 - Powered up, then opened Firefox.
Summary: Powered up, then opened Firefox.
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 02:14 UTC by jtdhome
Modified: 2012-02-14 02:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jtdhome 2012-02-14 02:14:50 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Linux Mint 12 KDE

-- Information about the crash:
- What I was doing when the application crashed:
Surfing with Firefox 10.0
Saw the perimeter of the screen flicker, then the crash notification appeared.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7808b20 (LWP 1545))]

Thread 4 (Thread 0xb09c1b70 (LWP 1739)):
#0  0x009a5416 in __kernel_vsyscall ()
#1  0x0021840e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x019e334b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x019d4896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x019d4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0242bb37 in QEventDispatcherGlib::processEvents (this=0xb0000468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x023fc1dd in QEventLoop::processEvents (this=0xb09c12a0, flags=...) at kernel/qeventloop.cpp:149
#7  0x023fc421 in QEventLoop::exec (this=0xb09c12a0, flags=...) at kernel/qeventloop.cpp:201
#8  0x022ff90b in QThread::exec (this=0x964dd98) at thread/qthread.cpp:498
#9  0x023dce2d in QInotifyFileSystemWatcherEngine::run (this=0x964dd98) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x023027b3 in QThreadPrivate::start (arg=0x964dd98) at thread/qthread_unix.cpp:331
#11 0x01968d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x002270ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xaf580b70 (LWP 1742)):
#0  0x00262b66 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0x00234ee8 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x019d38bb in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x019d4637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x019d4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0242bb37 in QEventDispatcherGlib::processEvents (this=0xb0002170, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x023fc1dd in QEventLoop::processEvents (this=0xaf5802a0, flags=...) at kernel/qeventloop.cpp:149
#7  0x023fc421 in QEventLoop::exec (this=0xaf5802a0, flags=...) at kernel/qeventloop.cpp:201
#8  0x022ff90b in QThread::exec (this=0x9889178) at thread/qthread.cpp:498
#9  0x023dce2d in QInotifyFileSystemWatcherEngine::run (this=0x9889178) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x023027b3 in QThreadPrivate::start (arg=0x9889178) at thread/qthread_unix.cpp:331
#11 0x01968d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x002270ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xadd7db70 (LWP 1748)):
#0  0x00234ee0 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#1  0x019d3f53 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x019d48f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x019d4f9b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x03d54cea in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#5  0x019fb5f4 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x01968d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#7  0x002270ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7808b20 (LWP 1545)):
[KCrash Handler]
#7  0x00000001 in ?? ()
#8  0x06184426 in ~QExplicitlySharedDataPointer (this=0x9aa99a4, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#9  Solid::Device::~Device (this=0x9aa99a4, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#10 0x0322a30a in ~QHashNode (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#11 deleteNode2 (node=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#12 deleteNode (node=<optimized out>, this=0x99127ac) at /usr/include/qt4/QtCore/qhash.h:507
#13 QHash<QString, Solid::Device>::remove (this=0x99127ac, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#14 0x0322a46a in remove (akey=..., this=0x99127ac) at /usr/include/qt4/QtCore/qhash.h:784
#15 HotplugEngine::onDeviceRemoved (this=0x9912798, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#16 0x0322cb23 in HotplugEngine::qt_metacall (this=0x9912798, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf934608) at ./hotplugengine.moc:81
#17 0x02403b7d in metacall (argv=0xbf934608, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0x9912798) at kernel/qmetaobject.cpp:237
#18 QMetaObject::metacall (object=0x9912798, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbf934608) at kernel/qmetaobject.cpp:232
#19 0x02412a6a in QMetaObject::activate (sender=0x9894520, m=0x6237f98, local_signal_index=1, argv=0xbf934608) at kernel/qobject.cpp:3278
#20 0x06185a65 in Solid::DeviceNotifier::deviceRemoved (this=0x9894520, _t1=...) at ./devicenotifier.moc:94
#21 0x06186db4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x9894520, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#22 0x061875b3 in Solid::DeviceManagerPrivate::qt_metacall (this=0x9894520, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf934788) at ./devicemanager_p.moc:80
#23 0x02403b7d in metacall (argv=0xbf934788, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x9894520) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9894520, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf934788) at kernel/qmetaobject.cpp:232
#25 0x02412a6a in QMetaObject::activate (sender=0x988ad00, m=0x623906c, local_signal_index=1, argv=0xbf934788) at kernel/qobject.cpp:3278
#26 0x0619ccd5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x988ad00, _t1=...) at ./ifaces/devicemanager.moc:94
#27 0x061e6548 in slotDeviceRemoved (opath=<optimized out>, this=0x988ad00) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#28 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x988ad00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9349ec) at ./backends/upower/upowermanager.moc:78
#29 0x02403b7d in metacall (argv=0xbf9349ec, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x988ad00) at kernel/qmetaobject.cpp:237
#30 QMetaObject::metacall (object=0x988ad00, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf9349ec) at kernel/qmetaobject.cpp:232
#31 0x02412a6a in QMetaObject::activate (sender=0x988ad0c, m=0x989be38, local_signal_index=4, argv=0xbf9349ec) at kernel/qobject.cpp:3278
#32 0x00bf6110 in QDBusInterfacePrivate::metacall (this=0x988b088, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbf9349ec) at qdbusinterface.cpp:278
#33 0x00be0d87 in QDBusConnectionPrivate::deliverCall (this=0x91d7c28, object=0x988ad0c, msg=..., metaTypes=..., slotIdx=162104760) at qdbusintegrator.cpp:942
#34 0x00beac26 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9cbe5f0, object=0x988ad0c) at qdbusintegrator_p.h:103
#35 0x02415b52 in QObject::event (this=0x988ad0c, e=0x9cbe5f0) at kernel/qobject.cpp:1217
#36 0x08460d84 in notify_helper (e=0x9cbe5f0, receiver=0x988ad0c, this=0x90ff770) at kernel/qapplication.cpp:4486
#37 QApplicationPrivate::notify_helper (this=0x90ff770, receiver=0x988ad0c, e=0x9cbe5f0) at kernel/qapplication.cpp:4458
#38 0x08466133 in QApplication::notify (this=0x9cbe5f0, receiver=0x988ad0c, e=0x9cbe5f0) at kernel/qapplication.cpp:3886
#39 0x01022971 in KApplication::notify (this=0x90eefe8, receiver=0x988ad0c, event=0x9cbe5f0) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x023fd19e in QCoreApplication::notifyInternal (this=0x90eefe8, receiver=0x988ad0c, event=0x9cbe5f0) at kernel/qcoreapplication.cpp:787
#41 0x02400f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x90b02e0) at kernel/qcoreapplication.cpp:1428
#43 0x024010ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#44 0x0242b6a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x9102300) at kernel/qeventdispatcher_glib.cpp:277
#46 0x019d425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0x019d4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0x019d4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#49 0x0242bada in QEventDispatcherGlib::processEvents (this=0x90b6a98, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#50 0x08518e7a in QGuiEventDispatcherGlib::processEvents (this=0x90b6a98, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x023fc1dd in QEventLoop::processEvents (this=0xbf935084, flags=...) at kernel/qeventloop.cpp:149
#52 0x023fc421 in QEventLoop::exec (this=0xbf935084, flags=...) at kernel/qeventloop.cpp:201
#53 0x0240119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#54 0x0845e924 in QApplication::exec () at kernel/qapplication.cpp:3760
#55 0x0032718b in kdemain (argc=1, argv=0xbf935284) at ../../../../plasma/desktop/shell/main.cpp:120
#56 0x0804850b in main (argc=1, argv=0xbf935284) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 279287.

Possible duplicates by query: bug 291844, bug 291066, bug 290475, bug 290426, bug 290045.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-14 02:35:10 UTC

*** This bug has been marked as a duplicate of bug 266383 ***