Bug 284045 - Plasma crash when resume from disk (hibernate)
Summary: Plasma crash when resume from disk (hibernate)
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-15 03:53 UTC by Tom Chiverton
Modified: 2011-10-17 00:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Chiverton 2011-10-15 03:53:36 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.1.0-0301rc9-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Resumed from disk, Plasma crashed. Only had FireFox and Kontact to restore.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb1f82b20 (LWP 2059))]

Thread 3 (Thread 0xaf5f7b70 (LWP 2081)):
#0  0xb30bbd44 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb76d5f54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2f9df1f in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2f9e8f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2f9ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6515b37 in QEventDispatcherGlib::processEvents (this=0x9c000f8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb64e61dd in QEventLoop::processEvents (this=0xaf5f72a0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb64e6421 in QEventLoop::exec (this=0xaf5f72a0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb63e990b in QThread::exec (this=0x9beaad8) at thread/qthread.cpp:498
#9  0xb64c6e2d in QInotifyFileSystemWatcherEngine::run (this=0x9beaad8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb63ec7b3 in QThreadPrivate::start (arg=0x9beaad8) at thread/qthread_unix.cpp:331
#11 0xb30b8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb76c80ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa8bfdb70 (LWP 2082)):
#0  0xb3058d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb64437d5 in do_gettime (frac=0xa8bfd010, sec=0xa8bfd008) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb65164b6 in QTimerInfoList::updateCurrentTime (this=0x9e324b4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb651680a in QTimerInfoList::timerWait (this=0x9e324b4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6515053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xa8bfd11c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb65150ed in timerSourcePrepare (source=0x9e32480, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb2f9d88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb2f9e637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb2f9ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6515b37 in QEventDispatcherGlib::processEvents (this=0x9e30c40, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb64e61dd in QEventLoop::processEvents (this=0xa8bfd2a0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb64e6421 in QEventLoop::exec (this=0xa8bfd2a0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb63e990b in QThread::exec (this=0x9e2fde8) at thread/qthread.cpp:498
#14 0xb64c6e2d in QInotifyFileSystemWatcherEngine::run (this=0x9e2fde8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb63ec7b3 in QThreadPrivate::start (arg=0x9e2fde8) at thread/qthread_unix.cpp:331
#16 0xb30b8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb76c80ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb1f82b20 (LWP 2059)):
[KCrash Handler]
#7  0x00000001 in ?? ()
#8  0xb37a6426 in ~QExplicitlySharedDataPointer (this=0x9c2e6b4, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#9  Solid::Device::~Device (this=0x9c2e6b4, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#10 0xa837230a in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#11 0xa837246a in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#12 0xa8374b23 in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#13 0xb64edb7d in metacall (argv=0xbf885988, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0x9fbeec0) at kernel/qmetaobject.cpp:237
#14 QMetaObject::metacall (object=0x9fbeec0, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbf885988) at kernel/qmetaobject.cpp:232
#15 0xb64fca6a in QMetaObject::activate (sender=0x9bfb800, m=0xb3858f98, local_signal_index=1, argv=0xbf885988) at kernel/qobject.cpp:3278
#16 0xb37a7a65 in Solid::DeviceNotifier::deviceRemoved (this=0x9bfb800, _t1=...) at ./devicenotifier.moc:94
#17 0xb37a8db4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x9bfb800, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#18 0xb37a95b3 in Solid::DeviceManagerPrivate::qt_metacall (this=0x9bfb800, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf885b08) at ./devicemanager_p.moc:80
#19 0xb64edb7d in metacall (argv=0xbf885b08, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x9bfb800) at kernel/qmetaobject.cpp:237
#20 QMetaObject::metacall (object=0x9bfb800, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf885b08) at kernel/qmetaobject.cpp:232
#21 0xb64fca6a in QMetaObject::activate (sender=0x9c001b8, m=0xb385a06c, local_signal_index=1, argv=0xbf885b08) at kernel/qobject.cpp:3278
#22 0xb37becd5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x9c001b8, _t1=...) at ./ifaces/devicemanager.moc:94
#23 0xb3808548 in slotDeviceRemoved (opath=<optimized out>, this=0x9c001b8) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#24 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x9c001b8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf885d6c) at ./backends/upower/upowermanager.moc:78
#25 0xb64edb7d in metacall (argv=0xbf885d6c, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x9c001b8) at kernel/qmetaobject.cpp:237
#26 QMetaObject::metacall (object=0x9c001b8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf885d6c) at kernel/qmetaobject.cpp:232
#27 0xb64fca6a in QMetaObject::activate (sender=0x9c001c4, m=0x9c0bfa8, local_signal_index=4, argv=0xbf885d6c) at kernel/qobject.cpp:3278
#28 0xb6656110 in QDBusInterfacePrivate::metacall (this=0xafb011c8, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbf885d6c) at qdbusinterface.cpp:278
#29 0xb6640d87 in QDBusConnectionPrivate::deliverCall (this=0x950f688, object=0x9c001c4, msg=..., metaTypes=..., slotIdx=166420432) at qdbusintegrator.cpp:942
#30 0xb664ac26 in QDBusCallDeliveryEvent::placeMetaCall (this=0xabe44a0, object=0x9c001c4) at qdbusintegrator_p.h:103
#31 0xb64ffb52 in QObject::event (this=0x9c001c4, e=0xabe44a0) at kernel/qobject.cpp:1217
#32 0xb5a12d54 in notify_helper (e=0xabe44a0, receiver=0x9c001c4, this=0x95095d8) at kernel/qapplication.cpp:4486
#33 QApplicationPrivate::notify_helper (this=0x95095d8, receiver=0x9c001c4, e=0xabe44a0) at kernel/qapplication.cpp:4458
#34 0xb5a18103 in QApplication::notify (this=0xabe44a0, receiver=0x9c001c4, e=0xabe44a0) at kernel/qapplication.cpp:3886
#35 0xb6b4c681 in KApplication::notify (this=0x94f16e0, receiver=0x9c001c4, event=0xabe44a0) at ../../kdeui/kernel/kapplication.cpp:311
#36 0xb64e719e in QCoreApplication::notifyInternal (this=0x94f16e0, receiver=0x9c001c4, event=0xabe44a0) at kernel/qcoreapplication.cpp:787
#37 0xb64eaf93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x94992e0) at kernel/qcoreapplication.cpp:1428
#39 0xb64eb0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#40 0xb65156a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=0x94fdbf8) at kernel/qeventdispatcher_glib.cpp:277
#42 0xb2f9e25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#43 0xb2f9e990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#44 0xb2f9ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#45 0xb6515ada in QEventDispatcherGlib::processEvents (this=0x949a230, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#46 0xb5acae3a in QGuiEventDispatcherGlib::processEvents (this=0x949a230, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0xb64e61dd in QEventLoop::processEvents (this=0xbf886404, flags=...) at kernel/qeventloop.cpp:149
#48 0xb64e6421 in QEventLoop::exec (this=0xbf886404, flags=...) at kernel/qeventloop.cpp:201
#49 0xb64eb19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#50 0xb5a108f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#51 0xb77c618b in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#52 0x0804850b in ?? ()
#53 0xb760f113 in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#54 0x08048531 in _start ()

Possible duplicates by query: bug 283797, bug 283263, bug 282678, bug 282665, bug 281300.

Reported using DrKonqi
Comment 1 Nicolas L. 2011-10-17 00:18:09 UTC

*** This bug has been marked as a duplicate of bug 266383 ***