Bug 303640 - KDE crash after downloading large ogg file from archive.org
Summary: KDE crash after downloading large ogg file from archive.org
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-17 04:15 UTC by dr_bbean
Modified: 2012-07-18 08:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dr_bbean 2012-07-17 04:15:04 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-22-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I left the PC running overnight while downloading a large file. The next morning, the crash report was there, while the movie file was successfully downloaded.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b6b20 (LWP 2014))]

Thread 3 (Thread 0xb1892b70 (LWP 2017)):
#0  0x06439e60 in ?? () from /usr/lib/i386-linux-gnu/libgthread-2.0.so.0
#1  0x03dfc6dc in g_thread_self () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x03dd4c18 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x05f37b37 in QEventDispatcherGlib::processEvents (this=0xa3cdc20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x05f081dd in QEventLoop::processEvents (this=0xb18922a0, flags=...) at kernel/qeventloop.cpp:149
#5  0x05f08421 in QEventLoop::exec (this=0xb18922a0, flags=...) at kernel/qeventloop.cpp:201
#6  0x05e0b90b in QThread::exec (this=0xa3cc148) at thread/qthread.cpp:498
#7  0x05ee8e2d in QInotifyFileSystemWatcherEngine::run (this=0xa3cc148) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x05e0e7b3 in QThreadPrivate::start (arg=0xa3cc148) at thread/qthread_unix.cpp:331
#9  0x077f0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x001e346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xaff7eb70 (LWP 2018)):
#0  0x03dd2e80 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x03dd456d in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x03dd4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x05f37b37 in QEventDispatcherGlib::processEvents (this=0xa5092c8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x05f081dd in QEventLoop::processEvents (this=0xaff7e2a0, flags=...) at kernel/qeventloop.cpp:149
#5  0x05f08421 in QEventLoop::exec (this=0xaff7e2a0, flags=...) at kernel/qeventloop.cpp:201
#6  0x05e0b90b in QThread::exec (this=0xa42f690) at thread/qthread.cpp:498
#7  0x05ee8e2d in QInotifyFileSystemWatcherEngine::run (this=0xa42f690) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x05e0e7b3 in QThreadPrivate::start (arg=0xa42f690) at thread/qthread_unix.cpp:331
#9  0x077f0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x001e346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77b6b20 (LWP 2014)):
[KCrash Handler]
#7  0x03ad8423 in ~QExplicitlySharedDataPointer (this=0xabf40dc, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#8  Solid::Device::~Device (this=0xabf40dc, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#9  0x0545e30a in ~QHashNode (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#10 deleteNode2 (node=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#11 deleteNode (node=<optimized out>, this=0xa673dec) at /usr/include/qt4/QtCore/qhash.h:507
#12 QHash<QString, Solid::Device>::remove (this=0xa673dec, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#13 0x0545e46a in remove (akey=..., this=0xa673dec) at /usr/include/qt4/QtCore/qhash.h:784
#14 HotplugEngine::onDeviceRemoved (this=0xa673dd8, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#15 0x05460b23 in HotplugEngine::qt_metacall (this=0xa673dd8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcbe628) at ./hotplugengine.moc:81
#16 0x05f0fb7d in metacall (argv=0xbfcbe628, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0xa673dd8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa673dd8, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbfcbe628) at kernel/qmetaobject.cpp:232
#18 0x05f1ea6a in QMetaObject::activate (sender=0xa3cb7e8, m=0x3b8bf98, local_signal_index=1, argv=0xbfcbe628) at kernel/qobject.cpp:3278
#19 0x03ad9a65 in Solid::DeviceNotifier::deviceRemoved (this=0xa3cb7e8, _t1=...) at ./devicenotifier.moc:94
#20 0x03adadb4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0xa3cb7e8, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#21 0x03adb5b3 in Solid::DeviceManagerPrivate::qt_metacall (this=0xa3cb7e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcbe7a8) at ./devicemanager_p.moc:80
#22 0x05f0fb7d in metacall (argv=0xbfcbe7a8, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0xa3cb7e8) at kernel/qmetaobject.cpp:237
#23 QMetaObject::metacall (object=0xa3cb7e8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfcbe7a8) at kernel/qmetaobject.cpp:232
#24 0x05f1ea6a in QMetaObject::activate (sender=0xa3cd9c8, m=0x3b8d06c, local_signal_index=1, argv=0xbfcbe7a8) at kernel/qobject.cpp:3278
#25 0x03af0cd5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0xa3cd9c8, _t1=...) at ./ifaces/devicemanager.moc:94
#26 0x03b3a548 in slotDeviceRemoved (opath=<optimized out>, this=0xa3cd9c8) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#27 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0xa3cd9c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcbea0c) at ./backends/upower/upowermanager.moc:78
#28 0x05f0fb7d in metacall (argv=0xbfcbea0c, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0xa3cd9c8) at kernel/qmetaobject.cpp:237
#29 QMetaObject::metacall (object=0xa3cd9c8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfcbea0c) at kernel/qmetaobject.cpp:232
#30 0x05f1ea6a in QMetaObject::activate (sender=0xa3cd9d4, m=0xa3dc490, local_signal_index=4, argv=0xbfcbea0c) at kernel/qobject.cpp:3278
#31 0x00b2c110 in QDBusInterfacePrivate::metacall (this=0xb0f00598, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbfcbea0c) at qdbusinterface.cpp:278
#32 0x00b16d87 in QDBusConnectionPrivate::deliverCall (this=0x9deb490, object=0xa3cd9d4, msg=..., metaTypes=..., slotIdx=175647640) at qdbusintegrator.cpp:942
#33 0x00b20c26 in QDBusCallDeliveryEvent::placeMetaCall (this=0xb2af3d0, object=0xa3cd9d4) at qdbusintegrator_p.h:103
#34 0x05f21b52 in QObject::event (this=0xa3cd9d4, e=0xb2af3d0) at kernel/qobject.cpp:1217
#35 0x01546d84 in notify_helper (e=0xb2af3d0, receiver=0xa3cd9d4, this=0x9cee368) at kernel/qapplication.cpp:4486
#36 QApplicationPrivate::notify_helper (this=0x9cee368, receiver=0xa3cd9d4, e=0xb2af3d0) at kernel/qapplication.cpp:4458
#37 0x0154c133 in QApplication::notify (this=0xb2af3d0, receiver=0xa3cd9d4, e=0xb2af3d0) at kernel/qapplication.cpp:3886
#38 0x0119c971 in KApplication::notify (this=0x9ce1610, receiver=0xa3cd9d4, event=0xb2af3d0) at ../../kdeui/kernel/kapplication.cpp:311
#39 0x05f0919e in QCoreApplication::notifyInternal (this=0x9ce1610, receiver=0xa3cd9d4, event=0xb2af3d0) at kernel/qcoreapplication.cpp:787
#40 0x05f0cf93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9ca22e0) at kernel/qcoreapplication.cpp:1428
#42 0x05f0d0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#43 0x05f376a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#44 postEventSourceDispatch (s=0x9cf07b0) at kernel/qeventdispatcher_glib.cpp:277
#45 0x03dd425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0x03dd4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0x03dd4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0x05f37ada in QEventDispatcherGlib::processEvents (this=0x9ca3218, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#49 0x015fee7a in QGuiEventDispatcherGlib::processEvents (this=0x9ca3218, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x05f081dd in QEventLoop::processEvents (this=0xbfcbf0a4, flags=...) at kernel/qeventloop.cpp:149
#51 0x05f08421 in QEventLoop::exec (this=0xbfcbf0a4, flags=...) at kernel/qeventloop.cpp:201
#52 0x05f0d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#53 0x01544924 in QApplication::exec () at kernel/qapplication.cpp:3760
#54 0x0085d18b in kdemain (argc=1, argv=0xbfcbf2a4) at ../../../../plasma/desktop/shell/main.cpp:120
#55 0x0804850b in main (argc=1, argv=0xbfcbf2a4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 266383.

Possible duplicates by query: bug 299188, bug 298579, bug 294357, bug 294324, bug 294036.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-17 06:14:05 UTC

*** This bug has been marked as a duplicate of bug 266383 ***
Comment 2 dr_bbean 2012-07-18 04:39:09 UTC
I was DEFINITELY NOT doing any partition operation on my drive when this fault occured. I do not think this case is a duplicate of "Bug 266383 - KDE crash during partition operations in KDE."

Could it be that a remote hacker was trying to partition my drive while I was downloading a large video file? Please double check this one.
Comment 3 Jekyll Wu 2012-07-18 08:51:15 UTC
Usually, the backtrace is more important and accurate than the summary and description. If you compare the backtraces, you will see they share the same cause: some device is unplugged.

*** This bug has been marked as a duplicate of bug 266383 ***