Bug 298579 - Plasma crash after hard reboot
Summary: Plasma crash after hard reboot
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-22 03:03 UTC by jimbob.squarepants
Modified: 2012-04-22 03:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jimbob.squarepants 2012-04-22 03:03:26 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-17-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I had to hard reboot while debugging a program in KDevelop; when i got back into KDE and reopened KDevelop, Plasma crashed.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76d4b20 (LWP 1627))]

Thread 2 (Thread 0xb17f1b70 (LWP 1738)):
#0  0x03c0ad10 in __GI_clock_gettime (clock_id=1, tp=0xb17f1018) at ../sysdeps/unix/clock_gettime.c:116
#1  0x04f5b7d5 in do_gettime (frac=0xb17f1010, sec=0xb17f1008) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x0502e4b6 in QTimerInfoList::updateCurrentTime (this=0x8ddf124) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0502e80a in QTimerInfoList::timerWait (this=0x8ddf124, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0502d053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb17f111c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0502d0ed in timerSourcePrepare (source=0x8ddf0f0, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x03e1f88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x03e20637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x03e20c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0502db37 in QEventDispatcherGlib::processEvents (this=0x8dd25b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x04ffe1dd in QEventLoop::processEvents (this=0xb17f12a0, flags=...) at kernel/qeventloop.cpp:149
#12 0x04ffe421 in QEventLoop::exec (this=0xb17f12a0, flags=...) at kernel/qeventloop.cpp:201
#13 0x04f0190b in QThread::exec (this=0x8dd2e80) at thread/qthread.cpp:498
#14 0x04fdee2d in QInotifyFileSystemWatcherEngine::run (this=0x8dd2e80) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x04f047b3 in QThreadPrivate::start (arg=0x8dd2e80) at thread/qthread_unix.cpp:331
#16 0x03cfdd31 in start_thread (arg=0xb17f1b70) at pthread_create.c:304
#17 0x0021f46e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76d4b20 (LWP 1627)):
[KCrash Handler]
#7  0x03917423 in ~QExplicitlySharedDataPointer (this=0x8d29b2c, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#8  Solid::Device::~Device (this=0x8d29b2c, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#9  0x05bf830a in ~QHashNode (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#10 deleteNode2 (node=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#11 deleteNode (node=<optimized out>, this=0x8fada04) at /usr/include/qt4/QtCore/qhash.h:507
#12 QHash<QString, Solid::Device>::remove (this=0x8fada04, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#13 0x05bf846a in remove (akey=..., this=0x8fada04) at /usr/include/qt4/QtCore/qhash.h:784
#14 HotplugEngine::onDeviceRemoved (this=0x8fad9f0, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#15 0x05bfab23 in HotplugEngine::qt_metacall (this=0x8fad9f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8f7e48) at ./hotplugengine.moc:81
#16 0x05005b7d in metacall (argv=0xbf8f7e48, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0x8fad9f0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8fad9f0, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbf8f7e48) at kernel/qmetaobject.cpp:232
#18 0x05014a6a in QMetaObject::activate (sender=0x8dd3258, m=0x39caf98, local_signal_index=1, argv=0xbf8f7e48) at kernel/qobject.cpp:3278
#19 0x03918a65 in Solid::DeviceNotifier::deviceRemoved (this=0x8dd3258, _t1=...) at ./devicenotifier.moc:94
#20 0x03919db4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x8dd3258, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#21 0x0391a5b3 in Solid::DeviceManagerPrivate::qt_metacall (this=0x8dd3258, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8f7fc8) at ./devicemanager_p.moc:80
#22 0x05005b7d in metacall (argv=0xbf8f7fc8, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x8dd3258) at kernel/qmetaobject.cpp:237
#23 QMetaObject::metacall (object=0x8dd3258, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf8f7fc8) at kernel/qmetaobject.cpp:232
#24 0x05014a6a in QMetaObject::activate (sender=0x8dd57a8, m=0x39cc06c, local_signal_index=1, argv=0xbf8f7fc8) at kernel/qobject.cpp:3278
#25 0x0392fcd5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x8dd57a8, _t1=...) at ./ifaces/devicemanager.moc:94
#26 0x03979548 in slotDeviceRemoved (opath=<optimized out>, this=0x8dd57a8) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#27 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x8dd57a8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8f822c) at ./backends/upower/upowermanager.moc:78
#28 0x05005b7d in metacall (argv=0xbf8f822c, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x8dd57a8) at kernel/qmetaobject.cpp:237
#29 QMetaObject::metacall (object=0x8dd57a8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf8f822c) at kernel/qmetaobject.cpp:232
#30 0x05014a6a in QMetaObject::activate (sender=0x8dd57b4, m=0x8dd3450, local_signal_index=4, argv=0xbf8f822c) at kernel/qobject.cpp:3278
#31 0x00c1a110 in QDBusInterfacePrivate::metacall (this=0x8dd5a68, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbf8f822c) at qdbusinterface.cpp:278
#32 0x00c04d87 in QDBusConnectionPrivate::deliverCall (this=0x88b3310, object=0x8dd57b4, msg=..., metaTypes=..., slotIdx=150219584) at qdbusintegrator.cpp:942
#33 0x00c0ec26 in QDBusCallDeliveryEvent::placeMetaCall (this=0x95ab0d8, object=0x8dd57b4) at qdbusintegrator_p.h:103
#34 0x05017b52 in QObject::event (this=0x8dd57b4, e=0x95ab0d8) at kernel/qobject.cpp:1217
#35 0x01359d84 in notify_helper (e=0x95ab0d8, receiver=0x8dd57b4, this=0x87f5d48) at kernel/qapplication.cpp:4486
#36 QApplicationPrivate::notify_helper (this=0x87f5d48, receiver=0x8dd57b4, e=0x95ab0d8) at kernel/qapplication.cpp:4458
#37 0x0135f133 in QApplication::notify (this=0x95ab0d8, receiver=0x8dd57b4, e=0x95ab0d8) at kernel/qapplication.cpp:3886
#38 0x00faf971 in KApplication::notify (this=0x87ec340, receiver=0x8dd57b4, event=0x95ab0d8) at ../../kdeui/kernel/kapplication.cpp:311
#39 0x04fff19e in QCoreApplication::notifyInternal (this=0x87ec340, receiver=0x8dd57b4, event=0x95ab0d8) at kernel/qcoreapplication.cpp:787
#40 0x05002f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x87ac2e0) at kernel/qcoreapplication.cpp:1428
#42 0x050030ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#43 0x0502d6a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#44 postEventSourceDispatch (s=0x87f9e68) at kernel/qeventdispatcher_glib.cpp:277
#45 0x03e2025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0x03e20990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0x03e20c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0x0502dada in QEventDispatcherGlib::processEvents (this=0x87ad200, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#49 0x01411e7a in QGuiEventDispatcherGlib::processEvents (this=0x87ad200, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x04ffe1dd in QEventLoop::processEvents (this=0xbf8f88c4, flags=...) at kernel/qeventloop.cpp:149
#51 0x04ffe421 in QEventLoop::exec (this=0xbf8f88c4, flags=...) at kernel/qeventloop.cpp:201
#52 0x0500319d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#53 0x01357924 in QApplication::exec () at kernel/qapplication.cpp:3760
#54 0x006c118b in kdemain (argc=1, argv=0xbf8f8ac4) at ../../../../plasma/desktop/shell/main.cpp:120
#55 0x0804850b in main (argc=1, argv=0xbf8f8ac4) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 294357, bug 294324, bug 294036, bug 291844, bug 291066.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-04-22 03:23:39 UTC

*** This bug has been marked as a duplicate of bug 266383 ***