Bug 272350 - Crash when unounting encrypted external HDD in Dolphin
Summary: Crash when unounting encrypted external HDD in Dolphin
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-03 18:29 UTC by Alan Prescott
Modified: 2011-12-03 19:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Prescott 2011-05-03 18:29:35 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2) "release 3"
Qt Version: 4.7.2
Operating System: Linux 2.6.34.8-0.2-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

Running the "Safely remove ..." on an encrypted 500GB external HDD connected by USB

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb585e710 (LWP 3412))]

Thread 2 (Thread 0xae22db70 (LWP 3413)):
#0  0xb5b5d22b in clock_gettime () from /lib/librt.so.1
#1  0xb6d84835 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6e58506 in updateCurrentTime (this=0x811ae34, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x811ae34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6e56d3b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae22d11c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6e56ddd in timerSourcePrepare (source=0x811ae00, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5ab10c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0xb5ab1f22 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb5ab260e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0xb6e57587 in QEventDispatcherGlib::processEvents (this=0x864a788, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6e2803d in QEventLoop::processEvents (this=0xae22d2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6e28269 in QEventLoop::exec (this=0xae22d2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6d26d39 in QThread::exec (this=0x8581f28) at thread/qthread.cpp:492
#14 0xb6e07a5d in QInotifyFileSystemWatcherEngine::run (this=0x8581f28) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6d29983 in QThreadPrivate::start (arg=0x8581f28) at thread/qthread_unix.cpp:320
#16 0xb6cacb25 in start_thread () from /lib/libpthread.so.0
#17 0xb605846e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb585e710 (LWP 3412)):
[KCrash Handler]
#7  0x00000001 in ?? ()
#8  0xb51f7cc6 in ~QExplicitlySharedDataPointer (this=0x8d8346c, __in_chrg=<value optimized out>) at /usr/include/QtCore/qshareddata.h:161
#9  Solid::Device::~Device (this=0x8d8346c, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.2/solid/solid/device.cpp:85
#10 0xae38187f in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#11 0xae37e723 in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#12 0xae380d23 in ?? () from /usr/lib/kde4/plasma_engine_hotplug.so
#13 0xb6e2f5fd in QMetaObject::metacall (object=0x869e800, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbf970ab8) at kernel/qmetaobject.cpp:237
#14 0xb6e3f7fc in QMetaObject::activate (sender=0x851eac8, m=0xb52a4c48, local_signal_index=1, argv=0xbf970ab8) at kernel/qobject.cpp:3278
#15 0xb51f9245 in Solid::DeviceNotifier::deviceRemoved (this=0x851eac8, _t1=...) at /usr/src/debug/kdelibs-4.6.2/build/solid/solid/devicenotifier.moc:94
#16 0xb51fa02f in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x851eac8, udi=...) at /usr/src/debug/kdelibs-4.6.2/solid/solid/devicemanager.cpp:207
#17 0xb51fa773 in Solid::DeviceManagerPrivate::qt_metacall (this=0x851eac8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf970c48)
    at /usr/src/debug/kdelibs-4.6.2/build/solid/solid/devicemanager_p.moc:80
#18 0xb6e2f5fd in QMetaObject::metacall (object=0x851eac8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf970c48) at kernel/qmetaobject.cpp:237
#19 0xb6e3f7fc in QMetaObject::activate (sender=0x86bdbf8, m=0xb52a5d20, local_signal_index=1, argv=0xbf970c48) at kernel/qobject.cpp:3278
#20 0xb520ee85 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x86bdbf8, _t1=...) at /usr/src/debug/kdelibs-4.6.2/build/solid/solid/ifaces/devicemanager.moc:94
#21 0xb525e478 in Solid::Backends::UDisks::UDisksManager::slotDeviceRemoved (this=0x86bdbf8, opath=...) at /usr/src/debug/kdelibs-4.6.2/solid/solid/backends/udisks/udisksmanager.cpp:217
#22 0xb525e713 in Solid::Backends::UDisks::UDisksManager::qt_metacall (this=0x86bdbf8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf970f5c)
    at /usr/src/debug/kdelibs-4.6.2/build/solid/solid/backends/udisks/udisksmanager.moc:80
#23 0xb6e2f5fd in QMetaObject::metacall (object=0x86bdbf8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf970f5c) at kernel/qmetaobject.cpp:237
#24 0xb6e3f7fc in QMetaObject::activate (sender=0x86bdc08, m=0x86590f8, local_signal_index=6, argv=0xbf970f5c) at kernel/qobject.cpp:3278
#25 0xb5c63070 in QDBusInterfacePrivate::metacall (this=0x857ad78, c=QMetaObject::InvokeMetaMethod, id=6, argv=0xbf970f5c) at qdbusinterface.cpp:278
#26 0xb5c4baa7 in QDBusConnectionPrivate::deliverCall (this=0x81184b8, object=0x86bdc08, msg=..., metaTypes=..., slotIdx=147739688) at qdbusintegrator.cpp:941
#27 0xb5c58086 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8d84388, object=0x86bdc08) at qdbusintegrator_p.h:103
#28 0xb6e3e37f in QObject::event (this=0x86bdc08, e=0x8d84388) at kernel/qobject.cpp:1217
#29 0xb631f6e4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#30 0xb63284a7 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#31 0xb7497a61 in KApplication::notify (this=0x80d2828, receiver=0x86bdc08, event=0x8d84388) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#32 0xb6e28d5e in QCoreApplication::notifyInternal (this=0x80d2828, receiver=0x86bdc08, event=0x8d84388) at kernel/qcoreapplication.cpp:731
#33 0xb6e2caec in sendEvent (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.h:215
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.cpp:1372
#35 0xb6e2cc3c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#36 0xb6e573b4 in sendPostedEvents (s=0x805cd80) at kernel/qcoreapplication.h:220
#37 postEventSourceDispatch (s=0x805cd80) at kernel/qeventdispatcher_glib.cpp:277
#38 0xb5ab1b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#39 0xb5ab2350 in ?? () from /usr/lib/libglib-2.0.so.0
#40 0xb5ab260e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#41 0xb6e5753b in QEventDispatcherGlib::processEvents (this=0x80c49d0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0xb63d61ca in ?? () from /usr/lib/libQtGui.so.4
#43 0xb6e2803d in QEventLoop::processEvents (this=0xbf971724, flags=...) at kernel/qeventloop.cpp:149
#44 0xb6e28269 in QEventLoop::exec (this=0xbf971724, flags=...) at kernel/qeventloop.cpp:201
#45 0xb6e2cd10 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#46 0xb631d3e4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#47 0xb0f31ada in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#48 0x0804e504 in _start ()

Possible duplicates by query: bug 271566, bug 269449, bug 268008, bug 266383.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-10 01:35:22 UTC
[Comment from a bug report cleaner]
This seems to be related to the crash in bug 266383. Regards
Comment 2 Marco Martin 2011-12-03 19:51:16 UTC

*** This bug has been marked as a duplicate of bug 266383 ***