Bug 289643 - plasma-desktop crash
Summary: plasma-desktop crash
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-23 08:13 UTC by Adrian Warman
Modified: 2012-01-02 19:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Warman 2011-12-23 08:13:40 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Building an ISO image using k3b.
Unmounting an encrypted external hard drive.
Connected to work network using an encrypted VPN.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb779eb20 (LWP 2104))]

Thread 4 (Thread 0xb07b2b70 (LWP 2106)):
#0  0x0097ff54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0x03918c4f in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x077a3b37 in QEventDispatcherGlib::processEvents (this=0xa874410, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#3  0x077741dd in QEventLoop::processEvents (this=0xb07b22a0, flags=...) at kernel/qeventloop.cpp:149
#4  0x07774421 in QEventLoop::exec (this=0xb07b22a0, flags=...) at kernel/qeventloop.cpp:201
#5  0x0767790b in QThread::exec (this=0xa811448) at thread/qthread.cpp:498
#6  0x07754e2d in QInotifyFileSystemWatcherEngine::run (this=0xa811448) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x0767a7b3 in QThreadPrivate::start (arg=0xa811448) at thread/qthread_unix.cpp:331
#8  0x0437ad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0x009720ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xaf530b70 (LWP 2109)):
#0  0x0097fee8 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#1  0x03917f53 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x039188f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x03918c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x077a3b37 in QEventDispatcherGlib::processEvents (this=0xaa850c8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x077741dd in QEventLoop::processEvents (this=0xaf5302a0, flags=...) at kernel/qeventloop.cpp:149
#6  0x07774421 in QEventLoop::exec (this=0xaf5302a0, flags=...) at kernel/qeventloop.cpp:201
#7  0x0767790b in QThread::exec (this=0xaa577e8) at thread/qthread.cpp:498
#8  0x07754e2d in QInotifyFileSystemWatcherEngine::run (this=0xaa577e8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x0767a7b3 in QThreadPrivate::start (arg=0xaa577e8) at thread/qthread_unix.cpp:331
#10 0x0437ad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x009720ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xadd2db70 (LWP 2115)):
#0  0x0437dd60 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x0097ff54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x03918102 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x03918990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x03918f9b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x05b8acea in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0x0393f5f4 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x0437ad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x009720ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb779eb20 (LWP 2104)):
[KCrash Handler]
#7  0x036e1423 in ~QExplicitlySharedDataPointer (this=0xca809bc, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#8  Solid::Device::~Device (this=0xca809bc, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#9  0x05148823 in QMap<QString, Solid::Device>::remove (this=0xaaf1558, akey=...) at /usr/include/qt4/QtCore/qmap.h:680
#10 0x05140875 in SolidDeviceEngine::sourceWasRemoved (this=0xaaf1548, source=...) at ../../../../../plasma/generic/dataengines/soliddevice/soliddeviceengine.cpp:94
#11 0x05140e0a in SolidDeviceEngine::qt_metacall (this=0xaaf1548, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec52f8) at ./soliddeviceengine.moc:83
#12 0x0777bb7d in metacall (argv=0xbfec52f8, idx=27, cl=QMetaObject::InvokeMetaMethod, object=0xaaf1548) at kernel/qmetaobject.cpp:237
#13 QMetaObject::metacall (object=0xaaf1548, cl=QMetaObject::InvokeMetaMethod, idx=27, argv=0xbfec52f8) at kernel/qmetaobject.cpp:232
#14 0x0778aa6a in QMetaObject::activate (sender=0xaaf1548, m=0x5159ac, local_signal_index=1, argv=0xbfec52f8) at kernel/qobject.cpp:3278
#15 0x00311645 in Plasma::DataEngine::sourceRemoved (this=0xaaf1548, _t1=...) at ./dataengine.moc:198
#16 0x00312199 in Plasma::DataEngine::removeSource (this=0xaaf1548, source=...) at ../../plasma/dataengine.cpp:324
#17 0x003133ab in Plasma::DataEngine::qt_metacall (this=0xaaf1548, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfec54d8) at ./dataengine.moc:128
#18 0x05140dd2 in SolidDeviceEngine::qt_metacall (this=0xaaf1548, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfec54d8) at ./soliddeviceengine.moc:75
#19 0x0777bb7d in metacall (argv=0xbfec54d8, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0xaaf1548) at kernel/qmetaobject.cpp:237
#20 QMetaObject::metacall (object=0xaaf1548, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfec54d8) at kernel/qmetaobject.cpp:232
#21 0x0778aa6a in QMetaObject::activate (sender=0xc60dfa0, m=0x515938, local_signal_index=1, argv=0xbfec54d8) at kernel/qobject.cpp:3278
#22 0x0030e235 in Plasma::DataContainer::becameUnused (this=0xc60dfa0, _t1=...) at ./datacontainer.moc:119
#23 0x0030e2e5 in checkUsage (this=0xc60dfa0) at ../../plasma/datacontainer.cpp:337
#24 Plasma::DataContainer::checkUsage (this=0xc60dfa0) at ../../plasma/datacontainer.cpp:331
#25 0x0030e980 in Plasma::DataContainer::disconnectVisualization (this=0xc60dfa0, visualization=0xaaced18) at ../../plasma/datacontainer.cpp:290
#26 0x00312ff2 in Plasma::DataEngine::disconnectSource (this=0xaaf1548, source=..., visualization=0xaaced18) at ../../plasma/dataengine.cpp:124
#27 0x052ae2de in Notifier::DeviceNotifier::onSourceRemoved (this=0xaaa1ec8, udi=...) at ../../../../../plasma/generic/applets/devicenotifier/devicenotifier.cpp:435
#28 0x052b14bb in Notifier::DeviceNotifier::qt_metacall (this=0xaaa1ec8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec56c8) at ./devicenotifier.moc:221
#29 0x0777bb7d in metacall (argv=0xbfec56c8, idx=85, cl=QMetaObject::InvokeMetaMethod, object=0xaaa1ec8) at kernel/qmetaobject.cpp:237
#30 QMetaObject::metacall (object=0xaaa1ec8, cl=QMetaObject::InvokeMetaMethod, idx=85, argv=0xbfec56c8) at kernel/qmetaobject.cpp:232
#31 0x0778aa6a in QMetaObject::activate (sender=0xaab6b50, m=0x5159ac, local_signal_index=1, argv=0xbfec56c8) at kernel/qobject.cpp:3278
#32 0x00311645 in Plasma::DataEngine::sourceRemoved (this=0xaab6b50, _t1=...) at ./dataengine.moc:198
#33 0x00312199 in Plasma::DataEngine::removeSource (this=0xaab6b50, source=...) at ../../plasma/dataengine.cpp:324
#34 0x0857a456 in HotplugEngine::onDeviceRemoved (this=0xaab6b50, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:242
#35 0x0857cb23 in HotplugEngine::qt_metacall (this=0xaab6b50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec5878) at ./hotplugengine.moc:81
#36 0x0777bb7d in metacall (argv=0xbfec5878, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0xaab6b50) at kernel/qmetaobject.cpp:237
#37 QMetaObject::metacall (object=0xaab6b50, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbfec5878) at kernel/qmetaobject.cpp:232
#38 0x0778aa6a in QMetaObject::activate (sender=0xaa5e8e8, m=0x3794f98, local_signal_index=1, argv=0xbfec5878) at kernel/qobject.cpp:3278
#39 0x036e2a65 in Solid::DeviceNotifier::deviceRemoved (this=0xaa5e8e8, _t1=...) at ./devicenotifier.moc:94
#40 0x036e3db4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0xaa5e8e8, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#41 0x036e45b3 in Solid::DeviceManagerPrivate::qt_metacall (this=0xaa5e8e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec59f8) at ./devicemanager_p.moc:80
#42 0x0777bb7d in metacall (argv=0xbfec59f8, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0xaa5e8e8) at kernel/qmetaobject.cpp:237
#43 QMetaObject::metacall (object=0xaa5e8e8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfec59f8) at kernel/qmetaobject.cpp:232
#44 0x0778aa6a in QMetaObject::activate (sender=0xaa622a8, m=0x379606c, local_signal_index=1, argv=0xbfec59f8) at kernel/qobject.cpp:3278
#45 0x036f9cd5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0xaa622a8, _t1=...) at ./ifaces/devicemanager.moc:94
#46 0x0374a09f in Solid::Backends::UDisks::UDisksManager::slotDeviceRemoved (this=0xaa622a8, opath=...) at ../../../solid/solid/backends/udisks/udisksmanager.cpp:217
#47 0x0374a3d3 in Solid::Backends::UDisks::UDisksManager::qt_metacall (this=0xaa622a8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec5ccc) at ./backends/udisks/udisksmanager.moc:80
#48 0x0777bb7d in metacall (argv=0xbfec5ccc, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0xaa622a8) at kernel/qmetaobject.cpp:237
#49 QMetaObject::metacall (object=0xaa622a8, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfec5ccc) at kernel/qmetaobject.cpp:232
#50 0x0778aa6a in QMetaObject::activate (sender=0xaa622b8, m=0xaa80018, local_signal_index=6, argv=0xbfec5ccc) at kernel/qobject.cpp:3278
#51 0x00a6f110 in QDBusInterfacePrivate::metacall (this=0xaa64be8, c=QMetaObject::InvokeMetaMethod, id=6, argv=0xbfec5ccc) at qdbusinterface.cpp:278
#52 0x00a59d87 in QDBusConnectionPrivate::deliverCall (this=0xa0789d0, object=0xaa622b8, msg=..., metaTypes=..., slotIdx=207386376) at qdbusintegrator.cpp:942
#53 0x00a63c26 in QDBusCallDeliveryEvent::placeMetaCall (this=0xcb1e840, object=0xaa622b8) at qdbusintegrator_p.h:103
#54 0x0778db52 in QObject::event (this=0xaa622b8, e=0xcb1e840) at kernel/qobject.cpp:1217
#55 0x015fdd54 in notify_helper (e=0xcb1e840, receiver=0xaa622b8, this=0x9fb0e78) at kernel/qapplication.cpp:4486
#56 QApplicationPrivate::notify_helper (this=0x9fb0e78, receiver=0xaa622b8, e=0xcb1e840) at kernel/qapplication.cpp:4458
#57 0x01603103 in QApplication::notify (this=0xcb1e840, receiver=0xaa622b8, e=0xcb1e840) at kernel/qapplication.cpp:3886
#58 0x0119d681 in KApplication::notify (this=0x9fa21e8, receiver=0xaa622b8, event=0xcb1e840) at ../../kdeui/kernel/kapplication.cpp:311
#59 0x0777519e in QCoreApplication::notifyInternal (this=0x9fa21e8, receiver=0xaa622b8, event=0xcb1e840) at kernel/qcoreapplication.cpp:787
#60 0x07778f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#61 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9f4a2e0) at kernel/qcoreapplication.cpp:1428
#62 0x077790ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#63 0x077a36a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#64 postEventSourceDispatch (s=0x9fb3550) at kernel/qeventdispatcher_glib.cpp:277
#65 0x0391825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#66 0x03918990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#67 0x03918c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#68 0x077a3ada in QEventDispatcherGlib::processEvents (this=0x9f4b200, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#69 0x016b5e3a in QGuiEventDispatcherGlib::processEvents (this=0x9f4b200, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#70 0x077741dd in QEventLoop::processEvents (this=0xbfec6364, flags=...) at kernel/qeventloop.cpp:149
#71 0x07774421 in QEventLoop::exec (this=0xbfec6364, flags=...) at kernel/qeventloop.cpp:201
#72 0x0777919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#73 0x015fb8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#74 0x00cd118b in kdemain (argc=1, argv=0xbfec6564) at ../../../../plasma/desktop/shell/main.cpp:120
#75 0x0804850b in main (argc=1, argv=0xbfec6564) at plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2011-12-23 11:24:50 UTC
Reassigning to Solid
Comment 2 Christoph Feck 2012-01-02 19:16:33 UTC

*** This bug has been marked as a duplicate of bug 266383 ***