Bug 293244 - Restarting from sleep triggered this crash
Summary: Restarting from sleep triggered this crash
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-03 21:13 UTC by Frans Leerink
Modified: 2012-06-01 07:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.70 KB, text/plain)
2012-06-01 07:45 UTC, Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frans Leerink 2012-02-03 21:13:47 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.9-1.4-default i686
Distribution: "openSUSE 12.1 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
During last week I have made roughly 20 restarts from sleep succesfully.

Today I restarted the system from a 1,5 hr sleep and that resulted in this crash. The system was already up and running while the wireless network was still in the restartng stage

The crash does not seem to be reproducible.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb587b710 (LWP 1775))]

Thread 2 (Thread 0xaa90db70 (LWP 1778)):
#0  0xb6d3aa94 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb5af5447 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0xb5af57fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0xb6edd8a7 in QEventDispatcherGlib::processEvents (this=0xaa000468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0xb6eae45d in QEventLoop::processEvents (this=0xaa90d2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0xb6eae6a1 in QEventLoop::exec (this=0xaa90d2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0xb6db175b in QThread::exec (this=0x88d1560) at thread/qthread.cpp:498
#7  0xb6e8f09d in QInotifyFileSystemWatcherEngine::run (this=0x88d1560) at io/qfilesystemwatcher_inotify.cpp:248
#8  0xb6db4613 in QThreadPrivate::start (arg=0x88d1560) at thread/qthread_unix.cpp:331
#9  0xb6d37a7d in start_thread () from /lib/libpthread.so.0
#10 0xb610089e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb587b710 (LWP 1775)):
[KCrash Handler]
#6  0xb521bbf3 in Solid::Device::~Device() () from /usr/lib/libsolid.so.4
#7  0xa9f6b61a in ~QHashNode (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/QtCore/qhash.h:216
#8  deleteNode2 (node=<optimized out>) at /usr/include/QtCore/qhash.h:519
#9  deleteNode (node=<optimized out>, this=0x8d654c4) at /usr/include/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x8d654c4, akey=<optimized out>) at /usr/include/QtCore/qhash.h:795
#11 0xa9f6b78a in remove (akey=..., this=0x8d654c4) at /usr/include/QtCore/qhash.h:784
#12 HotplugEngine::onDeviceRemoved (this=0x8d654b0, udi=...) at /usr/src/debug/kde-workspace-4.7.2/plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#13 0xa9f6de43 in HotplugEngine::qt_metacall (this=0x8d654b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfaa3688) at /usr/src/debug/kde-workspace-4.7.2/build/plasma/generic/dataengines/hotplug/hotplugengine.moc:81
#14 0xb6eb57ed in metacall (argv=0xbfaa3688, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0x8d654b0) at kernel/qmetaobject.cpp:237
#15 QMetaObject::metacall (object=0x8d654b0, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbfaa3688) at kernel/qmetaobject.cpp:232
#16 0xb6ec4720 in QMetaObject::activate (sender=0x88d1970, m=0xb52cff98, local_signal_index=1, argv=0xbfaa3688) at kernel/qobject.cpp:3287
#17 0xb521d235 in Solid::DeviceNotifier::deviceRemoved(QString const&) () from /usr/lib/libsolid.so.4
#18 0xb521e4a4 in ?? () from /usr/lib/libsolid.so.4
#19 0xb521eca3 in ?? () from /usr/lib/libsolid.so.4
#20 0xb6eb57ed in metacall (argv=0xbfaa3808, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x88d1970) at kernel/qmetaobject.cpp:237
#21 QMetaObject::metacall (object=0x88d1970, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfaa3808) at kernel/qmetaobject.cpp:232
#22 0xb6ec4720 in QMetaObject::activate (sender=0x88cdd28, m=0xb52d106c, local_signal_index=1, argv=0xbfaa3808) at kernel/qobject.cpp:3287
#23 0xb5233f85 in ?? () from /usr/lib/libsolid.so.4
#24 0xb527d728 in ?? () from /usr/lib/libsolid.so.4
#25 0xb6eb57ed in metacall (argv=0xbfaa3a7c, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x88cdd28) at kernel/qmetaobject.cpp:237
#26 QMetaObject::metacall (object=0x88cdd28, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbfaa3a7c) at kernel/qmetaobject.cpp:232
#27 0xb6ec4720 in QMetaObject::activate (sender=0x88cdd34, m=0x88d17c0, local_signal_index=4, argv=0xbfaa3a7c) at kernel/qobject.cpp:3287
#28 0xb5cb9900 in QDBusInterfacePrivate::metacall (this=0x88d36a0, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbfaa3a7c) at qdbusinterface.cpp:278
#29 0xb5ca4400 in QDBusConnectionPrivate::deliverCall (this=0x81b49b0, object=0x88cdd34, msg=..., metaTypes=..., slotIdx=148604544) at qdbusintegrator.cpp:942
#30 0xb5cae406 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8c71030, object=0x88cdd34) at qdbusintegrator_p.h:103
#31 0xb6ec783f in QObject::event (this=0x88cdd34, e=0x8c71030) at kernel/qobject.cpp:1226
#32 0xb63caf24 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#33 0xb63d02b2 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#34 0xb75f3681 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#35 0xb6eaf43e in QCoreApplication::notifyInternal (this=0x80defc0, receiver=0x88cdd34, event=0x8c71030) at kernel/qcoreapplication.cpp:787
#36 0xb6eb2c04 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:215
#37 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x805b1c0) at kernel/qcoreapplication.cpp:1428
#38 0xb6eb2d4c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#39 0xb6edd414 in sendPostedEvents () at kernel/qcoreapplication.h:220
#40 postEventSourceDispatch (s=0x80ea580) at kernel/qeventdispatcher_glib.cpp:277
#41 0xb5af4e2f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#42 0xb5af5560 in ?? () from /usr/lib/libglib-2.0.so.0
#43 0xb5af57fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#44 0xb6edd847 in QEventDispatcherGlib::processEvents (this=0x80e5d78, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#45 0xb647eb1a in ?? () from /usr/lib/libQtGui.so.4
#46 0xb6eae45d in QEventLoop::processEvents (this=0xbfaa4224, flags=...) at kernel/qeventloop.cpp:149
#47 0xb6eae6a1 in QEventLoop::exec (this=0xbfaa4224, flags=...) at kernel/qeventloop.cpp:201
#48 0xb6eb2dfa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#49 0xb63c8da4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#50 0xb1e797cb in kdemain (argc=1, argv=0x80a3d38) at /usr/src/debug/kde-workspace-4.7.2/plasma/desktop/shell/main.cpp:120
#51 0x0804fbcd in _start ()

Possible duplicates by query: bug 291844, bug 291066, bug 290475, bug 290426, bug 290045.

Reported using DrKonqi
Comment 1 Thijs 2012-02-04 09:55:04 UTC

*** This bug has been marked as a duplicate of bug 266383 ***
Comment 2 Dmitry 2012-06-01 07:45:13 UTC
Created attachment 71491 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

I pressed space on keyboard to get system out of sleep mode and got this crush message. I work with two monitors (laptop's, and external) - maybe this will help somehow.

-- Backtrace (Reduced):
#7  0x00007f46982e1ee1 in ~QHashNode (this=0x4d1c090, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#8  deleteNode2 (node=0x4d1c090) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (node=0x4d1c090, this=0x3210888) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x3210888, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#11 0x00007f46982e203c in remove (akey=..., this=0x3210888) at /usr/include/qt4/QtCore/qhash.h:784