Bug 297083 - Plasma crash on resume from suspend
Summary: Plasma crash on resume from suspend
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-30 00:23 UTC by sml
Modified: 2012-03-30 07:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sml 2012-03-30 00:23:31 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.2.0-2-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:

I resumed from suspend, unlocked the screen and was greeted by the drkonqi.

I was unable to tell if plasma had crashed just before suspend, or upon resume.

Possible duplicate of #266383, though the stack trace is slightly different.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f57b990e780 (LWP 2286))]

Thread 2 (Thread 0x7f578ffff700 (LWP 2289)):
#0  0x00007f57b91f2cc3 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f57acf7e5d8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f57acf7ea99 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f57b634e4a6 in QEventDispatcherGlib::processEvents (this=0x2fb9810, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f57b6322972 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f57b6322b6f in QEventLoop::exec (this=0x7f578fffedd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f57b623a4af in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f57b63059cf in QInotifyFileSystemWatcherEngine::run (this=0x2fba1f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f57b623cec5 in QThreadPrivate::start (arg=0x2fba1f0) at thread/qthread_unix.cpp:331
#9  0x00007f57adc94b50 in start_thread (arg=<optimized out>) at pthread_create.c:304
#10 0x00007f57b91fd90d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f57b990e780 (LWP 2286)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f578d34c281 in ~QHashNode (this=0x37c5410, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#8  deleteNode2 (node=0x37c5410) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (node=0x37c5410, this=0x340f488) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x340f488, akey=...) at /usr/include/qt4/QtCore/qhash.h:795
#11 0x00007f578d34c3dc in remove (akey=..., this=0x340f488) at /usr/include/qt4/QtCore/qhash.h:784
#12 HotplugEngine::onDeviceRemoved (this=0x340f460, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#13 0x00007f578d34e6a9 in HotplugEngine::qt_metacall (this=0x340f460, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04647270) at ./hotplugengine.moc:81
#14 0x00007f57b63364ba in QMetaObject::activate (sender=0x2fbd4f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff04647270) at kernel/qobject.cpp:3278
#15 0x00007f57b1924875 in Solid::DeviceNotifier::deviceRemoved (this=<optimized out>, _t1=...) at ./devicenotifier.moc:94
#16 0x00007f57b1925a5d in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x2fbd4f0, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#17 0x00007f57b1926219 in Solid::DeviceManagerPrivate::qt_metacall (this=0x2fbd4f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04647420) at ./devicemanager_p.moc:80
#18 0x00007f57b63364ba in QMetaObject::activate (sender=0x2fbb6b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff04647420) at kernel/qobject.cpp:3278
#19 0x00007f57b1938a25 in Solid::Ifaces::DeviceManager::deviceRemoved (this=<optimized out>, _t1=...) at ./ifaces/devicemanager.moc:94
#20 0x00007f57b19792f6 in slotDeviceRemoved (opath=..., this=0x2fbb6b0) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#21 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x2fbb6b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04647780) at ./backends/upower/upowermanager.moc:78
#22 0x00007f57b63364ba in QMetaObject::activate (sender=0x2fbb6c8, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff04647780) at kernel/qobject.cpp:3278
#23 0x00007f57b668a6ad in QDBusInterfacePrivate::metacall (this=0x2fccea0, c=<optimized out>, id=4, argv=0x7fff04647780) at qdbusinterface.cpp:278
#24 0x00007f57b66769ab in QDBusConnectionPrivate::deliverCall (this=0x1c41b40, object=0x2fbb6c8, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:942
#25 0x00007f57b667fcbf in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#26 0x00007f57b633a06a in QObject::event (this=0x2fbb6c8, e=<optimized out>) at kernel/qobject.cpp:1217
#27 0x00007f57b56f2df4 in notify_helper (e=0x3565ec0, receiver=0x2fbb6c8, this=0x1b2ac70) at kernel/qapplication.cpp:4486
#28 QApplicationPrivate::notify_helper (this=0x1b2ac70, receiver=0x2fbb6c8, e=0x3565ec0) at kernel/qapplication.cpp:4458
#29 0x00007f57b56f7c81 in QApplication::notify (this=0x1b1eb30, receiver=0x2fbb6c8, e=0x3565ec0) at kernel/qapplication.cpp:4365
#30 0x00007f57b701db26 in KApplication::notify (this=0x1b1eb30, receiver=0x2fbb6c8, event=0x3565ec0) at ../../kdeui/kernel/kapplication.cpp:311
#31 0x00007f57b632376c in QCoreApplication::notifyInternal (this=0x1b1eb30, receiver=0x2fbb6c8, event=0x3565ec0) at kernel/qcoreapplication.cpp:787
#32 0x00007f57b6326b48 in sendEvent (event=0x3565ec0, receiver=0x2fbb6c8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1abc430) at kernel/qcoreapplication.cpp:1428
#34 0x00007f57b634dfe3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#35 postEventSourceDispatch (s=0x1b2d570) at kernel/qeventdispatcher_glib.cpp:277
#36 0x00007f57acf7e0cf in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007f57acf7e8c8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007f57acf7ea99 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f57b634e43f in QEventDispatcherGlib::processEvents (this=0x1abdf40, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#40 0x00007f57b57972ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f57b6322972 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007f57b6322b6f in QEventLoop::exec (this=0x7fff04648140, flags=...) at kernel/qeventloop.cpp:201
#43 0x00007f57b6326d37 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#44 0x00007f57b94ef673 in kdemain (argc=1, argv=0x7fff04648528) at ../../../../plasma/desktop/shell/main.cpp:120
#45 0x00007f57b9143ead in __libc_start_main (main=<optimized out>, argc=<optimized out>, ubp_av=<optimized out>, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff04648518) at libc-start.c:228
#46 0x00000000004006c1 in _start ()

This bug may be a duplicate of or related to bug 266383.

Possible duplicates by query: bug 296847, bug 296661, bug 294357, bug 294324, bug 294036.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-30 07:32:19 UTC

*** This bug has been marked as a duplicate of bug 266383 ***