Bug 281300 - Plasma crashing when unlocking screen
Summary: Plasma crashing when unlocking screen
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-04 01:50 UTC by hermann.andreas
Modified: 2011-12-07 12:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hermann.andreas 2011-09-04 01:50:54 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.5 (4.6.5) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 3.0.4-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- When unlocking screen via xscreensaver, plasma desktop sometimes crashes.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd5bd592760 (LWP 3323))]

Thread 2 (Thread 0x7fd59e5e6700 (LWP 3329)):
#0  idleTimerSourcePrepare (source=<value optimized out>, timeout=0x7fd59e5e5b8c) at kernel/qeventdispatcher_glib.cpp:207
#1  0x00007fd5b7bd2cb9 in g_main_context_prepare (context=0x2879580, priority=<value optimized out>) at gmain.c:2762
#2  0x00007fd5b7bd3118 in g_main_context_iterate (context=0x2879580, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:3072
#3  0x00007fd5b7bd36fc in g_main_context_iteration (context=0x2879580, may_block=1) at gmain.c:3155
#4  0x00007fd5bc1cc6b6 in QEventDispatcherGlib::processEvents (this=0x2878590, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fd5bc19f222 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007fd5bc19f60c in QEventLoop::exec (this=0x7fd59e5e5d20, flags=) at kernel/qeventloop.cpp:201
#7  0x00007fd5bc0ab4bd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007fd5bc17f098 in QInotifyFileSystemWatcherEngine::run (this=0x2877e30) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fd5bc0ae4b5 in QThreadPrivate::start (arg=0x2877e30) at thread/qthread_unix.cpp:320
#10 0x00007fd5af1c79e3 in ?? () from /usr/lib64/opengl/nvidia/lib/libGL.so.1
#11 0x00007fd5bbe1bc1a in start_thread (arg=<value optimized out>) at pthread_create.c:301
#12 0x00007fd5babb428d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fd5bd592760 (LWP 3323)):
[KCrash Handler]
#6  0x00007fd5b52498be in ~QExplicitlySharedDataPointer (this=<value optimized out>, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#7  Solid::Device::~Device (this=<value optimized out>, __in_chrg=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/solid/solid/device.cpp:87
#8  0x00007fd59e5eeb03 in ~QHashNode (this=0x2945488, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:217
#9  deleteNode2 (this=0x2945488, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#10 deleteNode (this=0x2945488, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:507
#11 QHash<QString, Solid::Device>::remove (this=0x2945488, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#12 0x00007fd59e5ebccc in HotplugEngine::onDeviceRemoved (this=0x2945460, udi=...) at /var/tmp/portage/kde-base/plasma-workspace-4.6.5/work/plasma-workspace-4.6.5/plasma/generic/dataengines/hotplug/hotplugengine.cpp:243
#13 0x00007fd59e5edf39 in HotplugEngine::qt_metacall (this=0x2945460, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5359d7d0) at /var/tmp/portage/kde-base/plasma-workspace-4.6.5/work/plasma-workspace-4.6.5_build/plasma/generic/dataengines/hotplug/hotplugengine.moc:81
#14 0x00007fd5bc1b8277 in QMetaObject::activate (sender=0x29408c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x3f59040) at kernel/qobject.cpp:3278
#15 0x00007fd5b524aeb5 in Solid::DeviceNotifier::deviceRemoved (this=0x2aee960, _t1=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5_build/solid/solid/devicenotifier.moc:94
#16 0x00007fd5b524dfb3 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x29408c0, udi=...) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/solid/solid/devicemanager.cpp:207
#17 0x00007fd5b524e451 in Solid::DeviceManagerPrivate::qt_metacall (this=0x29408c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5359d9c0) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5_build/solid/solid/devicemanager_p.moc:80
#18 0x00007fd5bc1b8277 in QMetaObject::activate (sender=0x28803e0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x3f59040) at kernel/qobject.cpp:3278
#19 0x00007fd5b5261da5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x2aee960, _t1=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5_build/solid/solid/ifaces/devicemanager.moc:94
#20 0x00007fd5b52ad9d6 in slotDeviceRemoved (this=0x28803e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5359dc70) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/solid/solid/backends/upower/upowermanager.cpp:164
#21 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x28803e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5359dc70) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5_build/solid/solid/backends/upower/upowermanager.moc:78
#22 0x00007fd5bc1b8277 in QMetaObject::activate (sender=0x28803f8, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x3f59040) at kernel/qobject.cpp:3278
#23 0x00007fd5b8fbb9ff in QDBusInterfacePrivate::metacall (this=<value optimized out>, c=<value optimized out>, id=<value optimized out>, argv=<value optimized out>) at qdbusinterface.cpp:278
#24 0x00007fd5b8fa79e9 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:941
#25 0x00007fd5b8fb188f in QDBusCallDeliveryEvent::placeMetaCall (this=0x1, object=0x29dc9d0) at qdbusintegrator_p.h:103
#26 0x00007fd5bc1b234e in QObject::event (this=0x28803f8, e=0x2aee960) at kernel/qobject.cpp:1217
#27 0x00007fd5bb323bfc in QApplicationPrivate::notify_helper (this=0x1c4d7f0, receiver=0x28803f8, e=0x3f47d20) at kernel/qapplication.cpp:4462
#28 0x00007fd5bb32903d in QApplication::notify (this=0x1c24570, receiver=0x28803f8, e=0x3f47d20) at kernel/qapplication.cpp:4341
#29 0x00007fd5bcf7c8c6 in KApplication::notify (this=0x1c24570, receiver=0x28803f8, event=0x3f47d20) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#30 0x00007fd5bc1a04fc in QCoreApplication::notifyInternal (this=0x1c24570, receiver=0x28803f8, event=0x3f47d20) at kernel/qcoreapplication.cpp:731
#31 0x00007fd5bc1a3493 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1b5cb00) at kernel/qcoreapplication.h:215
#32 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1b5cb00) at kernel/qcoreapplication.cpp:1372
#33 0x00007fd5bc1ccb23 in sendPostedEvents (s=0x1c50ec0) at kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=0x1c50ec0) at kernel/qeventdispatcher_glib.cpp:277
#35 0x00007fd5b7bcee82 in g_main_dispatch (context=0x1c500e0) at gmain.c:2441
#36 g_main_context_dispatch (context=0x1c500e0) at gmain.c:3014
#37 0x00007fd5b7bd3548 in g_main_context_iterate (context=0x1c500e0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:3092
#38 0x00007fd5b7bd36fc in g_main_context_iteration (context=0x1c500e0, may_block=1) at gmain.c:3155
#39 0x00007fd5bc1cc663 in QEventDispatcherGlib::processEvents (this=0x1c25960, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#40 0x00007fd5bb3d5c9e in QGuiEventDispatcherGlib::processEvents (this=0x2aee960, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007fd5bc19f222 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#42 0x00007fd5bc19f60c in QEventLoop::exec (this=0x7fff5359e860, flags=) at kernel/qeventloop.cpp:201
#43 0x00007fd5bc1a36cb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#44 0x00007fd5aa30c5b3 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /var/tmp/portage/kde-base/plasma-workspace-4.6.5/work/plasma-workspace-4.6.5/plasma/desktop/shell/main.cpp:120
#45 0x0000000000407f13 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b28b "0") at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/kinit/kinit.cpp:734
#46 0x0000000000408b20 in handle_launcher_request (sock=7, who=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/kinit/kinit.cpp:1226
#47 0x000000000040907b in handle_requests (waitForPid=0) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/kinit/kinit.cpp:1419
#48 0x0000000000409c12 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.5-r1/work/kdelibs-4.6.5/kinit/kinit.cpp:1907

Possible duplicates by query: bug 281285, bug 279287, bug 278141, bug 277964, bug 276944.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-10-31 02:41:51 UTC

*** This bug has been marked as a duplicate of bug 278141 ***
Comment 2 Jekyll Wu 2011-12-07 12:39:41 UTC

*** This bug has been marked as a duplicate of bug 266383 ***