Bug 268994 - Run comman crashes frequently
Summary: Run comman crashes frequently
Status: RESOLVED DUPLICATE of bug 266383
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-20 22:23 UTC by Thomas Damgaard
Modified: 2011-12-07 12:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Damgaard 2011-03-20 22:23:31 UTC
Application: krunner (0.1)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I was maximizing Konsole.
This also happens at other seemingly random times. But always when I am doing something in the window manager. Like resizing or moving a window.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Run Command Interface (krunner), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8c7e6fd7a0 (LWP 2224))]

Thread 2 (Thread 0x7f8c64b92700 (LWP 2225)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f8c64b91990 in ?? ()
#2  0x00007fffb57ff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f8c7e6fd7a0 (LWP 2224)):
[KCrash Handler]
#6  0x00007f8800000008 in ?? ()
#7  0x00007f8c559524d3 in ~QHashNode (this=0x1929d88, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:217
#8  deleteNode2 (this=0x1929d88, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (this=0x1929d88, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x1929d88, akey=<value optimized out>) at /usr/include/qt4/QtCore/qhash.h:794
#11 0x00007f8c5594f69c in HotplugEngine::onDeviceRemoved (this=0x1929d60, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:243
#12 0x00007f8c55951909 in HotplugEngine::qt_metacall (this=0x1929d60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb57d9da0) at ./hotplugengine.moc:81
#13 0x00007f8c7aa16b27 in QMetaObject::activate (sender=0x13ec360, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f8c6003c3c4) at kernel/qobject.cpp:3280
#14 0x00007f8c761f2a05 in Solid::DeviceNotifier::deviceRemoved (this=0x7f8c6007ba80, _t1=<value optimized out>) at ./devicenotifier.moc:94
#15 0x00007f8c761f5ae3 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x13ec360, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#16 0x00007f8c761f5f81 in Solid::DeviceManagerPrivate::qt_metacall (this=0x13ec360, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb57d9f90) at ./devicemanager_p.moc:80
#17 0x00007f8c7aa16b27 in QMetaObject::activate (sender=0x7f8c6000f9d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f8c6003c3c4) at kernel/qobject.cpp:3280
#18 0x00007f8c762098d5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x7f8c6007ba80, _t1=<value optimized out>) at ./ifaces/devicemanager.moc:94
#19 0x00007f8c7625ef29 in Solid::Backends::UDisks::UDisksManager::slotDeviceRemoved (this=0x7f8c6000f9d0, opath=...) at ../../../solid/solid/backends/udisks/udisksmanager.cpp:217
#20 0x00007f8c7625f091 in Solid::Backends::UDisks::UDisksManager::qt_metacall (this=0x7f8c6000f9d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb57da490) at ./backends/udisks/udisksmanager.moc:80
#21 0x00007f8c7aa16b27 in QMetaObject::activate (sender=0x7f8c6000f9f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f8c6003c3c4) at kernel/qobject.cpp:3280
#22 0x00007f8c7a653c2f in QDBusInterfacePrivate::metacall (this=<value optimized out>, c=<value optimized out>, id=<value optimized out>, argv=<value optimized out>) at qdbusinterface.cpp:278
#23 0x00007f8c7a63e0ee in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#24 0x00007f8c7a6490ef in QDBusCallDeliveryEvent::placeMetaCall (this=0x7f8800000008, object=0x7f8c6002d754) at qdbusintegrator_p.h:103
#25 0x00007f8c7aa10bde in QObject::event (this=0x7f8c6000f9f0, e=0x7f8c6007ba80) at kernel/qobject.cpp:1219
#26 0x00007f8c7b3e1fdc in QApplicationPrivate::notify_helper (this=0x12d01f0, receiver=0x7f8c6000f9f0, e=0x7f8c60019d70) at kernel/qapplication.cpp:4396
#27 0x00007f8c7b3e7aed in QApplication::notify (this=0x12c9bb0, receiver=0x7f8c6000f9f0, e=0x7f8c60019d70) at kernel/qapplication.cpp:4277
#28 0x00007f8c7cf512c6 in KApplication::notify (this=0x12c9bb0, receiver=0x7f8c6000f9f0, event=0x7f8c60019d70) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007f8c7a9fecdc in QCoreApplication::notifyInternal (this=0x12c9bb0, receiver=0x7f8c6000f9f0, event=0x7f8c60019d70) at kernel/qcoreapplication.cpp:732
#30 0x00007f8c7aa01c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1264530) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1264530) at kernel/qcoreapplication.cpp:1373
#32 0x00007f8c7aa2b653 in sendPostedEvents (s=0x12d3aa0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x12d3aa0) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f8c73757342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f8c7375b2a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f8c7375b45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f8c7aa2b193 in QEventDispatcherGlib::processEvents (this=0x1263c20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f8c7b494a4e in QGuiEventDispatcherGlib::processEvents (this=0x7f8c6007ba80, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f8c7a9fda02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f8c7a9fddec in QEventLoop::exec (this=0x7fffb57daed0, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f8c7aa01ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f8c7e2f9f04 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../krunner/main.cpp:65
#43 0x00007f8c7df69d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffb57db198) at libc-start.c:226
#44 0x0000000000400669 in _start ()

Possible duplicates by query: bug 249236, bug 247117, bug 240898, bug 235808.

Reported using DrKonqi
Comment 1 Dario Andres 2011-04-11 02:15:26 UTC
This seems related to bug 266383. Regards
Comment 2 Jekyll Wu 2011-12-07 12:31:32 UTC

*** This bug has been marked as a duplicate of bug 266383 ***