Bug 254741

Summary: Multiple Application Crashes During and Immediately After running bleachbit
Product: kdelibs Reporter: Andrew Lambert <andrew>
Component: kshareddatacacheAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED NOT A BUG    
Severity: crash CC: 123design, arthur.marceauxditclement, axel.krebs, cfeck, deleteme, dutchgigalo, eric.vanh, fd.svensson, heubertt, lhbcomm, michael, mpyne, openweb, renardvoss, rflazaro, trennor.turcotte95
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi
New crash information added by DrKonqi
New crash information added by DrKonqi

Description Andrew Lambert 2010-10-20 09:57:56 UTC
Application: konsole (2.5)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Running bleachbit (launched from Konsole with sudo
- Unusual behavior I noticed:
konsole crashed, kwin crashed, konversation crashed, KDE Wallet crashed when the crash reporter tried to access my logon details to report the crash. Non-KDE (QT4) applications were not affected: Firefox, Thunderbird, Amarok 1.4, etc.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Konsole (konsole), signal: Bus error
[Current thread is 1 (Thread 0x7fd9c03b9760 (LWP 6749))]

Thread 3 (Thread 0x7fd9ad69a710 (LWP 6750)):
#0  0x00007fd9bfd222b3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fd9be8cde8d in QProcessManager::run (this=0x7fd9bec23f40) at io/qprocess_unix.cpp:245
#2  0x00007fd9be7fe27e in QThreadPrivate::start (arg=0x7fd9bec23f40) at thread/qthread_unix.cpp:266
#3  0x00007fd9bcb8c971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007fd9bfd2991d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd9a690a710 (LWP 6770)):
#0  0x00007fd9bfd1d1d3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd9b9499009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fd9b949945c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fd9be91e1e6 in QEventDispatcherGlib::processEvents (this=0xc52ab0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007fd9be8f0a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fd9be8f0dec in QEventLoop::exec (this=0x7fd9a6909db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fd9be7fb2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fd9be8d05f8 in QInotifyFileSystemWatcherEngine::run (this=0xb49090) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd9be7fe27e in QThreadPrivate::start (arg=0xb49090) at thread/qthread_unix.cpp:266
#9  0x00007fd9bcb8c971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007fd9bfd2991d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd9c03b9760 (LWP 6749)):
[KCrash Handler]
#6  pthread_mutex_timedlock (mutex=0x7fd9b2bae008, abstime=0x7fff4d90d060) at pthread_mutex_timedlock.c:40
#7  0x00007fd9bee6ae43 in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#8  0x00007fd9bee66faa in KSharedDataCache::find (this=0x906150, key=..., destination=0x7fff4d90d2c0) at ../../kdecore/util/kshareddatacache.cpp:1355
#9  0x00007fd9bf2bfd8c in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x8bd4b0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:862
#10 0x00007fd9bf2c7f53 in KIconLoader::loadIcon (this=0x904bf0, _name=<value optimized out>, group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1218
#11 0x00007fd9bf2becf0 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x00007fd9bdd0de55 in QIcon::pixmap (this=<value optimized out>, size=..., mode=QIcon::Disabled, state=1301337136) at image/qicon.cpp:676
#13 0x00007fd9bdf8a916 in QCommonStyle::drawControl (this=0x9022c0, element=<value optimized out>, opt=0x7fff4d910310, p=0x7fff4d914390, widget=0x9b1260) at styles/qcommonstyle.cpp:1891
#14 0x00007fd9be01e15e in QWindowsStyle::drawControl (this=0x9022c0, ce=QStyle::CE_TabBarTabLabel, opt=0x7fff4d910310, p=0x7fff4d914390, widget=0x9b1260) at styles/qwindowsstyle.cpp:2560
#15 0x00007fd9be00b8c3 in QCleanlooksStyle::drawControl (this=<value optimized out>, element=QStyle::CE_TabBarTabLabel, option=0x7fff4d910310, painter=0x7fff4d914390, widget=<value optimized out>) at styles/qcleanlooksstyle.cpp:2367
#16 0x00007fd9bdfb5b25 in QStyleSheetStyle::drawControl (this=0x99a570, ce=QStyle::CE_TabBarTabLabel, opt=0x7fff4d9141f0, p=0x7fff4d914390, w=0x9b1260) at styles/qstylesheetstyle.cpp:4017
#17 0x00007fd9bdf8bf3f in QCommonStyle::drawControl (this=<value optimized out>, element=<value optimized out>, opt=0x7fff4d9141f0, p=0x7fff4d914390, widget=0x9b1260) at styles/qcommonstyle.cpp:1698
#18 0x00007fd9be01e15e in QWindowsStyle::drawControl (this=0x99a570, ce=QStyle::CE_TabBarTab, opt=0x7fff4d9141f0, p=0x7fff4d914390, widget=0x9b1260) at styles/qwindowsstyle.cpp:2560
#19 0x00007fd9bdfb295e in QStyleSheetStyle::drawControl (this=0x99a570, ce=<value optimized out>, opt=0x7fff4d9141f0, p=0x7fff4d914390, w=0x9b1260) at styles/qstylesheetstyle.cpp:3993
#20 0x00007fd9be0e6f1b in drawControl (this=0x9b1260) at ../../include/QtGui/../../src/gui/painting/qstylepainter.h:89
#21 QTabBar::paintEvent (this=0x9b1260) at widgets/qtabbar.cpp:1588
#22 0x00007fd9bdcaec2e in QWidget::event (this=0x9b1260, event=0x7fff4d914c60) at kernel/qwidget.cpp:8333
#23 0x00007fd9be0e5fea in QTabBar::event (this=0x9b1260, event=0x7fff4d914c60) at widgets/qtabbar.cpp:1503
#24 0x00007fd9bdc58fdc in QApplicationPrivate::notify_helper (this=0x872bc0, receiver=0x9b1260, e=0x7fff4d914c60) at kernel/qapplication.cpp:4396
#25 0x00007fd9bdc5eaed in QApplication::notify (this=0x7fff4d916f30, receiver=0x9b1260, e=0x7fff4d914c60) at kernel/qapplication.cpp:4277
#26 0x00007fd9bf312156 in KApplication::notify (this=0x7fff4d916f30, receiver=0x9b1260, event=0x7fff4d914c60) at ../../kdeui/kernel/kapplication.cpp:310
#27 0x00007fd9be8f1cdc in QCoreApplication::notifyInternal (this=0x7fff4d916f30, receiver=0x9b1260, event=0x7fff4d914c60) at kernel/qcoreapplication.cpp:732
#28 0x00007fd9bdcb567d in sendSpontaneousEvent (this=0x9b1c30, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x966960) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 QWidgetPrivate::drawWidget (this=0x9b1c30, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x966960) at kernel/qwidget.cpp:5420
#30 0x00007fd9bdcb6328 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=0, rgn=<value optimized out>, offset=<value optimized out>, flags=68, sharedPainter=0x0, backingStore=0x966960) at kernel/qwidget.cpp:5627
#31 0x00007fd9bdcb53da in QWidgetPrivate::drawWidget (this=0x9b1540, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x966960) at kernel/qwidget.cpp:5473
#32 0x00007fd9bdcb6328 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=0, rgn=<value optimized out>, offset=<value optimized out>, flags=68, sharedPainter=0x0, backingStore=0x966960) at kernel/qwidget.cpp:5627
#33 0x00007fd9bdcb53da in QWidgetPrivate::drawWidget (this=0x96d750, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x966960) at kernel/qwidget.cpp:5473
#34 0x00007fd9bdcb6328 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=1, rgn=<value optimized out>, offset=<value optimized out>, flags=68, sharedPainter=0x0, backingStore=0x966960) at kernel/qwidget.cpp:5627
#35 0x00007fd9bdcb53da in QWidgetPrivate::drawWidget (this=0x97bf60, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x966960) at kernel/qwidget.cpp:5473
#36 0x00007fd9bdcb6328 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=8, rgn=<value optimized out>, offset=<value optimized out>, flags=68, sharedPainter=0x0, backingStore=0x966960) at kernel/qwidget.cpp:5627
#37 0x00007fd9bdcb53da in QWidgetPrivate::drawWidget (this=0x95dba0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x966960) at kernel/qwidget.cpp:5473
#38 0x00007fd9bde893a6 in QWidgetBackingStore::sync (this=0x966960) at painting/qbackingstore.cpp:1320
#39 0x00007fd9bdca8730 in QWidgetPrivate::syncBackingStore (this=0x95dba0) at kernel/qwidget.cpp:1805
#40 0x00007fd9bdcaf2f5 in QWidget::event (this=0x9583b0, event=0x99e960) at kernel/qwidget.cpp:8480
#41 0x00007fd9be09641b in QMainWindow::event (this=0x9583b0, event=0x99e960) at widgets/qmainwindow.cpp:1417
#42 0x00007fd9bf42e683 in KXmlGuiWindow::event (this=0x7fd9b2bae008, ev=0x7fff4d90d060) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:130
#43 0x00007fd9bdc58fdc in QApplicationPrivate::notify_helper (this=0x872bc0, receiver=0x9583b0, e=0x99e960) at kernel/qapplication.cpp:4396
#44 0x00007fd9bdc5eaed in QApplication::notify (this=0x7fff4d916f30, receiver=0x9583b0, e=0x99e960) at kernel/qapplication.cpp:4277
#45 0x00007fd9bf312156 in KApplication::notify (this=0x7fff4d916f30, receiver=0x9583b0, event=0x99e960) at ../../kdeui/kernel/kapplication.cpp:310
#46 0x00007fd9be8f1cdc in QCoreApplication::notifyInternal (this=0x7fff4d916f30, receiver=0x9583b0, event=0x99e960) at kernel/qcoreapplication.cpp:732
#47 0x00007fd9be8f4c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x841790) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#48 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x841790) at kernel/qcoreapplication.cpp:1373
#49 0x00007fd9be91e653 in sendPostedEvents (s=0x86c260) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#50 postEventSourceDispatch (s=0x86c260) at kernel/qeventdispatcher_glib.cpp:277
#51 0x00007fd9b9495342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#52 0x00007fd9b94992a8 in ?? () from /lib/libglib-2.0.so.0
#53 0x00007fd9b949945c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#54 0x00007fd9be91e193 in QEventDispatcherGlib::processEvents (this=0x8412d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#55 0x00007fd9bdd0ba4e in QGuiEventDispatcherGlib::processEvents (this=0x7fd9b2bae008, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#56 0x00007fd9be8f0a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#57 0x00007fd9be8f0dec in QEventLoop::exec (this=0x7fff4d916e80, flags=) at kernel/qeventloop.cpp:201
#58 0x00007fd9be8f4ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#59 0x00007fd9bffd96d6 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_konsole.so
#60 0x00007fd9bfc61d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff4d917178) at libc-start.c:226
#61 0x0000000000400659 in _start ()

Reported using DrKonqi
Comment 1 Matthias Fuchs 2010-11-24 00:00:08 UTC
*** Bug 257683 has been marked as a duplicate of this bug. ***
Comment 2 Nicolas L. 2011-01-03 17:29:14 UTC
*** Bug 261961 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2011-01-04 00:02:13 UTC
*** Bug 261960 has been marked as a duplicate of this bug. ***
Comment 4 Light Yagami 2011-01-14 18:46:11 UTC
Created attachment 56015 [details]
New crash information added by DrKonqi

kwin (4.5.1 (KDE 4.5.1)) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed: I was running Bleachbit in Sudomode.

- Unusual behavior I noticed: When you run Sudo mode of bleachbit with a Sudo startx -- :1 (kde sudo) you get awful bugs.

-- Backtrace (Reduced):
#8  0xb6c37de7 in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#9  0xb6c335e4 in KSharedDataCache::find (this=0x9db4038, key=..., destination=0xbff491dc) at ../../kdecore/util/kshareddatacache.cpp:1355
#10 0xb731e558 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x9db0cb0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:862
#11 0xb7326bcf in KIconLoader::loadIcon (this=0x9dad9c0, _name=..., group=KIconLoader::Small, size=32, state=0, overlays=..., path_store=0x0, canReturnNull=true) at ../../kdeui/icons/kiconloader.cpp:1218
#12 0xb74daa31 in KWindowSystem::icon (win=33558186, width=32, height=32, scale=true, flags=12) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:655
Comment 5 Light Yagami 2011-01-17 08:23:12 UTC
Created attachment 56115 [details]
New crash information added by DrKonqi

kwin (4.5.1 (KDE 4.5.1)) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed: Running bleach bit in SUDO mode and in normal mode, does cause my system to crash, normal mode is a bit more stable still i get crashes.

-- Backtrace (Reduced):
#8  0xb6cd4de7 in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#9  0xb6cd05e4 in KSharedDataCache::find (this=0x9c697b8, key=..., destination=0xbfbcd34c) at ../../kdecore/util/kshareddatacache.cpp:1355
#10 0xb73bb558 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x9c61038, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:862
#11 0xb73c3bcf in KIconLoader::loadIcon (this=0x9c61488, _name=..., group=KIconLoader::Small, size=32, state=0, overlays=..., path_store=0x0, canReturnNull=true) at ../../kdeui/icons/kiconloader.cpp:1218
#12 0xb7577a31 in KWindowSystem::icon (win=23072461, width=32, height=32, scale=true, flags=12) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:655
Comment 6 Christoph Feck 2011-01-21 17:49:32 UTC
*** Bug 263822 has been marked as a duplicate of this bug. ***
Comment 7 Ac17 2011-01-28 21:57:00 UTC
Created attachment 56590 [details]
New crash information added by DrKonqi

kwrite (4.5.95 (4.6 RC2)) on KDE Platform 4.5.95 (4.6 RC2) using Qt 4.7.0

- What I was doing when the application crashed:

I'm just finnish'd Bleshbit and should start firefox when it's happened

-- Backtrace (Reduced):
#6  0x00007f250630844b in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#7  0x00007f2506305aed in KSharedDataCache::find (this=0x25fed80, key=..., destination=0x7fff2b796dc0) at ../../kdecore/util/kshareddatacache.cpp:1457
#8  0x00007f2507481edc in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x23f5230, key=..., data=..., path=<value optimized out>) at ../../kdeui/icons/kiconloader.cpp:868
#9  0x00007f25074892f1 in KIconLoader::loadIcon (this=0x25fc290, _name=<value optimized out>, group=KIconLoader::Desktop, size=22, state=1, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1231
#10 0x00007f250747fdf0 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
Comment 8 Ac17 2011-01-28 22:02:47 UTC
Created attachment 56591 [details]
New crash information added by DrKonqi

kwin (4.5.95 (4.6 RC2)) on KDE Platform 4.5.95 (4.6 RC2) using Qt 4.7.0

- What I was doing when the application crashed:I've was doing the same thing but I've Bleachbit as a program.

-- Backtrace (Reduced):
#6  0x00007f1c7c3dd44b in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#7  0x00007f1c7c3daaed in KSharedDataCache::find (this=0x1f1bcf0, key=..., destination=0x7fff3ac44280) at ../../kdecore/util/kshareddatacache.cpp:1457
#8  0x00007f1c7f301edc in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x1f16180, key=..., data=..., path=<value optimized out>) at ../../kdeui/icons/kiconloader.cpp:868
#9  0x00007f1c7f3092f1 in KIconLoader::loadIcon (this=0x1cfbfd0, _name=<value optimized out>, group=KIconLoader::Small, size=32, state=0, overlays=..., path_store=0x0, canReturnNull=true) at ../../kdeui/icons/kiconloader.cpp:1231
#10 0x00007f1c7f4a6442 in KWindowSystem::icon (win=<value optimized out>, width=32, height=<value optimized out>, scale=<value optimized out>, flags=12) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:655
Comment 9 Dario Andres 2011-01-29 13:22:14 UTC
*** Bug 264677 has been marked as a duplicate of this bug. ***
Comment 10 Michael Pyne 2011-04-10 00:55:31 UTC
Does BleachBit touch /var/tmp? Because if it does, it shouldn't. I can add yet more sanity checks to try and detect other processes tromping around in the icon cache, but if the cache file needs to be removed the safe way to do it is to only use rm or unlink(), do *not* "shred" the contents of the file first.
Comment 11 Ac17 2011-04-11 00:05:57 UTC
With Kubuntu 11.04 Beta this is not a problem for me any more
Comment 12 Dario Andres 2011-05-01 15:03:17 UTC
*** Bug 271893 has been marked as a duplicate of this bug. ***
Comment 13 Dario Andres 2011-05-01 15:03:19 UTC
*** Bug 271894 has been marked as a duplicate of this bug. ***
Comment 14 Aaron J. Seigo 2011-05-06 17:16:22 UTC
*** Bug 272284 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2011-05-08 13:47:06 UTC
*** Bug 261959 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2011-05-08 13:52:29 UTC
In accordance to bug 271889, I am closing this one, too.

If BleachBit is setup to *not* write random data to files in /var/tmp, please reopen.
Comment 17 Thomas Lübking 2011-06-04 12:43:37 UTC
*** Bug 274884 has been marked as a duplicate of this bug. ***
Comment 18 Christoph Feck 2011-10-15 02:10:49 UTC
*** Bug 284041 has been marked as a duplicate of this bug. ***
Comment 19 Jekyll Wu 2012-07-10 15:32:44 UTC
*** Bug 303307 has been marked as a duplicate of this bug. ***
Comment 20 Jekyll Wu 2012-07-10 15:33:51 UTC
*** Bug 303308 has been marked as a duplicate of this bug. ***
Comment 21 Jekyll Wu 2012-07-10 15:34:26 UTC
*** Bug 303310 has been marked as a duplicate of this bug. ***
Comment 22 Jekyll Wu 2012-07-10 15:47:41 UTC
*** Bug 303312 has been marked as a duplicate of this bug. ***
Comment 23 trennor 2012-07-10 16:25:39 UTC
Why  send me this?! What's being DONE  about it?! Marking it as a duplicate
only tells me others are having the same trouble; is it FIXED yet?
Where's the repaired version?
On Tue, Jul 10, 2012 at 10:47 AM, Jekyll Wu <adaptee@gmail.com> wrote:

> https://bugs.kde.org/show_bug.cgi?id=254741
>
> --- Comment #22 from Jekyll Wu <adaptee@gmail.com> ---
> *** Bug 303312 has been marked as a duplicate of this bug. ***
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>
Comment 24 Christoph Feck 2012-07-10 17:33:07 UTC
> Where's the repaired version?

Upgrade bleachbit to a version that does not overwrite vital KDE files while KDE runs.
Comment 25 trennor 2012-07-10 17:57:15 UTC
And which one is that?

On Tue, Jul 10, 2012 at 12:33 PM, Christoph Feck <christoph@maxiom.de>wrote:

> https://bugs.kde.org/show_bug.cgi?id=254741
>
> --- Comment #24 from Christoph Feck <christoph@maxiom.de> ---
> > Where's the repaired version?
>
> Upgrade bleachbit to a version that does not overwrite vital KDE files
> while
> KDE runs.
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>
Comment 26 Christoph Feck 2012-07-10 18:17:41 UTC
0.8.8
Comment 27 Axel Krebs 2012-07-11 06:02:54 UTC
Thanks for hint; I run the software contained in my distri, usually.

Axel

Am 10.07.2012 19:33, schrieb Christoph Feck:
> https://bugs.kde.org/show_bug.cgi?id=254741
> 
> --- Comment #24 from Christoph Feck <christoph@maxiom.de> ---
>> Where's the repaired version?
> 
> Upgrade bleachbit to a version that does not overwrite vital KDE files while
> KDE runs.
>
Comment 28 Thomas Lübking 2012-07-14 07:41:30 UTC
*** Bug 303509 has been marked as a duplicate of this bug. ***
Comment 29 Thomas Lübking 2013-06-02 10:50:59 UTC
*** Bug 320603 has been marked as a duplicate of this bug. ***
Comment 30 Michael 2013-06-02 14:53:55 UTC
ok, thanks!
Comment 31 Thomas Lübking 2014-09-01 09:56:26 UTC
*** Bug 338717 has been marked as a duplicate of this bug. ***
Comment 32 Martin Flöser 2014-09-01 10:15:55 UTC
*** Bug 338714 has been marked as a duplicate of this bug. ***
Comment 33 Christoph Feck 2014-09-01 22:06:18 UTC
*** Bug 338713 has been marked as a duplicate of this bug. ***
Comment 34 Christoph Feck 2014-09-01 22:07:33 UTC
*** Bug 338715 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Feck 2014-09-01 22:08:06 UTC
*** Bug 338716 has been marked as a duplicate of this bug. ***
Comment 36 Christoph Feck 2014-09-01 22:08:23 UTC
*** Bug 338718 has been marked as a duplicate of this bug. ***
Comment 37 Thomas Lübking 2015-03-28 08:48:44 UTC
*** Bug 345605 has been marked as a duplicate of this bug. ***
Comment 38 Frank Reininghaus 2015-06-16 19:52:19 UTC
*** Bug 349232 has been marked as a duplicate of this bug. ***