Bug 257683 - kget crashed while right clicking its panel symbol
Summary: kget crashed while right clicking its panel symbol
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kget
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KGet authors
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-23 11:12 UTC by renardvoss
Modified: 2010-11-24 00:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description renardvoss 2010-11-23 11:12:29 UTC
Application: kget (2.5.1)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I tried to right click the kget symbol in the panel.

Some minutes before i used bleachbit to clean up my system, but I don't know if this affected kget.

-- Backtrace:
Application: KGet (kget), signal: Bus error
[Current thread is 1 (Thread 0x7f61832f0760 (LWP 30575))]

Thread 2 (Thread 0x7f6175471700 (LWP 30576)):
#0  0x00007f617a4db878 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0x00007f617a4dbe78 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f617a4dc7b5 in g_main_loop_run () from /lib/libglib-2.0.so.0
#3  0x00007f6175ba83c4 in ?? () from /usr/lib/libgio-2.0.so.0
#4  0x00007f617a5017e4 in ?? () from /lib/libglib-2.0.so.0
#5  0x00007f618174f971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f617ec8992d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f61832f0760 (LWP 30575)):
[KCrash Handler]
#6  pthread_mutex_timedlock (mutex=0x7f616d276008, abstime=0x7fff8fecf380) at pthread_mutex_timedlock.c:40
#7  0x00007f6180d09e43 in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#8  0x00007f6180d05faa in KSharedDataCache::find (this=0x13f6470, key=..., destination=0x7fff8fecf5e0) at ../../kdecore/util/kshareddatacache.cpp:1355
#9  0x00007f6182cadd8c in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x13f1010, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:862
#10 0x00007f6182cb5f53 in KIconLoader::loadIcon (this=0x13edd80, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1218
#11 0x00007f6182caccf0 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x00007f617f931e55 in QIcon::pixmap (this=<value optimized out>, size=..., mode=QIcon::Disabled, state=2414671696) at image/qicon.cpp:676
#13 0x00007f617fbaf578 in QCommonStyle::drawControl (this=0x12736b0, element=<value optimized out>, opt=0x7fff8fed2f00, p=0x7fff8fed3ab0, widget=0x149bf80) at styles/qcommonstyle.cpp:1598
#14 0x00007f617fc4215e in QWindowsStyle::drawControl (this=0x12736b0, ce=QStyle::CE_ToolButtonLabel, opt=0x7fff8fed2f00, p=0x7fff8fed3ab0, widget=0x149bf80) at styles/qwindowsstyle.cpp:2560
#15 0x00007f617fc2f8c3 in QCleanlooksStyle::drawControl (this=<value optimized out>, element=QStyle::CE_ToolButtonLabel, option=0x7fff8fed2f00, painter=0x7fff8fed3ab0, widget=<value optimized out>) at styles/qcleanlooksstyle.cpp:2367
#16 0x00007f617fc0f3f9 in QGtkStyle::drawControl (this=0x12736b0, element=QStyle::CE_ToolButtonLabel, option=0x7fff8fed2f00, painter=0x7fff8fed3ab0, widget=0x149bf80) at styles/qgtkstyle.cpp:3029
#17 0x00007f617fc13c7c in QGtkStyle::drawComplexControl (this=0x12736b0, control=<value optimized out>, option=0x7fff8fed3a30, painter=0x7fff8fed3ab0, widget=0x149bf80) at styles/qgtkstyle.cpp:1637
#18 0x00007f617fd28cd8 in drawComplexControl (this=0x149bf80) at ../../include/QtGui/../../src/gui/painting/qstylepainter.h:94
#19 QToolButton::paintEvent (this=0x149bf80) at widgets/qtoolbutton.cpp:556
#20 0x00007f617f8d2c2e in QWidget::event (this=0x149bf80, event=0x7fff8fed42c0) at kernel/qwidget.cpp:8333
#21 0x00007f617f87cfdc in QApplicationPrivate::notify_helper (this=0x11f0a70, receiver=0x149bf80, e=0x7fff8fed42c0) at kernel/qapplication.cpp:4396
#22 0x00007f617f882aed in QApplication::notify (this=0x7fff8fed58c0, receiver=0x149bf80, e=0x7fff8fed42c0) at kernel/qapplication.cpp:4277
#23 0x00007f6182d00156 in KApplication::notify (this=0x7fff8fed58c0, receiver=0x149bf80, event=0x7fff8fed42c0) at ../../kdeui/kernel/kapplication.cpp:310
#24 0x00007f6180515cdc in QCoreApplication::notifyInternal (this=0x7fff8fed58c0, receiver=0x149bf80, event=0x7fff8fed42c0) at kernel/qcoreapplication.cpp:732
#25 0x00007f617f8d967d in sendSpontaneousEvent (this=0x16c16d0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x17147a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#26 QWidgetPrivate::drawWidget (this=0x16c16d0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x17147a0) at kernel/qwidget.cpp:5420
#27 0x00007f617f8da328 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=4, rgn=<value optimized out>, offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x17147a0) at kernel/qwidget.cpp:5627
#28 0x00007f617f8d93da in QWidgetPrivate::drawWidget (this=0x15ba4d0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x17147a0) at kernel/qwidget.cpp:5473
#29 0x00007f617faad408 in QWidgetBackingStore::sync (this=0x17147a0) at painting/qbackingstore.cpp:1328
#30 0x00007f617faad769 in QWidgetBackingStore::sync (this=0x17147a0, exposedWidget=0x15ae2a0, exposedRegion=...) at painting/qbackingstore.cpp:1130
#31 0x00007f617f8f74da in QETWidget::translatePaintEvent (this=0x15ae2a0, event=<value optimized out>) at kernel/qapplication_x11.cpp:5117
#32 0x00007f617f90404b in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff8fed54f0) at kernel/qapplication_x11.cpp:3436
#33 0x00007f617f9300e2 in x11EventSourceDispatch (s=0x11f4550, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#34 0x00007f617a4d8342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f617a4dc2a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f617a4dc45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f6180542193 in QEventDispatcherGlib::processEvents (this=0x11c0300, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f617f92fa4e in QGuiEventDispatcherGlib::processEvents (this=0x7f616d276008, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f6180514a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f6180514dec in QEventLoop::exec (this=0x7fff8fed5820, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f6180518ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00000000004a8dd5 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../kget/main.cpp:202

Possible duplicates by query: bug 254741.

Reported using DrKonqi
Comment 1 Matthias Fuchs 2010-11-24 00:00:08 UTC

*** This bug has been marked as a duplicate of bug 254741 ***