Bug 264677 - Multi crach after Bleachbit
Summary: Multi crach after Bleachbit
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-28 22:11 UTC by Ac17
Modified: 2011-01-29 13:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ac17 2011-01-28 22:11:26 UTC
Application: kmix (3.8)
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
This is the theerd (3) rapport about the crash, so you should find some simular crashraport. I've just run Bleachbit and should start firefox when it happens.

-- Backtrace:
Application: Kmix (kmix), signal: Bus error
[Current thread is 1 (Thread 0x7f144c9be780 (LWP 2218))]

Thread 5 (Thread 0x7f1434a53700 (LWP 2261)):
#0  __pthread_mutex_lock (mutex=0x1766728) at pthread_mutex_lock.c:56
#1  0x00007f14422588bf in g_main_context_prepare (context=0x1766720, priority=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2398
#2  0x00007f1442258e78 in g_main_context_iterate (context=0x1766720, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2760
#3  0x00007f14422597b5 in g_main_loop_run (loop=0x1766480) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2988
#4  0x00007f14396f93c4 in gdbus_shared_thread_func (data=<value optimized out>) at /build/buildd/glib2.0-2.26.1/gio/gdbusprivate.c:277
#5  0x00007f144227e7e4 in g_thread_create_proxy (data=0x1766800) at /build/buildd/glib2.0-2.26.1/glib/gthread.c:1897
#6  0x00007f144317d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#7  0x00007f144c2d592d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f1426dd0700 (LWP 2331)):
#0  0x00007f1448f42954 in QPair () at ../../include/QtCore/../../src/corelib/tools/qpair.h:60
#1  qMakePair<long, long> () at ../../include/QtCore/../../src/corelib/tools/qpair.h:104
#2  do_gettime () at tools/qelapsedtimer_unix.cpp:106
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#4  0x00007f144900f1fd in QTimerInfoList::updateCurrentTime (this=0x7f1426dcfac0) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007f144900f225 in QTimerInfoList::timerWait (this=0x7f1426dcfac0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007f144900d3dd in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f1426dcfbfc) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f144900d485 in timerSourcePrepare (source=0x7f1426dcfac0, timeout=0x7f1426dcfac0) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f1442258a11 in g_main_context_prepare (context=0x1b65020, priority=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2469
#9  0x00007f1442258e78 in g_main_context_iterate (context=0x1b65020, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2760
#10 0x00007f144225945c in g_main_context_iteration (context=0x1b65020, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#11 0x00007f144900d1e6 in QEventDispatcherGlib::processEvents (this=0x1b77280, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#12 0x00007f1448fdfa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#13 0x00007f1448fdfdec in QEventLoop::exec (this=0x7f1426dcfd90, flags=) at kernel/qeventloop.cpp:201
#14 0x00007f1448eea2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#15 0x00007f1448fbf5f8 in QInotifyFileSystemWatcherEngine::run (this=0x1b4f0e0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f1448eed27e in QThreadPrivate::start (arg=0x1b4f0e0) at thread/qthread_unix.cpp:266
#17 0x00007f144317d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#18 0x00007f144c2d592d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f14225ce700 (LWP 2350)):
#0  0x00007f144c2c9203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1442259009 in g_main_context_poll (context=0x1c75c10, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:3093
#2  g_main_context_iterate (context=0x1c75c10, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2775
#3  0x00007f144225945c in g_main_context_iteration (context=0x1c75c10, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#4  0x00007f144900d1e6 in QEventDispatcherGlib::processEvents (this=0x1c75ab0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f1448fdfa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f1448fdfdec in QEventLoop::exec (this=0x7f14225cdd90, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f1448eea2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f1448fbf5f8 in QInotifyFileSystemWatcherEngine::run (this=0x1c6f720) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f1448eed27e in QThreadPrivate::start (arg=0x1c6f720) at thread/qthread_unix.cpp:266
#10 0x00007f144317d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f144c2d592d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f1421dcd700 (LWP 2354)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f1421dcca90 in ?? ()
#2  0x00007fffeefff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f144c9be780 (LWP 2218)):
[KCrash Handler]
#6  0x00007f14497f744b in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#7  0x00007f14497f4863 in KSharedDataCache::clear (this=0x1a19800) at ../../kdecore/util/kshareddatacache.cpp:1491
#8  0x00007f144b28a1ca in Plasma::ThemePrivate::discardCache (this=0x19a38b0, caches=) at ../../plasma/theme.cpp:273
#9  0x00007f144b28a74b in Plasma::ThemePrivate::compositingChanged (this=0x19a38b0) at ../../plasma/theme.cpp:263
#10 0x00007f144b290d6c in Plasma::Theme::qt_metacall (this=0x19a37e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffeeedb4c0) at ./theme.moc:116
#11 0x00007f1448ff8b27 in QMetaObject::activate (sender=0x19a64a0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x2) at kernel/qobject.cpp:3280
#12 0x00007f144b8b64ad in KSelectionWatcher::Private::x11Event (this=<value optimized out>, ev_P=0x1a2d440) at ../../kdeui/util/kmanagerselection.cpp:395
#13 0x00007f144b84152e in publicx11Event (this=<value optimized out>, _event=0x7fffeeedbb90) at ../../kdeui/kernel/kapplication.cpp:916
#14 KApplication::x11EventFilter (this=<value optimized out>, _event=0x7fffeeedbb90) at ../../kdeui/kernel/kapplication.cpp:967
#15 0x00007f1449cb4751 in qt_x11EventFilter (ev=0x7fffeeedbb90) at kernel/qapplication_x11.cpp:408
#16 0x00007f1449cc44f1 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffeeedbb90) at kernel/qapplication_x11.cpp:3248
#17 0x00007f1449cf10e2 in x11EventSourceDispatch (s=0x16f8370, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#18 0x00007f1442255342 in g_main_dispatch (context=0x16f70b0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2149
#19 g_main_context_dispatch (context=0x16f70b0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2702
#20 0x00007f14422592a8 in g_main_context_iterate (context=0x16f70b0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2780
#21 0x00007f144225945c in g_main_context_iteration (context=0x16f70b0, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#22 0x00007f144900d193 in QEventDispatcherGlib::processEvents (this=0x16c44f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#23 0x00007f1449cf0a4e in QGuiEventDispatcherGlib::processEvents (this=0x7fffeeedb2b0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007f1448fdfa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#25 0x00007f1448fdfdec in QEventLoop::exec (this=0x7fffeeedbec0, flags=) at kernel/qeventloop.cpp:201
#26 0x00007f1448fe3ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#27 0x00007f144c5955ba in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kmix/apps/main.cpp:73
#28 0x00007f144c20dd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffeeedc478) at libc-start.c:226
#29 0x0000000000400669 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-29 13:22:14 UTC
[Comment from a bug triager]
This is a bug in kdelibs (in the shareddatacache component): bug 254741. Merging.
Thanks

*** This bug has been marked as a duplicate of bug 254741 ***