Bug 261960 - Multiple crashes after running BleachBit
Summary: Multiple crashes after running BleachBit
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kwallet (show other bugs)
Version: 0.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michael Leupold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-03 15:30 UTC by Arthur Marceaux dit Clément
Modified: 2011-01-04 00:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arthur Marceaux dit Clément 2011-01-03 15:30:40 UTC
Application: kwalletd (0.2)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I used BleachBit to clean my Kubuntu. Then, as I was shutting down the computer, KWin crashed, I wanted to send a bug report, but when I wanted to save my login informations in KdeWallet, it crashed too....
(sorry for the english, i'm french.)

The crash can be reproduced some of the time.

-- Backtrace:
Application: Service de Portefeuille de KDE (kwalletd), signal: Bus error
[KCrash Handler]
#6  pthread_mutex_timedlock (mutex=0x7f5f856d9008, abstime=0x7fff29cd22b0) at pthread_mutex_timedlock.c:40
#7  0x00007f5f8fad438a in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#8  0x00007f5f8fad1a9a in KSharedDataCache::find (this=0x19a7c80, key=..., destination=0x7fff29cd2530) at ../../kdecore/util/kshareddatacache.cpp:1378
#9  0x00007f5f9013f25c in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x199b150, key=..., data=..., path=<value optimized out>) at ../../kdeui/icons/kiconloader.cpp:867
#10 0x00007f5f90146961 in KIconLoader::loadIcon (this=0x19a59a0, _name=<value optimized out>, group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1230
#11 0x00007f5f9013d5e0 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x00007f5f8e6fce55 in QIcon::pixmap (this=<value optimized out>, size=..., mode=3813930959, state=4294967295) at image/qicon.cpp:676
#13 0x00007f5f9019da84 in KStyle::drawKStylePrimitive (this=0x1961740, widgetType=<value optimized out>, primitive=<value optimized out>, opt=<value optimized out>, r=..., pal=..., flags=..., p=0x7fff29cd4a90, widget=0x190c910, kOpt=0x7fff29cd3030) at ../../kdeui/kernel/kstyle.cpp:833
#14 0x00007f5f8635e4e2 in Oxygen::Style::drawKStylePrimitive (this=0x1961740, widgetType=KStyle::WT_PushButton, primitive=<value optimized out>, opt=<value optimized out>, r=..., palette=<value optimized out>, flags=) at ../../../kstyles/oxygen/oxygenstyle.cpp:1149
#15 0x00007f5f901a49b0 in KStyle::drawControl (this=0x1961740, element=<value optimized out>, option=0x7fff29cd3d60, p=<value optimized out>, widget=0x190c910) at ../../kdeui/kernel/kstyle.cpp:1453
#16 0x00007f5f86370afb in Oxygen::Style::drawControl (this=0x1961740, element=QStyle::CE_PushButtonLabel, option=0x7fff29cd3d60, p=0x7fff29cd4a90, widget=0x190c910) at ../../../kstyles/oxygen/oxygenstyle.cpp:1015
#17 0x00007f5f901a4d0b in KStyle::drawControl (this=0x1961740, element=<value optimized out>, option=0x7fff29cd4a30, p=<value optimized out>, widget=0x190c910) at ../../kdeui/kernel/kstyle.cpp:1358
#18 0x00007f5f86370afb in Oxygen::Style::drawControl (this=0x1961740, element=QStyle::CE_PushButton, option=0x7fff29cd4a30, p=0x7fff29cd4a90, widget=0x190c910) at ../../../kstyles/oxygen/oxygenstyle.cpp:1015
#19 0x00007f5f9027f835 in drawControl (this=0x190c910) at /usr/include/qt4/QtGui/qstylepainter.h:89
#20 KPushButton::paintEvent (this=0x190c910) at ../../kdeui/widgets/kpushbutton.cpp:376
#21 0x00007f5f8e69dc2e in QWidget::event (this=0x190c910, event=0x7fff29cd52a0) at kernel/qwidget.cpp:8333
#22 0x00007f5f8e647fdc in QApplicationPrivate::notify_helper (this=0x191e0e0, receiver=0x190c910, e=0x7fff29cd52a0) at kernel/qapplication.cpp:4396
#23 0x00007f5f8e64daed in QApplication::notify (this=0x7fff29cd8560, receiver=0x190c910, e=0x7fff29cd52a0) at kernel/qapplication.cpp:4277
#24 0x00007f5f90191576 in KApplication::notify (this=0x7fff29cd8560, receiver=0x190c910, event=0x7fff29cd52a0) at ../../kdeui/kernel/kapplication.cpp:310
#25 0x00007f5f8f2e0cdc in QCoreApplication::notifyInternal (this=0x7fff29cd8560, receiver=0x190c910, event=0x7fff29cd52a0) at kernel/qcoreapplication.cpp:732
#26 0x00007f5f8e6a467d in sendSpontaneousEvent (this=0x19c5930, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x1a124d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#27 QWidgetPrivate::drawWidget (this=0x19c5930, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x1a124d0) at kernel/qwidget.cpp:5420
#28 0x00007f5f8e6a5328 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x1a124d0) at kernel/qwidget.cpp:5627
#29 0x00007f5f8e6a5159 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=3, rgn=<value optimized out>, offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x1a124d0) at kernel/qwidget.cpp:5614
#30 0x00007f5f8e6a5159 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=4, rgn=<value optimized out>, offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x1a124d0) at kernel/qwidget.cpp:5614
#31 0x00007f5f8e6a5159 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=5, rgn=<value optimized out>, offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x1a124d0) at kernel/qwidget.cpp:5614
#32 0x00007f5f8e6a43da in QWidgetPrivate::drawWidget (this=0x19c4ef0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x1a124d0) at kernel/qwidget.cpp:5473
#33 0x00007f5f8e878408 in QWidgetBackingStore::sync (this=0x1a124d0) at painting/qbackingstore.cpp:1328
#34 0x00007f5f8e878769 in QWidgetBackingStore::sync (this=0x1a124d0, exposedWidget=0x19efd20, exposedRegion=...) at painting/qbackingstore.cpp:1130
#35 0x00007f5f8e6c24da in QETWidget::translatePaintEvent (this=0x19efd20, event=<value optimized out>) at kernel/qapplication_x11.cpp:5117
#36 0x00007f5f8e6cf04b in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff29cd6a40) at kernel/qapplication_x11.cpp:3436
#37 0x00007f5f8e6fb0e2 in x11EventSourceDispatch (s=0x19217e0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#38 0x00007f5f8aa2e342 in g_main_dispatch (context=0x1920920) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2149
#39 g_main_context_dispatch (context=0x1920920) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2702
#40 0x00007f5f8aa322a8 in g_main_context_iterate (context=0x1920920, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2780
#41 0x00007f5f8aa3245c in g_main_context_iteration (context=0x1920920, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#42 0x00007f5f8f30d193 in QEventDispatcherGlib::processEvents (this=0x18f5f90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#43 0x00007f5f8e6faa4e in QGuiEventDispatcherGlib::processEvents (this=0x7f5f856d9008, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007f5f8f2dfa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#45 0x00007f5f8f2dfdec in QEventLoop::exec (this=0x7fff29cd6d70, flags=) at kernel/qeventloop.cpp:201
#46 0x00007f5f8eb3c7de in QDialog::exec (this=0x19efd20) at dialogs/qdialog.cpp:552
#47 0x00007f5f90948402 in KWalletD::isAuthorizedApp (this=0x7fff29cd84b0, appid=..., wallet=..., w=25192764) at ../../kwalletd/kwalletd.cpp:607
#48 0x00007f5f90949173 in KWalletD::internalOpen (this=0x7fff29cd84b0, appid=..., wallet=..., isPath=false, w=<value optimized out>, modal=<value optimized out>, service=...) at ../../kwalletd/kwalletd.cpp:561
#49 0x00007f5f90949ef4 in KWalletD::doTransactionOpen (this=0x7fff29cd84b0, appid=..., wallet=<value optimized out>, isPath=207, wId=25192764, modal=<value optimized out>, service=...) at ../../kwalletd/kwalletd.cpp:397
#50 0x00007f5f9094aef6 in KWalletD::processTransactions (this=0x7fff29cd84b0) at ../../kwalletd/kwalletd.cpp:183
#51 0x00007f5f9094b234 in KWalletD::qt_metacall (this=0x7fff29cd84b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x197d160) at ./kwalletd.moc:288
#52 0x00007f5f8f2f2bde in QObject::event (this=0x7fff29cd84b0, e=0x7f5f856d9008) at kernel/qobject.cpp:1219
#53 0x00007f5f8e647fdc in QApplicationPrivate::notify_helper (this=0x191e0e0, receiver=0x7fff29cd84b0, e=0x1919540) at kernel/qapplication.cpp:4396
#54 0x00007f5f8e64daed in QApplication::notify (this=0x7fff29cd8560, receiver=0x7fff29cd84b0, e=0x1919540) at kernel/qapplication.cpp:4277
#55 0x00007f5f90191576 in KApplication::notify (this=0x7fff29cd8560, receiver=0x7fff29cd84b0, event=0x1919540) at ../../kdeui/kernel/kapplication.cpp:310
#56 0x00007f5f8f2e0cdc in QCoreApplication::notifyInternal (this=0x7fff29cd8560, receiver=0x7fff29cd84b0, event=0x1919540) at kernel/qcoreapplication.cpp:732
#57 0x00007f5f8f2e3c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x18f68a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x18f68a0) at kernel/qcoreapplication.cpp:1373
#59 0x00007f5f8f30d653 in sendPostedEvents (s=0x19215c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#60 postEventSourceDispatch (s=0x19215c0) at kernel/qeventdispatcher_glib.cpp:277
#61 0x00007f5f8aa2e342 in g_main_dispatch (context=0x1920920) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2149
#62 g_main_context_dispatch (context=0x1920920) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2702
#63 0x00007f5f8aa322a8 in g_main_context_iterate (context=0x1920920, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2780
#64 0x00007f5f8aa3245c in g_main_context_iteration (context=0x1920920, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#65 0x00007f5f8f30d193 in QEventDispatcherGlib::processEvents (this=0x18f5f90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#66 0x00007f5f8e6faa4e in QGuiEventDispatcherGlib::processEvents (this=0x7f5f856d9008, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#67 0x00007f5f8f2dfa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#68 0x00007f5f8f2dfdec in QEventLoop::exec (this=0x7fff29cd8400, flags=) at kernel/qeventloop.cpp:201
#69 0x00007f5f8f2e3ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#70 0x00007f5f90940872 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwalletd/main.cpp:68
#71 0x00007f5f905cfd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff29cd8888) at libc-start.c:226
#72 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 254741.

Possible duplicates by query: bug 254741.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-01-04 00:02:13 UTC

*** This bug has been marked as a duplicate of bug 254741 ***